FIX: Error message when you use an IEEE 1394-based scanner on a computer that is running Windows XP 64-bit, Windows Server 2003, or Windows Vista: 0x0000000A or 0x000000BE

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Article ID: 922498 - View products that this article applies to.
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SYMPTOMS

When you use an IEEE 1394-based scanner and run a 32-bit scanning program on a computer that is running Microsoft Windows XP 64-bit, Microsoft Windows Server 2003, you receive an error message on a blue screen that resembles one of the following:
0x0000000A: IRQL_NOT_LESS_OR_EQUAL

0x000000BE: ATTEMPTED_WRITE_TO_READONLY_MEMORY
This problem occurs when the scanning program calls the DeviceIoControl function to send a IOCTL_SCSISCAN_CMD control code to the kernel mode driver.

In Windows Vista, you may not experience the blue screen. When your scanning program calls the DeviceIoControl function to send an IOCTL_SCSISCAN_CMD control code to the kernel mode driver in Windows Vista, this call may not be completed successfully, and your scanning program does not work as expected. The exact symptom that is observed in the user interface depends on how your scanning software works when the DeviceIoControl function fails.

Note If your scanning program does not work correctly, it may be related to various causes.You have to contact the software vendor first to check whether you are encountering the exact problem that is described in this article.

CAUSE

This problem occurs because of an issue with the Scsiscan.sys file.

RESOLUTION

Windows Vista service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Windows Vista hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart your computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys6.0.6000.2071214,33631-Oct-200702:32x86
Serscan.sys6.0.6000.207129,21631-Oct-200702:33x86
Usbscan.sys6.0.6000.2071235,32831-Oct-200702:32x86
Wiafbdrv.dll6.0.6000.2071289,08831-Oct-200703:59x86
Wsdscan.sys6.0.6000.2071219,96831-Oct-200702:33x86

Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys6.0.6000.2071217,92031-Oct-200703:18x64
Serscan.sys6.0.6000.2071212,28831-Oct-200703:18x64
Usbscan.sys6.0.6000.2071241,47231-Oct-200703:18x64
Wiafbdrv.dll6.0.6000.20712107,00831-Oct-200704:52x64
Wsdscan.sys6.0.6000.2071224,06431-Oct-200703:18x64

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Windows Server 2003 SP1 installed to apply this hotfix.
Restart Requirement
You must restart your computer after you apply this hotfix.
Hotfix Replacement Information
This hotfix does not replace any other hotfixes.
File Information
The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys5.2.3790.274013,31205-Jul-200609:36x86

Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys5.2.3790.274039,42404-Jul-200621:27IA-64

Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys5.2.3790.274019,96804-Jul-200621:24x64
Note If you are running Windows XP x64 Editions, download the package for Windows Server 2003 x64. This version will install on Windows XP x64 Editions.

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Scsiscan.sys5.2.3790.274019,96804-Jul-200621:24x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 922498 - Last Review: October 9, 2011 - Revision: 5.0
APPLIES TO
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows XP Professional x64 Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbbug kbfix kbHotfixServer kbqfe KB922498

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