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The name of a public folder appears as a question mark character when you view Diagnostic Logging event messages in Exchange Server 2003

Article ID:922622
Last Review:October 25, 2007
Revision:2.3
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SYMPTOMS

You configure the Diagnostic Logging feature to monitor the Microsoft Exchange Server Information Store Public Folders service (MSExchangeIS\Public) in Microsoft Exchange Server 2003. When you view Diagnostic Logging event messages, the name of a public folder appears as a question mark character (?).

This problem occurs when you view the following event messages in Event Viewer:

1034
The rule (1-7A42) with sequence number 100 is being ignored because it is disabled.
The public folder is ????? on database "First Storage Group\Public Folder Store (SERVER)".
For more information, click http://www.microsoft.com/contentredirect.asp.

1036
The rule (1-7A42) with sequence number 100 is being ignored because it is in an error state.
The public folder is ????? on database "First Storage Group\Public Folder Store (SERVER)".
For more information, click http://www.microsoft.com/contentredirect.asp.

1038
Triggering the rule (1-7A42) with sequence number 100.
The public folder is ????? on database "First Storage Group\Public Folder Store (SERVER)".
For more information, click http://www.microsoft.com/contentredirect.asp.

1041
The rule "1-7A42" with the sequence number 100 was disabled due to the error 1405 that was encountered while applying the rule. Subject of the message that caused this error is "Subject_Of_Error_Message"
Problem was found in the function "EcDoPublicFolderRules". The public folder is "?????" on database "First Storage Group\Public Folder Store (SERVER)".
For more information, click http://www.microsoft.com/contentredirect.asp.

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CAUSE

This problem occurs when the name of the public folder contains double-byte character set (DBCS) characters.

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Microsoft Exchange Server 2003 Service Pack 1 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File NameTime DateSizeFile Version
Mdbmsg.dll01:40:2705-Aug-20063,269,6326.5.7234.10
Redir.asp20:50:3229-Jan-20063,3040.0.0.0
Store.exe02:17:2505-Aug-20065,200,8966.5.7234.10

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information about a hotfix to resolve this problem on a computer that has Microsoft Exchange Server 2003 Service Pack 2 installed, click the following article number to view the article in the Microsoft Knowledge Base:
917256 (http://support.microsoft.com/kb/917256/) A DBCS character may appear as a question mark in event messages in Exchange Server 2003
For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates
817903 (http://support.microsoft.com/kb/817903/) New naming schema for Exchange Server software update packages

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APPLIES TO
Microsoft Exchange Server 2003 Standard Edition
Microsoft Exchange Server 2003 Enterprise Edition

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Keywords: 
kbautohotfix kbhotfixserver kbqfe kbfix kbbug kbpubtypekc KB922622

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