SQL Server 2005 Reporting Services에서 보고서 관리자 도구를 열려고 하면 오류 메시지: "HTTP 상태 400 요청이 실패했습니다: 잘못된 요청"또는"보고서 서버에 연결하지 못했습니다"

기술 자료 번역 기술 자료 번역
기술 자료: 922656 - 이 문서가 적용되는 제품 보기.
# 버그: 426887 (SQLBUDT)
모두 확대 | 모두 축소

이 페이지에서

현상

Microsoft SQL Server 2005 Reporting Services에서 보고서 서버 사이트가 성공적으로 열 수 있습니다. 그러나 보고서 관리자 도구를 열려고 하면 다음 오류 메시지 중 하나가 나타납니다.
오류 메시지 1
HTTP 상태 400 요청에 실패했습니다: 잘못된 요청.
오류 메시지 2
보고서 서버에 연결하지 못했습니다. 연결 정보를 확인하고 현재 사용 중인 보고서 서버의 호환성을 검사하십시오.
보고서 서버 사이트 로컬 호스트 (127.0.0.1) IP 주소를 다른 IP 주소를 할당할 때 이 문제가 발생합니다.

원인

보고서 서버 사이트 잘못된 서버 URL이 보고서 관리자 도구를 사용하기 때문에 이 문제가 발생합니다. 파일 RSWebApplication.config ReportServerUrl 태그에 대한 보고서 관리자 도구를 검색합니다 보고서 서버 사이트의 URL이 지정됩니다. 이 태그는 비워 두면 기본적으로 서버 URL로 "Localhost을" 보고서 관리자 도구를 사용합니다.

해결 과정

이 문제를 해결하려면 다음과 같이 하십시오.
  1. 파일 RSWebApplication.config 파일을 텍스트 편집기에서 엽니다. RSWebApplication.config 파일은 다음 폴더에 있습니다.
    SQLInstall\ MSSQL.X \Reporting Services\ReportManager
    참고SQLInstall SQL Server 2005 설치되어 있는 위치를 나타냅니다. 인스턴스를 ID의 SQL Server 2005 보고서 Services MSSQL.X 나타냅니다.
  2. ReportServerVirtualDirectory 태그 항목을 삭제하십시오.

    참고ReportServerVirtualDirectory 태그를 삭제하여 합니다지 않습니다. 경우에만 ReportServerVirtualDirectory 태그 값을 제거하십시오.
  3. ReportServerUrl 태그 보고서 서버 정규화된 URL을 입력하십시오. 예를 들어, 다음 형식을 사용합니다:
    <ReportServerUrl>http://<FullyQualifiedURL>:<PortNumber>/<VirtualDirectoryOfReportServer></ReportServerUrl>
    <ReportServerVirtualDirectory></ReportServerVirtualDirectory>
  4. RSWebApplication.config 파일을 저장하고 텍스트 편집기를 닫습니다.

현재 상태

Microsoft는 "본 문서의 정보는 다음의 제품에 적용됩니다." 절에 나열된 Microsoft 제품에서 이 문제를 확인했습니다.

추가 정보

문제를 재현하는 방법

  1. 인터넷 서비스 관리자를 시작하십시오.
  2. 웹 사이트 를 확장한 기본 웹 사이트 를 마우스 오른쪽 단추로 클릭한 다음 속성 을 클릭하십시오.
  3. 속성 대화 상자의 IP 주소 상자에 정적 IP 주소를 입력하십시오.
  4. 속성 대화 상자를 닫으려면 확인 을 클릭하십시오.
  5. 보고서 관리자 도구를 연결하십시오.

속성

기술 자료: 922656 - 마지막 검토: 2006년 7월 28일 금요일 - 수정: 1.2
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft SQL Server 2005 Reporting Services
키워드:?
kbmt kbsql2005rs kbexpertiseadvanced kbtshoot kbprb KB922656 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com