FIX: Установка установки, программа не отвечает после развертывания приложения ClickOnce, через Интернет или через интрасеть и пользователь нажимает кнопку, или на опубликованной страницы в обозревателе Internet Explorer

Переводы статьи Переводы статьи
Код статьи: 922774 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

При развертывании приложения, использующего технологию ClickOnce, через Интернет или по локальной сети, пользователь на клиентском компьютере может щелкнутьУстановкаилиЗапуститьна опубликованной странице. Тем не менее программа установки не отвечает. Кроме того пользователь не получает сообщение об ошибке. При попытке установить приложение ClickOnce с веб-сервера, программа установки выполняется как ожидалось.

Данная проблема возникает при использовании версии Internet Explorer, которые перечислены в разделе «Данная статья применима к».

Причина

Эта проблема возникает из-за параметров безопасности обозревателя Internet Explorer дляЗапуск компонентов, не подписан с помощью Authenticodeпараметр в группеКомпоненты к платформе платформы .NETимеет значениеОтключенилиПриглашения. Эти параметры не позволяют установить приложение ClickOnce через Интернет или по локальной сети, даже если он подписан компонента.

Решение

Для решения этой проблемы загрузите и установите Microsoft .NET Framework 3.5 с пакетом обновления 1 (SP1) или более поздней версии. Чтобы получить .NET Framework 3.5 SP1, посетите следующий веб-узел корпорации Майкрософт:
http://www.Microsoft.com/downloads/details.aspx?FamilyId=ab99342f-5d1a-413d-8319-81da479ab0d7

Временное решение

ВажноЭтих действий может увеличить риск безопасности. и повышает степень уязвимости компьютера или сети перед возможной атакой злоумышленника или проникновением вирусов и других потенциально опасных программ.. Чтобы используемые приложения функционировали надлежащим образом, рекомендуется следовать указаниям, приведенным в данной статье.. Однако предварительно необходимо оценить влияние этих действий на безопасность существующего окружения.. В случае использования описанного способа устранения неполадки примите все доступные меры для дополнительного обеспечения безопасности системы.. Корпорация Майкрософт рекомендует использовать этот процесс, только если действительно требуется процесса.

ПримечаниеСледующие решения следует использовать только при установке .NET Framework 3.5 SP1 или более поздней версии практику.

Для временного решения этой проблемы установитеЗапуск компонентов, не подписан с помощью Authenticodeпараметр в группеКомпоненты к платформе платформы .NETдляВключенав обозревателе Internet Explorer. Чтобы сделать это, выполните следующие действия:
  1. Запустите Internet Explorer.
  2. НаСредстваменю, нажмите кнопкуСвойства обозревателя.
  3. НаБезопасностьвкладки, щелкнитеПользовательский уровень.
  4. ВПараметрыполе, нажмите кнопкуВключитьв группеЗапуск компонентов, не подписан с помощью Authenticode.
  5. Нажмите кнопкуОК, а затем нажмите кнопкуДаЧтобы проверить изменение параметра.
  6. Нажмите кнопкуОКЗакрытьСвойства обозревателядиалоговое окно.

Дополнительная информация

При развертывании приложения ClickOnce на узле интрасети, программа установки на зависит от параметров зоны безопасности интрасети. В случае развертывания приложения на веб-узла, настройки программы зависит от параметров зоны безопасности Интернета.

Ссылки

Для получения дополнительных сведений о приложениях ClickOnce посетите следующий веб-узел Microsoft Developer Network (MSDN):
.aspx HTTP://msdn2.Microsoft.com/en-us/library/t71a733d (vs.80)
Для получения дополнительных сведений об использовании зон безопасности, щелкните следующий номер статьи базы знаний Майкрософт:
174360Использование зон безопасности обозревателя Internet Explorer

Свойства

Код статьи: 922774 - Последний отзыв: 28 сентября 2011 г. - Revision: 3.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft .NET Framework 2.0
  • Windows Internet Explorer 8
  • Windows Internet Explorer 8 on Windows Server
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows XP
  • Windows Internet Explorer 7 for Windows Server 2003
  • Microsoft Internet Explorer 6.0
Ключевые слова: 
kbprb kbexpertiseinter kbbug kbtshoot kbmt KB922774 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:922774

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com