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Stop error message when a Terminal Services client logs off from a session on a server that is running Windows Server 2003 with Service Pack 1: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

Article ID:923035
Last Review:July 9, 2008
Revision:3.0
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SYMPTOMS

When a client computer logs off from a Terminal Services session, you may receive a Stop error message on the terminal server that resembles the following:
Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)
This problem occurs when the terminal server is running Microsoft Windows Server 2003 with Service Pack 1. When this problem occurs, other client computers that are logged on to the terminal server may stop responding.

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CAUSE

This problem is caused by a session pool memory leak in the Win32k.sys file.

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RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 (http://support.microsoft.com/kb/889100/) How to obtain the latest service pack for Windows Server 2003

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 installed. For more information about how to obtain the latest service pack for Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
889100 (http://support.microsoft.com/kb/889100/) How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces the following hotfixes:
901150 (http://support.microsoft.com/kb/901150/) You may receive a “Stop 0x000000ab” error message when you log off a Terminal Services session on a Windows Server 2003 S901150-based Terminal Server
907242 (http://support.microsoft.com/kb/907242/) You receive a "Stop 0x000000ab" error message when you log off from a Terminal Services session on a Windows Server 2003 S907242-based terminal server
910362 (http://support.microsoft.com/kb/910362/) Error message when you log off from a Terminal Services session on a Windows Server 2003 Service Pack 1-based terminal server: "Stop 0x000000AB SESSION_HAS_VALID_POOL_ON_EXIT"
918673 (http://support.microsoft.com/kb/918673/) You receive a "Stop 0x000000ab" error message when a Terminal Services client computer logs off from a Terminal Services session on a Windows Server 2003 S918673-based Terminal Services computer

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions

File nameFile versionFile sizeDateTimePlatformSP requirement
Gdi32.dll5.2.3790.2766282,11208-Aug-200613:04x86SP1
Win32k.sys5.2.3790.27661,850,88006-Aug-200616:28x86SP1

Windows Server 2003, x64-based versions

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2767610,30407-Aug-200622:23x64SP1Not Applicable
Win32k.sys5.2.3790.27674,529,66407-Aug-200622:23x64SP1Not Applicable
Wgdi32.dll5.2.3790.2766285,18407-Aug-200622:23x86SP1WOW

Windows Server 2003, Itanium-based versions

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2767906,24007-Aug-200622:23IA-64SP1Not Applicable
Win32k.sys5.2.3790.27675,546,49607-Aug-200622:23IA-64SP1Not Applicable
Wgdi32.dll5.2.3790.2766285,18407-Aug-200622:23x86SP1WOW

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MORE INFORMATION

Other problems may cause similar symptoms. For more information about the "Stop 0x000000AB" error message, click the following article numbers to view the articles in the Microsoft Knowledge Base:
924806 (http://support.microsoft.com/kb/924806/) Stop error message when a client logs off a Terminal Services session on a server that is running Windows Server 2003 with Service Pack 1: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"
925919 (http://support.microsoft.com/kb/925919/) Stop error message when a client computer logs off from a Terminal Services session on a server that is running Windows Server 2003 with S925919 or with SP2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"
928942 (http://support.microsoft.com/kb/928942/) Error message when you log off a Terminal Services session on Windows Server 2003 Terminal Server with Service Pack 1 or with Service Pack 2: "Stop 0x000000AB"
931282 (http://support.microsoft.com/kb/931282/) Stop error message when a client computer logs off from a Terminal Services session on a server that is running Windows Server 2003 with S931282 or with SP2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"
939442 (http://support.microsoft.com/kb/939442/) Stop error message when a client logs off from a Terminal Services session on a Windows Server 2003-based terminal server: "Stop 0x000000ab"
944916 (http://support.microsoft.com/kb/944916/) Stop error message when a client logs off from a Terminal Services session on a server that is running Windows Server 2003 with S944916 or Windows Server 2003 with SP2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"
946068 (http://support.microsoft.com/kb/946068/) Stop error message on a terminal server that is running Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"
951749 (http://support.microsoft.com/kb/951749/) Stop error message on a terminal server that is running Windows Server 2003 S951749 or Windows Server 2003 SP2: "Stop 0x000000AB (SESSION_HAS_VALID_POOL_ON_EXIT)"

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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APPLIES TO
Microsoft Windows Server 2003 Service Pack 1, when used with:
  Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  Microsoft Windows Server 2003, Web Edition
  Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Microsoft Windows Server 2003, Standard x64 Edition
Microsoft Windows Server 2003, Enterprise x64 Edition

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Keywords: 
kbautohotfix kbwinserv2003sp2fix kbwinserv2003presp2fix kbfix kbqfe kbhotfixserver KB923035

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