Nelze otevřít soubory, které mají rozšíření těchto as.exe,.com and.lnk v počítači se systémem Windows XP

Překlady článku Překlady článku
ID článku: 923077 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při pokusu o otevření souborů s příponami .exe, .com a LNK v počítači se systémem Microsoft Windows XP nelze otevřít soubory. Alternativně Otevřít v programu Zobrazí se dialogové okno.

K tomuto problému dochází i v případě, že jsou splněny následující podmínky:
  • Je počítač v nouzovém režimu.
  • Tato rozšíření jsou výchozí položky registru.

Příčina

K tomuto problému dochází, pokud jeden nebo více z následujících podmínek:
  • Hodnoty registru, které jsou spojeny s příponou názvu souboru jsou poškozeny nebo chybí hodnoty.
  • Počítač je napaden virem.

Řešení

Důležité Tento oddíl, metoda nebo úkol obsahuje kroky, které popisují úpravu registru. Při nesprávné úpravě registru však mohou nastat závažné problémy. Proto postupujte přesně podle následujících kroků. Pro zvýšení ochrany proveďte před úpravami zálohu registru. Pokud pak dojde k potížím, budete moci registr obnovit. Další informace o zálohování a obnovení registru získáte v článku znalostní báze Microsoft Knowledge Base:
322756 Postup zálohování a obnovení registru v systému Windows
Chcete-li vyřešit tento problém, postupujte takto:
  1. Restartování počítače problém v nouzovém režimu a potom zálohovat registr.
  2. Klepněte na tlačítko Start, klepněte na tlačítko Spustit, typ příkaz regedit.com %Windir%\regedit.exe /c kopírovánía potom klepněte na tlačítko OK.
  3. Klepněte na tlačítko Start, klepněte na tlačítko Spustit, typ regedita potom klepněte na tlačítko OK.
  4. V programu Editor registru porovnejte s podklíče registru do funkčního počítače přípony názvů souborů, které nelze otevřít následující podklíče registru:
    • HKEY_CLASSES_ROOT\.<file_name_extension>
    • HKEY_CLASSES_ROOT\<file_name_extension>file
    • HKEY_CLASSES_ROOT\.<file_name_extension>\<Sub_Folder>
    Pokud nelze otevřít soubory .com, porovnejte s následující podklíče registru pro pracovní počítač následující podklíče registru:
    • HKEY_CLASSES_ROOT\.com
    • HKEY_CLASSES_ROOT\comfile
    • HKEY_CLASSES_ROOT\.com\PersistentHandler
  5. Pokud zjistíte případný rozdíl mezi položky registru v počítači problém a pracovní počítače, obnovení výchozích hodnot poškozené položky. Postupujte následujícím způsobem
    1. Vyberte položku registru, který chcete změnit.
    2. Na Upravit nabídky, klepněte na tlačítko Upravit.
    3. V Upravit řetězec Dialogové okno zadejte hodnotu, která můžete najít v počítači práci Údaj hodnoty textové pole a potom klepněte na tlačítko OK.
Pokud potíže potrvají, postupujte takto:
  1. Poznamenejte si číslo CLSID, který se nachází v
    HKEY_CLASSES_ROOT\.com\PersistentHandler
    podklíč registru.

    Poznámka: Identifikátor CLSID se skládá z dlouhé sadu čísel, která je uzavřena ve složených závorkách ({}).
  2. Identifikátory CLSID s identifikátorem CLSID, který se nachází v porovnání
    HKEY_CLASSES_ROOT\CLSID\<CLSID_number>
    podklíč registru. Pokud tyto identifikátory CLSID liší, obnovte výchozí hodnoty poškozené položky.

Další informace

Zvažte následující scénář. Nelze otevřít soubory s příponou .com po instalaci softwaru jiných výrobců. V tomto scénáři je aktualizována registru počítače následující podklíče registru Chcete-li vyřešit tento problém:
  • HKEY_CLASSES_ROOT\.com
  • HKEY_CLASSES_ROOT\comfile
  • HKEY_CLASSES_ROOT\CLSID\{098f2470-bae0-11cd-b579-08002b30bfeb}
Další informace o tom, jak zobrazit přípony názvů souborů, klepněte na následující číslo článku databáze Microsoft Knowledge Base:
865219Zobrazení nebo skrytí přípon názvů souborů v Průzkumníkovi Windows

Vlastnosti

ID článku: 923077 - Poslední aktualizace: 9. dubna 2013 - Revize: 6.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Klíčová slova: 
kbtshoot kbprb kbmt KB923077 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku: 923077

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com