No se puede abrir los archivos que tienen las extensiones de este tipo as.exe,.com, and.lnk en un equipo basado en Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 923077 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Al intentar abrir archivos que tienen extensiones como .exe, .com y .lnk en un equipo basado en Microsoft Windows XP, no puede abrir los archivos. Como alternativa, aparecerá el cuadro de diálogo Abrir con .

Este problema se produce incluso si las siguientes condiciones son verdaderas:
  • El equipo está en modo a prueba de errores.
  • Las extensiones tienen las entradas del registro de forma predeterminada.

Causa

Este problema se produce cuando uno o más de las siguientes condiciones son verdaderas:
  • Los valores del registro asociados a la extensión de nombre de archivo están dañados o faltan los valores.
  • El equipo está infectado con un virus.

Solución

Importante Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, copia de seguridad del registro antes de modificarlo. Luego puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows
Para resolver este problema, siga estos pasos:
  1. Reinicie el equipo con problemas en modo seguro y, a continuación, copia de seguridad del registro.
  2. Haga clic en Inicio, haga clic en Ejecutar, tipo comando /c copy %Windir%\regedit.exe regedit.comy, a continuación, haga clic en Aceptar.
  3. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedity, a continuación, haga clic en Aceptar.
  4. En el Editor del registro, compare las siguientes subclaves del registro con las subclaves del registro de un equipo de trabajo para las extensiones de nombre de archivo que no se abre:
    • HKEY_CLASSES_ROOT\.<file_name_extension>
    • HKEY_CLASSES_ROOT\<file_name_extension>file
    • HKEY_CLASSES_ROOT\.<file_name_extension>\<Sub_Folder>
    Si no puede abrir los archivos .com, compare las siguientes subclaves del registro con las subclaves del registro del equipo de trabajo:
    • HKEY_CLASSES_ROOT\.com
    • HKEY_CLASSES_ROOT\comfile
    • HKEY_CLASSES_ROOT\.com\PersistentHandler
  5. Si encuentra alguna diferencia entre las entradas del registro en el equipo con problemas y en el equipo de trabajo, restaurar los valores predeterminados de las entradas dañadas. Para ello, siga estos pasos:
    1. Seleccione la entrada de registro que desea cambiar.
    2. En el menú Edición , haga clic en Modificar.
    3. En el cuadro de diálogo Editar cadena , escriba el valor que se encuentra en el equipo de trabajo en el cuadro de texto información del valor y, a continuación, haga clic en Aceptar.
Si el problema persiste, siga estos pasos:
  1. Anote el número CLSID que se encuentra en el
    HKEY_CLASSES_ROOT\.com\PersistentHandler
    subclave del registro.

    Nota El CLSID consta de una serie de números que se encierra entre llaves ({}).
  2. Comparar los CLSID con el CLSID que se encuentra en el
    HKEY_CLASSES_ROOT\CLSID\<CLSID_number>
    subclave del registro. Si difieren estos CLSID, restaurar los valores predeterminados de las entradas dañadas.

Más información

Tenga en cuenta la situación siguiente. No se puede abrir archivos que tienen la extensión .com después de instalar el software de otros fabricantes.En este escenario, el registro del equipo se actualiza con las siguientes subclaves del registro para resolver este problema:
  • HKEY_CLASSES_ROOT\.com
  • HKEY_CLASSES_ROOT\comfile
  • HKEY_CLASSES_ROOT\CLSID\{098f2470-bae0-11cd-b579-08002b30bfeb}
Para obtener información adicional acerca de cómo mostrar las extensiones de nombre de archivo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
865219 Cómo mostrar u ocultar extensiones de nombre de archivo en el Explorador de Windows

Propiedades

Id. de artículo: 923077 - Última revisión: jueves, 06 de febrero de 2014 - Versión: 7.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Palabras clave: 
kbtshoot kbprb kbmt KB923077 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 923077

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com