No puede utilizar el método POST para publicar datos en un servidor Web en un equipo basado en Windows XP SP2

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Id. de artículo: 923155 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Asegúrese de que copia el registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
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Síntomas

Tenga en cuenta la situación siguiente. En un equipo basado en Windows XP SP2, utiliza Microsoft Internet Explorer 6 para abrir una página Web. Intenta utilizar el método POST para enviar datos al servidor Web que aloja la página Web. En este escenario, no puede registrar los datos en el servidor Web. Este problema se produce si el servidor Web utiliza el protocolo Kerberos versión 5 autenticación para mejorar la seguridad.

Nota Este problema se produce cuando se utiliza el método POST para la primera vez. Si hace clic en el botón Atrás para volver a la página Web y, a continuación, registrar los datos nuevo, puede registrar correctamente los datos en el servidor Web.

Causa

Este problema se produce debido a un defecto en el archivo WinINet.dll. Cuando intenta publicar datos en el servidor Web en Internet Explorer 6, el archivo WinINet.dll obtiene nuevas credenciales y, a continuación, el archivo WinINet.dll libera el contexto de seguridad original. A continuación, el archivo WinINet.dll llama a la función InitializeSecurityContext para iniciar el contexto de seguridad del cliente salientes.

En este escenario, el archivo WinINet.dll no comprobará el si el esquema de autenticación del servidor Web es la autenticación NTLM o Kerberos. Debido a de defecto, el archivo WinINet.dll espera que el servidor Web utiliza el esquema de autenticación NTLM. Por tanto, la autenticación falla y no se puede publicar datos en el servidor Web.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar la revisión, debe instalarse Windows XP Service Pack 2 (SP2) en el equipo.

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ninguna otro publicada previamente.

Información del registro

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Para habilitar la revisión, siga estos pasos:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit y, a continuación, presione ENTRAR.
  2. Busque la siguiente subclave del registro y a continuación, haga clic en él:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  4. Escriba el nombre de subclave siguiente y, a continuación, presione ENTRAR:
    FEATURE_FIX_KERBEROS_POST_KB923155
  5. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  6. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  7. En el menú Edición , haga clic en Modificar .
  8. En el cuadro datos del valor , escriba 1 y, a continuación, haga clic en Aceptar .
  9. Editor de registro de salida.
Nota Para deshabilitar la revisión, escriba 0 en el cuadro datos del valor en el paso 8.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP con SP2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Wininet.dll6.0.2900.2992664,57608-Septiembre de 200612: 51x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la función InitializeSecurityContext , visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa375506.aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 923155 - Última revisión: martes, 11 de septiembre de 2007 - Versión: 1.3
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows XP Professional SP2
Palabras clave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB923155 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 923155

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