Você não pode usar o método POST para postar dados em um servidor Web em um computador com Windows XP SP2

Traduções deste artigo Traduções deste artigo
ID do artigo: 923155 - Exibir os produtos aos quais esse artigo se aplica.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário. Em um computador baseado no Windows XP SP2, você usar o Microsoft Internet Explorer 6 para abrir uma página da Web. Você tenta usar o método POST para postar dados para o servidor Web que hospeda a página da Web. Nesse cenário, você não pode lançar os dados para o servidor Web. Esse problema ocorre se o servidor Web usa o protocolo Kerberos versão 5 autenticação para melhorar a segurança.

Observação Esse problema ocorre apenas quando você usa o método POST pela primeira vez. Se você clicar no botão Voltar para retornar à página da Web e, em seguida, você lançar os dados novamente, você pode lançar os dados para o servidor Web com êxito.

Causa

Esse problema ocorre devido a um defeito no arquivo WinINet.dll. Quando você tenta postar dados para o servidor Web no Internet Explorer 6, o arquivo WinINet.dll obtém novas credenciais e, em seguida, o arquivo WinINet.dll libera o contexto de segurança original. Em seguida, o arquivo WinINet.dll chama a função InitializeSecurityContext para iniciar o contexto de segurança do cliente a saída.

Nesse cenário, o arquivo WinINet.dll não verificará se o esquema de autenticação do servidor Web é a autenticação NTLM ou autenticação Kerberos. Devido a defeito, o arquivo WinINet.dll espera que o servidor Web usa o esquema de autenticação NTLM. Portanto, a autenticação falhar, e você não pode postar dados para o servidor Web.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para aplicar o hotfix, o Windows XP Service Pack 2 (SP2) deve ser instalado no computador.

Requisitos de reinicialização

Você precisa reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes lançados anteriormente.

Informações do registro

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Para habilitar o hotfix, siga estas etapas:
  1. Clique em Iniciar , clique em Executar , digite regedit e pressione ENTER.
  2. Localize a seguinte subchave do Registro e em seguida, clique em:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  3. No menu Editar , aponte para novo e, em seguida, clique em chave .
  4. Digite o seguinte nome subchave e pressione ENTER:
    FEATURE_FIX_KERBEROS_POST_KB923155
  5. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  6. Digite iexplore.exe e, em seguida, pressione ENTER.
  7. No menu Editar , clique em Modificar .
  8. Na caixa dados do valor , digite 1 e, em seguida, clique em OK .
  9. Feche o Editor do Registro.
Observação Para desativar o hotfix, digite 0 na caixa dados do valor na etapa 8.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP com SP2, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Wininet.dll6.0.2900.2992664,57608 De setembro de 200612: 51x 86

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a função InitializeSecurityContext , visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/aa375506.aspx
Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 923155 - Última revisão: terça-feira, 11 de setembro de 2007 - Revisão: 1.3
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition SP2
  • Microsoft Windows XP Professional SP2
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB923155 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 923155

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com