Article ID: 923157 - Last Review: November 24, 2010 - Revision: 2.0

After you install Windows Live OneCare, you can no longer share or access shared files, folders, and printers

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.



Windows Live OneCare is no longer available for sale

Existing subscribers will continue to be supported throughout the term of their subscriptions. Existing subscribers can reinstall by following the steps to download a trial (http://onecare.live.com/standard/en-us/install/install.htm) , and can still add a PC to their existing OneCare circle (http://onecare.live.com/standard/en-us/install/addcomputerinstall.htm) .

Learn more about end of sale for OneCare (http://onecare.live.com/standard/en-us/activation/oc_eol_guidance.htm) .

On September 29th 2009, Microsoft introduced Microsoft Security Essentials, a FREE consumer anti-malware solution for Genuine Windows based PCs.

Learn more about Microsoft Security Essentials (http://onecare.live.com/standard/en-us/default.htm) or download from Microsoft directly at: http://www.microsoft.com/security_essentials/default.aspx (http://onecare.live.com/standard/en-us/default.htm) .






Expand all | Collapse all

SYMPTOMS

After you install Microsoft Windows Live OneCare, you cannot perform the following actions:
  • Access shared files, folders, and printers on other computers on the network.
  • Share files, folders, and printers on the Windows Live OneCare computer with other computers on the network.

CAUSE

This occurs because after you install Windows Live OneCare, file and printer sharing is disabled. Windows Live OneCare disables file and printer sharing in order to help increase the overall security of the computer. File and printer sharing should only be enabled as needed and should be configured to allow the minimum amount of access in order to accomplish the required task (set to subnet rather than to internet if possible).

RESOLUTION

To modify the default behavior of file and printer sharing, follow these steps:
  1. In the notification area, right-click the Windows Live OneCare icon, and then click Open Windows Live OneCare.
  2. In the left pane, click View or Change Settings, and then click the Firewall tab.
  3. Click Firewall Connection Tool.
  4. Click to select the File and Printer Sharing – share files and printers with other computers on the network check box.
  5. Click OK and close the View or Change Settings options.
  6. Restart the computer and test the access shared files and folders.
If the above solution does not resolve the problem, please continue with the steps below to manually set File and Printer Sharing to the "Internet" Setting.
  1. In the notification area, right-click the Windows Live OneCare icon, and then click Open Windows Live OneCare.
  2. In the left pane, click View or Change Settings, and then click the Firewall tab.
  3. Click Advanced Settings.
  4. On the Advanced tab, select the appropriate settings to enable shared folders and shared printers to be accessible from the Internet. To do this, follow these steps:
    1. Click Share them with all computers (even those on the Internet) to enable files and printers to be shared over the Internet.

MORE INFORMATION

Consider the following scenario:
  • The network contains multiple routers. For example, the network contains a wireless router and a wired router.
  • You cannot share files between computers connected to the individual routers. For example, you cannot share folders from wireless computers to wired computers that are connected through separate routers.
In this scenario, you may have to configure file and printer sharing, and select the Share them with all computers (even those on the Internet) option. This is because Windows Live OneCare will not recognize the computers that are connected to a wireless router as on the same subnet as the computers that are connected to a wired router. However, this is not a deficiency of Windows Live OneCare. It is a limitation that is caused by the way that routers and subnets function generally. In these scenarios, if your network contains a router that is managing the connection to your cable model or DSL modem, file and printer sharing is normally blocked at the hardware router, which reduces the security risk of the above configuration.

APPLIES TO
  • Windows Live OneCare Free Trial
Keywords: 
KBRetire kbtshoot kbprinters kbsharedfolders kbexpertisebeginner kbfirewall kbprb KB923157
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.