When you try to receive TCP data in Microsoft Windows Server 2003, the TCP connection may be reset before all the data can be processed

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Article ID: 923200 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

When you try to receive Transmission Control Protocol (TCP) data in Microsoft Windows Server 2003, the TCP connection may be reset before all the data can be processed.

CAUSE

This problem occurs when the receiving computer cannot process all the data that is sent within a certain length of time. By default in Windows Server 2003, TCP connections must close after the TCP connection state has been set to FIN_WAIT_2 for two minutes.

Note When the sending computer sends FIN, the state of the TCP connection is set to FIN_WAIT_2. After the TCP connection has been closed, the sending computer sends RST in order to reset the connection if the receiving computer sends any packets to the sending computer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Tcpip.sys5.2.3790.2768386,04809-Aug-200615:21x86
Windows Server 2003, x64-based versions
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File nameFile versionFile sizeDateTimePlatform
Tcpip.sys5.2.3790.2768813,05610-Aug-200601:40x64
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tcpip.sys5.2.3790.27681,283,07210-Aug-200601:40IA-64

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this problem, increase the time that TCP connections may remain in the FIN_WAIT_2 state. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  3. In the details pane, double-click TCPFinWait2Delay, and then enter a value from 30 through 300.

    Note If the TCPFinWait2Delay value does not exist, you must create it as a REG_DWORD registry value. This registry value controls how many seconds that a TCP connection waits before it is forced to close after the shutdown(s, SD_SEND) function is called. The default value is 240 seconds. The range for this value is from 30 through 300. This registry value must be created manually. Otherwise, the default value is used.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 923200 - Last Review: October 9, 2011 - Revision: 6.0
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbregistry kbnetwork kbfix kbqfe KB923200

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