Mensaje de error al realizar una copia de seguridad completa de una base de datos en SQL Server 2005: "Error de copia de seguridad para Server 'ComputerName\SQLInstanceName'" o "la copia de seguridad del archivo o grupo de archivos 'sysft_FullTextCatalog' no está permitido porque no está en línea"

Seleccione idioma Seleccione idioma
Id. de artículo: 923355 - Ver los productos a los que se aplica este artículo
Nº de error: 432932 (SQLBUDT)
Expandir todo | Contraer todo

En esta página

Síntomas

Al realizar una copia de seguridad completa de una base de datos en Microsoft SQL Server 2005, puede recibir un mensaje de error similar al siguiente:
Error de copia de seguridad para Server ? ComputerName \ SQLInstanceName '. (Microsoft.SqlServer.Smo)

obtener información adicional:
System.Data.SqlClient.SqlError: No se permite la copia de seguridad del archivo o grupo de archivos "sysft_ FullTextCatalog" porque no está conectado. BACKUP puede realizarse mediante las cláusulas FILEGROUP o FILE para restringir la selección para incluir sólo los datos en línea. (Microsoft.SqlServer.Smo)
Si realiza una copia de seguridad completa de una base de datos en SQL Server 2005 Service Pack 2 (SP2), puede recibir un mensaje de error similar al siguiente:
La copia de seguridad del catálogo de texto 'FullTextCatalog' no está permitido porque no está conectado. Consulte archivo de registro de errores para la razón que catálogo de texto se convierte en sin conexión y ponerlo en conexión. O BACKUP puede realizarse mediante las cláusulas FILEGROUP o FILE para restringir la selección para incluir sólo los datos en línea.

Causa

Este comportamiento se produce porque un catálogo de texto en la base de datos no está conectado. Para realizar una copia de seguridad completa, SQL Server 2005 requiere todos los archivos de base de datos y catálogos de texto completo de la base de datos en línea.

El catálogo de texto completo puede ser en línea se cumple una o varias de las siguientes condiciones:
  • La carpeta de catálogo de texto se elimina o dañada.
  • No se habilitar la indización de texto completo la base de datos.
  • Es restaurar la base de datos desde una copia de seguridad base de datos de Microsoft SQL Server 2000. Por lo tanto, la carpeta del catálogo de texto completo de la base de datos no existe en el servidor donde restaurar la base de datos.
  • Se actualizó la instancia de SQL Server 2005 que se ejecutan desde SQL Server 2000. Sin embargo, el servicio de búsqueda de texto puede no puede tener acceso a durante la actualización.
  • Se adjunta la base de datos de otro sitio. Sin embargo, se especifica la ubicación incorrecta de la carpeta de catálogo de texto durante los datos adjuntos.
Nota En SQL Server 2005 SP2, la razón de que el catálogo de texto completo no está en línea se registra en el registro de error de SQL Server. Consulte el registro de errores SQL Server de la causa específica de este comportamiento.

Solución

Para solucionar este comportamiento, siga estos pasos:
  1. Busque la carpeta que contiene los archivos del catálogo de texto completo problemático.
  2. Ejecute la instrucción ALTER DATABASE. Especificar en la instrucción la ubicación correcta para el catálogo de texto.

    Para obtener más información acerca de cómo utilizar la instrucción ALTER DATABASE en este escenario, visite el siguiente sitio Web de Microsoft Developer Network (MSDN) y, a continuación, busque el tema "Mover catálogos de texto":
    http://msdn2.microsoft.com/en-us/library/ms345483.aspx
  3. Reconstruir el catálogo de texto problemático en la base de datos.
  4. Realice una copia de seguridad completa de la base de datos SQL Server 2005 nuevo.
notas
  • Si no ha habilitado la base de datos para la indización de texto completo, debe habilitar primero esta opción para poder realizar una copia de seguridad completa de la base de datos en SQL Server 2005.

    Para obtener más información acerca de cómo habilitar una base de datos para la indización en SQL Server 2005 de texto, visite el siguiente sitio Web de MSDN:
    http://msdn2.microsoft.com/en-us/library/ms403375.aspx
  • Si ya no necesita el catálogo de texto completo, puede eliminar el catálogo de texto problemático. A continuación, realice una copia de seguridad completa de la base de datos en SQL Server 2005.

Estado

Este comportamiento es por diseño.

Más información

Pasos para reproducir el comportamiento

  1. En SQL Server 2005, cree un catálogo de texto.
  2. Detenga el servicio de búsqueda de texto completo.
  3. Eliminar el proceso de búsqueda de texto completo en el Administrador de tareas de Windows si existe el proceso.
  4. Elimine la carpeta de catálogo de texto. La carpeta de catálogo de texto se encuentra en la carpeta siguiente:
    %ProgramFiles%\Microsoft SQL Server\MSSQL.1\MSSQL\FTData
  5. Inicie el servicio Búsqueda de texto completo.
  6. Realizar un completo fondo de la base de datos que contiene el catálogo de texto completo.

Propiedades

Id. de artículo: 923355 - Última revisión: jueves, 09 de julio de 2009 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Workgroup Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition
Palabras clave: 
kbmt kbsql2005fts kbexpertiseadvanced kbtshoot kbprb KB923355 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 923355

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com