Při práci se soubory prostřednictvím sítě v počítači se systémem Windows 2000 Server nebo systémem Windows Server 2003 můžete zaznamenat různé problémy

Překlady článku Překlady článku
ID článku: 923360 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Na počítači se systémem Microsoft Windows 2000 Server nebo systémem Microsoft Windows Server 2003 můžete zaznamenat jeden nebo více následujících příznaků při práci se soubory v síti:
  • Soubor systémem Windows server, který je konfigurován jako souborový a tiskový server přestane reagovat. Funkce serveru souborů a tisku potom dočasně zastaví.
  • Při otevřít, uložit, zavřete, odstranit nebo tisknout soubory, které jsou umístěny na sdíleném prostředku dochází k dlouhé prodlevě.
  • Při použití aplikace prostřednictvím sítě dochází k dočasnému snížení výkonu. Obvykle je pomalé přibližně 40 až 45 sekund. Některé prodlevy však mohou trvat až 5 minut.
  • Zaznamenat prodlevu při kopírování kopírování souboru nebo provedení operací zálohování.
  • Při připojení ke sdílenému prostředku Průzkumník buď přestane reagovat nebo zobrazit červený KŘÍŽEK na připojené síťové jednotce.
  • Program přestane reagovat buď používá vzdálené volání procedur (RPC) nebo se připojit k serveru soubor, který používá pojmenované kanály.
  • Server přestane dočasně reagovat a v systémovém protokolu na souborovém serveru se zobrazí jeden nebo více zpráv s ID události podobné následující zprávy:
    Event ID: 2022 
    Source: Srv			
    Type: Error 
    Description: 
    Server was unable to find a free connection <number> times in the last <number> seconds.
    Event ID: 2021 
    Source: Srv 
    Type: Error 
    Description: 
    Server was unable to create a work item <number> times in the last <number> seconds.
    Event ID: 2020 
    Source: Srv 
    Type: Error 
    Description: 
    The server was unable to allocate from the system paged pool because the pool was empty.
    Event ID: 2019 
    Source: Srv 
    Type: Error 
    Description: 
    The server was unable to allocate from the system nonpaged pool because the pool was empty. 
    Event ID: 2510
    Source: Server
    Event Type: Error 
    Description: 
    The server service was unable to map error code 1722.
    Dále se může zobrazit následující událost do systémového protokolu v klientském počítači:
    Event ID: 3013 
    Event Type: Error 
    Event Source: MrxSmb /	Rdr 
    Description: 
    The redirector has timed out a request to <ComputerName>.
  • Jeden z následujících chybových zpráv obdržíte při pokusu o připojení sdíleného prostředku:
    Systémová chyba 53. Cesta v síti nebyla nalezena. (ERROR_BAD_NETPATH)
    Systémová chyba 64. Zadaný síťový název je již k dispozici. (ERROR_NETNAME_DELETED)
  • Dochází k přerušovanému odpojování od síťových prostředků a nelze se připojit k síťovým prostředkům na souborovém serveru. Server však reaguje na příkaz ping a můžete se k němu připojit pomocí relace Terminálové služby.
  • Pokud více uživatelů pokusí otevřít dokumenty sady Microsoft Office na serveru, dialogové okno soubor je uzamčen pro úpravy vždy nezobrazí Jakmile druhý uživatel soubor otevře.
  • Trasování v síti označuje, že je 30 do 40 druhé zpoždění mezi klienta příkaz serveru zprávu blok (SMB) Service a odpovědí ze souborového serveru.
  • V systému Windows Server 2003 a Windows 2000 Service Pack 4 (SP4), server může přestat reagovat libovolně.
  • Když se pokusíte otevřít soubor databáze Microsoft Access 2.0 (MDB) v aplikaci Access 97, Access 2000 nebo Access 2002, může se zobrazit chybová zpráva podobná následující:
    Chyba disku nebo sítě.
  • Otevřete aplikaci Microsoft Excel, může se zobrazit následující chybová zpráva:
    Soubor nebyl uložen.
  • Otevřete Průzkumník, může se zobrazit následující chybová zpráva:
    Nelze získat přístup k < cesta a název souboru > tyto relace byla zrušena.
  • Při otevření souboru aplikace Word může selhat. Potom může zobrazit následující chybová zpráva:
    Čtení z tohoto souboru < název > se nezdařilo. Obnovte síťové připojení nebo vyměňte disketu a akci opakujte.
    Navíc po obnovení síťového připojení a klepněte na tlačítko OK, zobrazí následující chybová zpráva:
    Word ztratil data kvůli chybné síťové připojení nebo chybějící disketě. Dokumenty, použití tato data budou uložena a potom zavřen.

Příčina

Tyto problémy může dojít, pokud platí jedna z následujících podmínek:
  • Verze ovladače Obsluha událostí Symantec (SymEvent.sys) je zastaralá. Proto jsou zablokovány dva či více podprocesů v SymEvent.sys ovladače funkce Symevent_GetSubTask.
  • Existuje OpLock INO_FLTR.SYS Computer Associates (CA) spolupráce potíže se souborem SRV.sys.

Řešení

Chcete-li tyto problémy vyřešit, aktualizujte ovladač filtru systému souborů jiných výrobců antivirového. Pokud máte Obsluha událostí Symantec například ovladač (SymEvent.sys) nainstalován v počítači aktualizace verze 11.6.4.1 nebo vyšší verze. Chcete-li získat aktualizovanou verzi souboru SymEvent.sys nebo najít nápovědu změnu konfigurace, navštivte následující web společnosti Symantec:
http://www.symantec.com


Poznámka:Verze souboru SymEvent.sys 11.6.4.2 má chyba můžete provést některé servery restartovat libovolně. Informace o výrobce hardwaru naleznete na následujícím webu:
http://support.microsoft.com/gp/vendors/en-us

Další informace

Všechny chybové zprávy uvedené v "Příznaky" oddíl bod selhání připojení SMB. Tyto nefunkční připojení může být související sítě. Nebo selhání připojení může dojít, když server přestane reagovat libovolně.

Následující verze antivirového ovladač může také způsobit servery přestat reagovat:
  • Problém se vyskytly při následující verze ovladače jsou nainstalovány na souborovém serveru.
    Zmenšit tuto tabulkuRozšířit tuto tabulku
    NÁZEVSpolečnostVerzeDatumPOPIS
    Symevent.sysSymantec Corporation11.4:0.6 05. Března 2004Symantec událostí knihovny
    Symtdi.sysSymantec Corporation5.3:6.13 23. Prosince 2004Ovladač Pult sítě
    Tyto verze jsou nainstalovány s Symantec AntiVirus 9.0.

    Následující webové stránce na webu společnosti Symantec (Symantec ID dokumentu: 2005062909055948) popisuje, jak aktualizovat Symevent soubory:
    http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/1998092408260848?Open&src=&docid=2005081909325748&nsf=ent-security.nsf&view=docid&dtype=&prod=&ver=&osv=&osv_lvl=&seg=
  • Problém se vyskytly při následující verze CÚ eTrust Antivirus/InoculateIT ovladače filtru systému souborů jsou nainstalovány na souborovém serveru.
    Zmenšit tuto tabulkuRozšířit tuto tabulku
    NÁZEVSpolečnostVerzeDatumPOPIS
    Ino_flpy.sysComputer Associates5.0:6100.106 19. června 2003CÚ eTrust Antivirus/InoculateIT soubor System připojování filtr ovladačů pro systém Windows 2000/XP/.Net
    Ino_fltr.sysComputer Associates5.0:6100.13608. Srpna 2004CÚ eTrust Antivirus/InoculateIT soubor System filtr ovladač pro systém Windows 2000/XP/2003
    Problém odkazuje na následující webové stránce na webu Computer Associates:
    http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/DriverFix.asp
Prozkoumat trasování v síti můžete najít soubor serveru neodpovídá požadavky SMB. Například po provedení operace sledování sítě se zobrazí následující kód:
15:28:14  client -> server SMB Read AndX Request, FID 0x0002
15:28:14   server -> client  TCP [ACK]
Přibližně 45 sekund klientský počítač ukončí relace TCP (FIN) a server potom odešle "[FIN ACK]." Po provedení operace sledování sítě se zobrazí následující kód:
15:29:05  client  -> server TCP [FIN ACK]
15:29:05   server -> client  TCP [FIN ACK]
v takové trasování uvidíte, že server neodpovídá SMB požadavek. Server však stále odesílá potvrzení TCP pro počítač požadavek klienta. To znamená, že je služba serveru na serveru soubor systémem Windows reagovat na požadavky SMB. To také znamená, že připojení k síti není příčinou problému.

Odkazy

Další informace naleznete v následujících článcích znalostní báze Microsoft Knowledge Base:
816071Dočasné vypnutí ovladače filtru režimu jádra v systému Windows (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)
240309Jak plně zakázat antivirový software z filtrování souborů
822219Při práci se soubory umístěnými na souborovém serveru je odezva serveru pomalá a dochází k prodlevám
Produkty třetích stran, o nichž se hovoří v tomto článku, jsou vyráběny společnostmi nezávislými na společnosti Microsoft. Společnost Microsoft neposkytuje žádnou záruku (implicitně předpokládanou ani jinou) týkající se výkonu a spolehlivosti těchto produktů.

Vlastnosti

ID článku: 923360 - Poslední aktualizace: 20. září 2006 - Revize: 1.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Klíčová slova: 
kbmt kbtshoot kbprb KB923360 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:923360

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com