Puede experimentar diversos problemas cuando trabaja con archivos a través de la red en un equipo Windows Server 2003 o Windows 2000 Server

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Síntomas

En un equipo de Microsoft Windows Server 2003 o Microsoft Windows 2000 Server, puede experimentar uno o varios de los síntomas siguientes cuando se trabaja con archivos a través de la red:
  • Un servidor de archivos basados en Windows que está configurado como un servidor de archivos e impresión deja de responder. A continuación, la funcionalidad del servidor archivo e impresión detiene temporalmente.
  • Experimenta un retraso largo al abrir, guardar, cerrar, eliminar o imprimir archivos que se encuentran en un recurso compartido.
  • Experimenta una reducción temporal del rendimiento al utilizar un programa a través de la red. Normalmente, rendimiento es lento durante aproximadamente 40 a 45 segundos. Sin embargo, algunos retrasos pueden durar hasta cinco minutos.
  • Experimenta un retraso cuando copia una copia del archivo o al realizar operaciones de copia de seguridad.
  • Cuando se conecta a un recurso compartido, el Explorador de Windows o deja de responder o ve una X roja en la unidad de red conectada.
  • Un programa deja de responder que cualquiera utiliza llamada a procedimiento remoto (RPC) o que utiliza canalizaciones con nombre para conectarse a un servidor de archivos.
  • El servidor deja temporalmente de responder y uno o más mensajes de identificador de evento similares a los siguientes mensajes aparecen en el registro de sistema en el servidor de archivos:
    Event ID: 2022 
    Source: Srv			
    Type: Error 
    Description: 
    Server was unable to find a free connection <number> times in the last <number> seconds.
    Event ID: 2021 
    Source: Srv 
    Type: Error 
    Description: 
    Server was unable to create a work item <number> times in the last <number> seconds.
    Event ID: 2020 
    Source: Srv 
    Type: Error 
    Description: 
    The server was unable to allocate from the system paged pool because the pool was empty.
    Event ID: 2019 
    Source: Srv 
    Type: Error 
    Description: 
    The server was unable to allocate from the system nonpaged pool because the pool was empty. 
    Event ID: 2510
    Source: Server
    Event Type: Error 
    Description: 
    The server service was unable to map error code 1722.
    Además, el suceso siguiente puede aparecer en el registro del sistema del equipo cliente:
    Event ID: 3013 
    Event Type: Error 
    Event Source: MrxSmb /	Rdr 
    Description: 
    The redirector has timed out a request to <ComputerName>.
  • Recibirá uno de los siguientes mensajes de error al intentar conectarse a un recurso compartido:
    Error de sistema 53. No se encontró la ruta de acceso de red. (ERROR_BAD_NETPATH)
    Error de sistema 64. El nombre de red especificado ya no está disponible. (ERROR_NETNAME_DELETED)
  • Se desconecta de forma intermitente de los recursos de red y no puede volver a conectarse a los recursos de red del servidor de archivos. Sin embargo, puede hacer ping al servidor y utilizar una sesión de Servicios de Terminal Server para conectarse al servidor.
  • Si varios usuarios intentan tener acceso a documentos de Microsoft Office en el servidor, el cuadro de diálogo archivo está bloqueado para edición no aparece siempre cuando el segundo usuario abre el archivo.
  • Una traza de red indica que hay un 30 a 40 retraso segundo entre un comando de cliente de servicio de servidor mensaje bloque (SMB) y una respuesta del servidor de archivos.
  • En Windows Server 2003 y Windows 2000 Service Pack 4 (SP4), el servidor deje de responder arbitrariamente.
  • Cuando intenta abrir un archivo de base de datos (.mdb) de Microsoft Access 2.0 en Microsoft Access 97, Access 2000 o Access 2002, puede recibir un mensaje de error similar al siguiente:
    Error de disco o de red.
  • Cuando abre Microsoft Excel, puede recibir el siguiente mensaje de error:
    archivo no se ha guardado.
  • Cuando abra el Explorador de Windows, puede recibir el siguiente mensaje de error:
    No puede tener acceso a < ruta y el nombre de archivo >.el se canceló la sesión.
  • Cuando se abre un archivo de Microsoft Word, es posible que Word no. Puede que reciba a continuación el siguiente mensaje de error:
    Word no pudo leer de este archivo < nombre >. Restaure la conexión de red o reemplace el disco y vuelva a intentarlo.
    Además, después de restaurar la conexión de red y haga clic en Aceptar , recibirá el siguiente mensaje de error:
    Word perdió datos debido de una mala conexión de red o disco que falta. Documentos depender de este tipo de datos se guarda y, a continuación, se cierra.

Causa

Estos problemas pueden producirse cuando se cumple una de las condiciones siguientes:
  • La versión del controlador de controlador de eventos de Symantec (symevent.sys) es obsoleta. Por lo tanto, dos o más subprocesos se interbloqueado en el symevent.sys controlador en la función Symevent_GetSubTask .
  • Hay un OpLock INO_FLTR.SYS de Computer Associates (CA) problema de interoperabilidad con el archivo SRV.sys.

Solución

Para resolver estos problemas, actualice el controlador de filtro del sistema de archivos de antivirus de terceros. Por ejemplo, si tiene el controlador de eventos Symantec controlador (SymEvent.sys) instalado en el equipo, la actualización de versión 11.6.4.1 o una versión posterior. Para obtener una versión actualizada del archivo symevent.sys o para obtener ayuda con la reconfiguración, visite el siguiente sitio Web de Symantec:
http://www.symantec.com


Nota La versión del archivo SymEvent.sys 11.6.4.2 tiene un error que puede hacer que algunos servidores reiniciar arbitrariamente. Para obtener información sobre el fabricante del hardware, visite el siguiente sitio Web:
http://support.microsoft.com/gp/vendors/en-us

Más información

Todos los mensajes de error que se mencionan en la sección "Síntomas" sección punto para errores de conexiones de SMB. Estos errores conexiones pueden ser relacionado con la red. O las conexiones de error cuando el servidor deja de responder arbitrariamente.

Las siguientes versiones de controlador antivirus también pueden hacer los servidores para dejar de responder:
  • El problema se sabe que produce cuando se instalan las siguientes versiones de controlador en el servidor de archivos.
    Contraer esta tablaAmpliar esta tabla
    NombreCompañíaVersiónFechaDescripción
    Symevent.sysSymantec Corporation11.4:0.6 05-Mar-2004Evento Symantec biblioteca
    Symtdi.sysSymantec Corporation5.3:6.13 23-Dic-2004Controlador de envío de red
    Estas versiones que se instalan con 9.0 de Symantec Antivirus.

    La siguiente página Web en el sitio Web de Symantec (ID de documento de Symantec: 2005062909055948) describe cómo actualizar el Symevent archivos:
    http://service1.symantec.com/SUPPORT/ent-security.nsf/docid/1998092408260848?Open&src=&docid=2005081909325748&nsf=ent-security.nsf&view=docid&dtype=&prod=&ver=&osv=&osv_lvl=&seg=
  • El problema se sabe que produce cuando se instalan las versiones de controlador de filtro del sistema de antivirus y InoculateIT archivos de eTrust de CA siguientes en el servidor de archivos.
    Contraer esta tablaAmpliar esta tabla
    NombreCompañíaVersiónFechaDescripción
    Ino_flpy.sysEquipo Associates5.0:6100.106 19-Jun-2003CA eTrust Antivirus/InoculateIT archivos del sistema montaje filtro controladores para Windows 2000/XP/.Net
    Ino_fltr.sysEquipo Associates5.0:6100.13608-Ago-2004ETrust de CA InoculateIT o antivirus archivo sistema filtro controlador para Windows 2000/XP/2003
    La siguiente página Web en el sitio Web de Computer Associates hace referencia el problema:
    http://supportconnectw.ca.com/premium/antivirus/downloads/nt/4.5/DriverFix.asp
Si investiga las trazas de red, es posible que el servidor de archivos no responde a solicitudes SMB. Por ejemplo, después de realizar una operación de seguimiento de red, recibirá el siguiente código:
15:28:14  client -> server SMB Read AndX Request, FID 0x0002
15:28:14   server -> client  TCP [ACK]
después de aproximadamente 45 segundos, el equipo cliente termina la sesión de TCP (FIN), y a continuación, el servidor envía un "[FIN ACK]." Después de realizar la operación de seguimiento de red, recibirá el siguiente código:
15:29:05  client  -> server TCP [FIN ACK]
15:29:05   server -> client  TCP [FIN ACK]
en estas trazas, puede ver que el servidor no responde a SMB solicitud. Sin embargo, el servidor aún envía una confirmación de TCP para la solicitud de equipo cliente. Esto significa que el servicio servidor en el servidor de archivos basados en Windows es responder a solicitudes SMB. Esto también significa que la conectividad de red no es la causa del problema.

Referencias

Para obtener más información, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
816071Cómo desactivar temporalmente el controlador de filtro de modo de núcleo en Windows
240309Cómo deshabilitar totalmente el filtrado de archivos para el software antivirus
822219Experimenta rendimiento lento y retrasos en el servidor de archivos cuando trabaja con archivos ubicados en un servidor de archivos
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Propiedades

Id. de artículo: 923360 - Última revisión: miércoles, 20 de septiembre de 2006 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Palabras clave: 
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Haga clic aquí para ver el artículo original (en inglés): 923360

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