Article ID: 923575 - Last Review: May 21, 2010 - Revision: 2.0

Error message when Outlook tries to connect to a server by using an RPC connection or an HTTPS connection: "There is a problem with the proxy server's security certificate"

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SYMPTOMS

When Microsoft Office Outlook tries to connect to a server by using a remote procedure call (RPC) connection or a secure HTTP (HTTPS) connection, you receive one of the following error messages:
  • Error message 1
    There is a problem with the proxy server's security certificate, %s. Outlook is unable to connect to this server. (%s)
  • Error message 2
    There is a problem with the proxy server's security certificate, %s. The name on the security certificate is invalid or does not match the name of the site. Outlook is unable to connect to this server. (%s)
  • Error message 3
    There is a problem with the proxy server's security certificate, %s. The security certificate is not from a trusted certifying authority. Outlook is unable to connect to this server. (%s)"
Notes about the error messages
  • The %s placeholder is the Outlook profile property 001f6622. This is the Microsoft Exchange Server RPC proxy server name.
  • The (%s) placeholder is the error code.

    For error message 1 and error message 2, the error code that is returned is the sum of all the bitmask certificate problem codes. See the "More Information" section for information about the bitmask certificate problem codes.

    For error message 3, the error code is expected to always be 0x00000008.

CAUSE

This issue may occur if one or more of the following conditions are true:
  • The connection to the server requires a certification authority (CA).
  • You have not trusted the certification authority at the root.
  • The certificate may be invalid or revoked.
  • The certificate does not match the name of the site.

RESOLUTION

To resolve this issue, use one of the following methods, as appropriate for your situation.

Method 1: Examine the certificate

Use this method if you receive either error message 1 or error message 2. Examine the certificate. Then, contact your system administrator to resolve this issue.

To examine the certificate, follow these steps:
  1. In Microsoft Internet Explorer, connect to the RPC server or to the secure server. For example, type https://www.server_name.com/rpc in the Address bar of the Web browser, and then press ENTER.

    Note The server_name placeholder references the RPC server name or the secure server name.
  2. Double-click the padlock icon that is located in the lower-right corner of the Web browser.
  3. Click the Details tab.
  4. Note the information in the following fields:
    • Valid to
      The Valid to field indicates the date until which the certificate is valid.
    • Subject
      The data in the Subject field should match the site name.

Method 2: Install the trusted root certificate

Use this method if you receive error message 3. To install the trusted root certificate, follow these steps:
  1. Click Install Certificate when you are prompted with the Certificate dialog box.
  2. Click Next.
  3. Click to select the Place all certificate in the following store check box.
  4. Click Browse.
  5. Click Trusted Root Certification Authorities, and then click OK.
  6. Click Next.
  7. Click Finish.
  8. Click OK.

MORE INFORMATION

The bitmask certificate problem codes are listed in the following table.
Collapse this tableExpand this table
DescriptionError code
FLAG_CERT_REV_FAILED0x00000001
FLAG_INVALID_CERT0x00000002
FLAG_CERT_REVOKED0x00000004
FLAG_INVALID_CA0x00000008
FLAG_CERT_CN_INVALID0x00000010
FLAG_CERT_DATE_INVALID0x00000020
FLAG_CERT_WRONG_USAGE0x00000040
FLAG_SECURITY_CHANNEL_ERROR0x80000000

APPLIES TO
  • Microsoft Office Outlook 2007
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