Outlook이 RPC 연결 또는 HTTPS 연결을 사용하여 서버에 연결하려고 할 때 오류: 프록시 서버의 보안 인증서에 문제가 있습니다.

원래 KB 번호: 923575

증상

Microsoft Outlook에서 RPC(원격 프로시저 호출) 연결 또는 HTTPS(보안 HTTP) 연결을 사용하여 서버에 연결하려고 하면 다음 오류 메시지 중 하나가 표시됩니다.

  • 오류 메시지 1

    프록시 서버의 보안 인증서 %s에 문제가 있습니다. Outlook에서 이 서버에 연결할 수 없습니다. (%s)

  • 오류 메시지 2

    프록시 서버의 보안 인증서 %s에 문제가 있습니다. 보안 인증서의 이름이 잘못되었거나 사이트 이름과 일치하지 않습니다. Outlook에서 이 서버에 연결할 수 없습니다. (%s)

  • 오류 메시지 3

    프록시 서버의 보안 인증서 %s에 문제가 있습니다. 보안 인증서는 신뢰할 수 있는 인증 기관에서 온 것이 아닙니다. Outlook에서 이 서버에 연결할 수 없습니다. (%s)"

  • 오류 메시지 4

    프록시 서버의 보안 인증서에 문제가 있습니다. 보안 인증서의 이름이 잘못되었거나 대상 사이트 outlook.office365.com 이름과 일치하지 않습니다. Outlook에서 프록시 서버에 연결할 수 없음(오류 코드 0)

오류 메시지에 대한 참고 사항

  • %s 자리 표시자는 Outlook 프로필 속성 001f6622입니다. Microsoft Exchange Server RPC 프록시 서버 이름입니다.

  • (%s) 자리 표시자는 오류 코드입니다.

    오류 메시지 1 및 오류 메시지 2의 경우 반환되는 오류 코드는 모든 비트 마스크 인증서 문제 코드의 합계입니다. 비트 마스크 인증서 문제 코드에 대한 자세한 내용은 "추가 정보" 섹션을 참조하세요.

    오류 메시지 3의 경우 오류 코드는 항상 0x00000008 합니다.

원인

다음 조건 중 하나 이상이 true인 경우 이 문제가 발생할 수 있습니다.

  • 서버에 연결하려면 CA(인증 기관)가 필요합니다.
  • 루트에서 인증 기관을 신뢰하지 않았습니다.
  • 인증서가 잘못되었거나 해지될 수 있습니다.
  • 인증서가 사이트 이름과 일치하지 않습니다.
  • 타사 추가 기능 또는 타사 브라우저 추가 기능이 액세스를 차단합니다.

해결 방법 1: 인증서에서 오류 메시지 1 또는 2 검사

인증서를 검사합니다. 그런 다음 시스템 관리자에게 문의하여 이 문제를 resolve.

인증서를 검사하려면 다음 단계를 수행합니다.

  1. Microsoft 인터넷 Explorer RPC 서버 또는 보안 서버에 연결합니다. 예를 들어 웹 브라우저의 주소 표시줄server_name.com/rpc를 입력https://www.한 다음 Enter 키를 누릅니다.

    참고

    server_name 자리 표시자는 RPC 서버 이름 또는 보안 서버 이름을 참조합니다.

  2. 웹 브라우저의 오른쪽 아래 모서리에 있는 자물쇠 아이콘을 두 번 클릭합니다.

  3. 세부 정보 탭을 클릭합니다.

  4. 다음 필드에 있는 정보를 확인합니다.

    • 유효한 경우
      유효할 날짜 필드는 인증서가 유효할 때까지의 날짜를 나타냅니다.
    • 제목
      주체 필드의 데이터는 사이트 이름과 일치해야 합니다.

해결 방법 2: 오류 메시지 3에 대해 신뢰할 수 있는 루트 인증서 설치

클라이언트에 신뢰할 수 있는 루트 인증서를 설치하려면 다음 단계를 수행합니다.

  1. 인증서 대화 상자가 표시되면 인증서설치를 클릭합니다.
  2. 다음을 클릭합니다.
  3. 다음 저장소 검사 모든 인증서 배치 상자를 클릭하여 선택합니다.
  4. 찾아보기를 클릭합니다.
  5. 신뢰할 수 있는 루트 인증 기관>확인을 클릭합니다.
  6. 다음을 클릭합니다.
  7. 마침을 클릭합니다.
  8. 확인을 클릭합니다.

참조는 신뢰할 수 있는 루트 인증서 설치를 참조하세요.

해결 방법 3: 오류 메시지 4에 대해 타사 추가 기능 또는 타사 브라우저 추가 기능 사용 안 함

타사 추가 기능 사용 안 함

  1. 문제를 격리하는 데 도움이 되도록 안전 모드로 Outlook을 시작합니다. 이렇게 하려면 실행 시작을> 클릭하고 /safeoutlook.exe 입력한 다음 확인을 클릭합니다.

    Outlook이 안전 모드에서 성공적으로 시작되면 타사 추가 기능으로 인해 발생하는 문제가 발생할 수 있습니다.

  2. 타사 COM 추가 기능을 확인하고 사용하지 않도록 설정합니다. 이렇게 하려면 다음과 같이 하십시오.

    1. 파일 메뉴에서 옵션>추가 기능을 클릭합니다.
    2. 관리 상자에서 COM 추가 기능>이동을 클릭합니다.
    3. 사용하지 않도록 설정할 타사 추가 기능 옆에 있는 검사 상자를 선택 취소하려면 클릭합니다.
    4. Outlook을 다시 시작합니다.

자세한 내용은 다음 Microsoft 기술 자료 문서의 "6단계: 안전 모드에서 Outlook 시작" 섹션을 참조하세요.

2632425 Outlook 2010 및 Outlook 2013에서 충돌 문제를 해결하는 방법

타사 브라우저 추가 기능 사용 안 함

Outlook은 HTTP 요청에 인터넷 Explorer 설정을 사용합니다. 타사 브라우저 추가 기능으로 인해 이 문제가 발생하는 경우 인터넷 Explorer 사용하지 않도록 설정합니다. 이 작업을 수행하는 방법에 대한 단계는 다음 Microsoft 기술 자료 문서의 "인터넷 Explorer 추가 기능 사용 안 함" 섹션을 참조하세요.

956196 "인터넷 Explorer 웹 페이지를 표시할 수 없음" 오류

추가 정보

비트 마스크 인증서 문제 코드는 다음 표에 나와 있습니다.

설명 오류 코드
FLAG_CERT_REV_FAILED 0x00000001
FLAG_INVALID_CERT 0x00000002
FLAG_CERT_REVOKED 0x00000004
FLAG_INVALID_CA 0x00000008
FLAG_CERT_CN_INVALID 0x00000010
FLAG_CERT_DATE_INVALID 0x00000020
FLAG_CERT_WRONG_USAGE 0x00000040
FLAG_SECURITY_CHANNEL_ERROR 0x80000000