ID do artigo: 923575 - Última revisão: quinta-feira, 24 de janeiro de 2008 - Revisão: 1.2

Mensagem de erro exibida quando o Outlook 2007 tenta se conectar a um servidor usando uma conexão RPC ou uma conexão HTTPS: "Há um problema com o certificado de segurança do servidor proxy"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Quando o Microsoft Office Outlook 2007 tenta se conectar a um servidor usando uma conexão de RPC (chamada de procedimento remoto) ou uma conexão HTTP (HTTPS) segura, uma das seguintes mensagens de erro é exibida:
  • Mensagem de erro 1
    Há um problema com o certificado de segurança do servidor proxy, %s.O Outlook não pode estabelecer conexão com o servidor. (%s)
  • Mensagem de erro 2
    Há um problema com o certificado de segurança do servidor proxy, %s. O nome no certificado de segurança é inválido ou não corresponde ao nome do site. O Outlook não pode estabelecer conexão com o servidor. (%s)
  • Mensagem de erro 3
    Há um problema com o certificado de segurança do servidor proxy, %s. O certificado de segurança não provém de uma autoridade de certificação confiável. O Outlook não pode estabelecer conexão com o servidor. (%s)"
Observações sobre as mensagens de erro
  • O espaço reservado %s é a propriedade de perfil 001f6622 do Outlook. Esse é o nome do servidor proxy do Microsoft Exchange Server RPC.
  • O espaço reservado (%s) é o código do erro.

    Nas mensagens de erro 1 e 2, o código de erro retornado é a soma de todos os códigos de problemas de certificado bitmask. Consulte a seção "Mais informações" para obter informações sobre os códigos de problemas de certificado bitmask.

    Em relação à mensagem de erro 3, espera-se que o código de erro seja sempre 0x00000008.

Causa

Esse problema ocorre se uma ou mais das seguintes condições forem verdadeiras:
  • A conexão ao servidor requer um certificado de autoridade (CA).
  • Autoridade de certificação não confiável na raiz.
  • O certificado pode estar inválido ou cancelado.
  • O certificado não corresponde ao nome do site.

Resolução

Para resolver esse problema use um dos seguintes métodos, conforme apropriado à sua situação.

Método 1: Examinar o certificado

Use esse método caso receba a mensagem de erro 1 ou 2. Examine o certificado. Em seguida, entre em contato com o administrador do sistema para resolver esse problema.

Para examinar o certificado, execute as seguintes etapas:
  1. No Microsoft Internet Explorer, conecte-se ao servidor de RPC ou ao servidor seguro. Por exemplo, digite https://www.nome_do_servidor.com/rpc na barra Endereço do browser da Web e pressione ENTER.

    Observação O espaço reservado nome_do_servidor se refere ao nome do servidor RPC ou ao nome do servidor seguro.
  2. Clique duas vezes no ícone de cadeado localizado no canto inferior direito do navegador da Web.
  3. Clique na guia Detalhes.
  4. Observe as informações nos seguintes campos:
    • Válido até
      O campo Válido até indica a data até a qual o certificado é válido.
    • Assunto
      A data no campo Assunto deve ser correspondente ao nome do site.

Método 2: Instalar o certificado raiz confiável

Use esse método se você receber a mensagem de erro 3. Para instalar o certificado raiz confiável, execute as seguintes etapas:
  1. Clique em Instalar certificado quando a caixa de diálogo Certificado solicitar.
  2. Clique em Avançar.
  3. Marque a caixa de seleção Colocar todos os certificados no armazenamento a seguir.
  4. Clique em Procurar.
  5. Clique em Autoridades de certificação raiz confiáveis e em OK.
  6. Clique em Avançar.
  7. Clique em Concluir.
  8. Clique em OK.

Mais Informações

Os códigos de problemas de certificado bitmask estão listados na tabela a seguir.
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DescriçãoCódigo de erro
FLAG_CERT_REV_FAILED0x00000001
FLAG_INVALID_CERT0x00000002
FLAG_CERT_REVOKED0x00000004
FLAG_INVALID_CA0x00000008
FLAG_CERT_CN_INVALID0x00000010
FLAG_CERT_DATE_INVALID0x00000020
FLAG_CERT_WRONG_USAGE0x00000040
FLAG_SECURITY_CHANNEL_ERROR0x80000000

A informação contida neste artigo aplica-se a:
  • Microsoft Office Outlook 2007
Palavras-chave: 
kberrmsg kbtshoot kbprb kbexpertisebeginner KB923575