A client computer may not be authenticated by ISA Server 2006 or ISA Server 2004 when you use integrated Windows authentication

Article translations Article translations
Article ID: 923766 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • A Web proxy client computer tries to connect to a Web site through a computer that is running Microsoft Internet Security and Acceleration (ISA) Server 2006 or Microsoft Internet Security and Acceleration (ISA) Server 2004.
  • ISA Server is configured to request integrated Windows authentication from the client computer.
  • The client computer uses the HTTP 1.0 protocol to send connection requests to ISA Server.
In this scenario, the client computer may not be authenticated by ISA Server. Additionally, the client computer is repeatedly prompted to provide credentials or receives authentication error messages.

Note This problem may occur when the client computer tries to connect to either secure (HTTPS) Web pages or nonsecure (HTTP) Web pages.

CAUSE

This problem occurs if the client computer does not send connection requests that contain either a "Proxy-Connection: Keep-Alive" header or a "Connection: Keep-Alive" header to ISA Server. If a request that uses the HTTP 1.0 protocol does not contain either a "Proxy-Connection: Keep-Alive" header or a "Connection: Keep-Alive" header, ISA Server closes the connection during the authentication process.

Integrated Windows authentication is a session-based authentication method that requires the whole authentication process to occur over the same connection without any disconnects.

Note This problem typically occurs when you use integrated Windows authentication. This problem may not occur when you use other authentication methods, such as basic proxy authentication.

RESOLUTION

To resolve this problem, install the latest ISA Server service pack.
For more information about how to obtain the latest service pack for ISA Server 2006, click the following article number to view the article in the Microsoft Knowledge Base:
954258 How to obtain the latest Internet Security and Acceleration (ISA) Server 2006 Service Pack

For more information about how to obtain the latest service pack for ISA Server 2004, click the following article number to view the article in the Microsoft Knowledge Base:
891024 How to obtain the latest ISA Server 2004 Service Pack

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information about how to install ISA Server hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:
885957 How to install ISA Server hotfixes and updates

Properties

Article ID: 923766 - Last Review: March 24, 2009 - Revision: 2.0
APPLIES TO
  • Microsoft Internet Security and Acceleration Server 2006 Enterprise Edition
  • Microsoft Internet Security and Acceleration Server 2006 Standard Edition
  • Microsoft Internet Security and Acceleration Server 2004 Enterprise Edition
  • Microsoft Internet Security and Acceleration Server 2004 Standard Edition
Keywords: 
kbqfe kbtshoot kbprb KB923766

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com