CORRECÇÃO: O recurso AutoCompletar não funciona após você clicar em um hiperlink de JavaScript em uma página da Web no Internet Explorer 6

Traduções deste artigo Traduções deste artigo
ID do artigo: 924301 - Exibir os produtos aos quais esse artigo se aplica.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário. No Microsoft Internet Explorer 6, você digita texto em um campo em um formulário. Em seguida, clicar em um hiperlink JavaScript em uma página da Web. Nesse cenário, o recurso AutoCompletar não funciona. Quando você digita o mesmo texto no mesmo campo no formulário, a caixa de AutoCompletar não é exibida.

Causa

Esse problema ocorre devido a um problema no recurso AutoCompletar no Internet Explorer 6. O problema no recurso AutoCompletar ocorre após clicar no hiperlink de JavaScript.

Resolução

Windows XP

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.
Pré-requisitos
Para aplicar esse hotfix, você deve ter o Microsoft Windows XP Service Pack 2 (SP2) instalado no computador.
Requisitos de reinicialização
Reinicie o computador após aplicar esse hotfix.
Informações sobre a substituição do hotfix
Esse hotfix não substitui outros hotfixes.
Informações sobre o arquivo
A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Shdocvw.dll6.0.2900.30091,497,60005 De outubro de 200612: 15x 86
Informações do registro
Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Depois de aplicar esse hotfix, você deve habilitar esse hotfix. Para fazer isso, execute as seguintes etapas:
  1. Certifique-se de que você sair dele.
  2. Clique em Iniciar , clique em Executar , digite regedit na caixa Abrir e, em seguida, clique em OK .
  3. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  4. No menu Editar , aponte para novo e, em seguida, clique em chave .
  5. Digite FEATURE_INTELLIFORMS_ALTERNATE_RELEASE_KB924301 e, em seguida, pressione ENTER.
  6. Clique em FEATURE_INTELLIFORMS_ALTERNATE_RELEASE_KB924301 .
  7. No menu Editar , aponte para novo e, em seguida, clique em Valor DWORD .
  8. Digite iexplore.exe e, em seguida, pressione ENTER.
  9. Clique com o botão direito do mouse iexplore.exe e, em seguida, clique em Modificar .
  10. Na caixa dados do valor , digite 1 e, em seguida, clique em OK .

Windows Server 2003

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Server 2003. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
889100Como obter o service pack mais recente para o Windows Server 2003

Informações sobre o hotfix

Para resolver esse problema no Microsoft Windows Server 2003, aplique o hotfix descrito no seguinte artigo da Base de dados de Conhecimento Microsoft:
931298CORRECÇÃO: O recurso AutoCompletar não funciona após você clicar em um hiperlink de JavaScript em uma página da Web no Internet Explorer 6

Como Contornar

Para contornar esse problema, atualize a página da Web para ativar o recurso AutoCompletar.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a". Esse problema foi corrigido primeiro no Windows Server 2003 Service Pack 2.

Mais Informações

Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software
Os produtos de terceiros mencionados neste artigo são fabricados por empresas que são independentes da Microsoft. Microsoft não oferece garantia, implícita ou não, sobre o desempenho ou confiabilidade desses produtos.

Propriedades

ID do artigo: 924301 - Última revisão: quinta-feira, 15 de novembro de 2007 - Revisão: 4.6
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Explorer 6.0
  • Microsoft Windows XP Service Pack 2 nas seguintes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Palavras-chave: 
kbmt kbautohotfix kbwinserv2003sp2fix kbexpertiseinter kbwinxpsp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB924301 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 924301

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com