Mensaje de error de revisión: Cuando utiliza la propiedad document.domain para cambiar el dominio de la página Web antes de llamar al método de envío en Internet Explorer 6: "Acceso denegado"

Seleccione idioma Seleccione idioma
Id. de artículo: 924347 - Ver los productos a los que se aplica este artículo
importante Este artículo contiene información acerca de cómo modificar el registro. Compruebe que ha hecho una copia de seguridad del Registro antes de modificarlo. Compruebe que sabe restaurar el Registro en caso de que se produzca algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y modificar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente. En Microsoft Internet Explorer 6, un usuario intenta enviar un formulario en una página Web. En el código de página Web, utilice la propiedad de document.domain para cambiar el dominio de la página Web antes de llamar al método submit . En este escenario, el usuario puede recibir el siguiente mensaje de error de secuencia de comandos:
Acceso denegado

Causa

El problema se produce cuando se cumplen las condiciones siguientes:
  • Antes de llamar a método submit , establezca la propiedad document.domain para la página Web en un dominio común menos restrictivo.
  • Después de llamar al método submit , restablece la propiedad document.domain para la página Web en el dominio completo original.
Cuando restablece la propiedad document.domain para la página Web en el dominio original, Internet Explorer no guardará el dominio original como el contexto de seguridad para la página Web. Por lo tanto, se infringe la seguridad entre dominios porque los dominios no coinciden. Después de Internet se devuelve desde el método submit , Internet Explorer provoca mensaje de error la secuencia de comandos.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado en el equipo Microsoft Windows XP Service Pack 2 (SP2).

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Mshtml.dll6.0.2900.29923,058,68808-Septiembre de 200612: 59x 86

Información del registro

Advertencia Pueden producirse problemas graves si modifica incorrectamente el registro mediante el Editor del registro o utilizando otro método. Estos problemas pueden requerir que reinstale el sistema operativo. Microsoft no puede garantizar la solución de esos problemas. Modifique el Registro bajo su responsabilidad.

Después de aplicar esta revisión, debe habilitar esta revisión. Para ello, siga estos pasos:
  1. Asegúrese de que salga de Internet Explorer.
  2. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar .
  3. Busque y haga clic en la siguiente subclave del Registro:
    Explorer\Main\FeatureControl HKEY_CURRENT_USER\Software\Microsoft\Internet
  4. En el menú Edición , seleccione nuevo y, a continuación, haga clic en clave .
  5. Escriba FEATURE_ENABLE_DOCUMENT_DOMAIN_UNDO_KB924347 y, a continuación, presione ENTRAR.
  6. Haga clic en FEATURE_ENABLE_DOCUMENT_DOMAIN_UNDO_KB924347 .
  7. En el menú Edición , seleccione nuevo y, a continuación, haga clic en Valor DWORD .
  8. Escriba iexplore.exe y, a continuación, presione ENTRAR.
  9. Haga clic con el botón secundario del mouse en iexplore.exe y, a continuación, haga clic en Modificar .
  10. En el cuadro datos del valor , escriba 1 y, a continuación, haga clic en Aceptar .

Solución

Para evitar este problema, no cambia la propiedad document.domain para la página Web antes de llamar al método submit .

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la propiedad document.domain , visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
http://msdn2.microsoft.com/en-us/library/ms533740.aspx
Para obtener más información acerca de la terminología relativa de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 924347 - Última revisión: jueves, 15 de noviembre de 2007 - Versión: 1.3
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0
  • Microsoft Windows XP Service Pack 2 sobre las siguientes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbexpertiseadvanced kbwinxpsp2fix kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB924347 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 924347

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com