Event ID 257 is logged in the System event log several times on a Windows Server 2003-based computer

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Article ID: 924390 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You use Net Appliance backup applications on a Microsoft Windows Server 2003-based computer.
  • You add a disk device to the computer.
In this scenario, the following event is logged in the System event log several times:

Event Type: Warning
Event Source: PlugPlayManager
Event Category: None
Event ID: 257
Date: Date
Time: Time
User: N/A
Computer: Computer Name
Description: Timed out sending notification of target device change to window of "Application Name"

CAUSE

This problem occurs because the Dmadmin.exe process is not responding. When you add a disk device to the computer, the Plug and Play service deletes a volume object and then creates a new volume object that has a different name. However, the Dmadmin.exe process waits for the volume object that the Plug and Play service deleted.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dmadmin.exe5.2.3790.2865234,49619-Jan-200711:46x86SP1SP1QFE
Dmadmin.exe5.2.3790.4007235,00818-Jan-200719:04x86SP2SP2QFE
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dmadmin.exe5.2.3790.2865743,93621-Jan-200718:03IA-64SP1SP1QFE
Dmadmin.exe5.2.3790.4007744,44821-Jan-200718:19IA-64SP2SP2QFE
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dmadmin.exe5.2.3790.2865400,38421-Jan-200718:07x64SP1SP1QFE
Dmadmin.exe5.2.3790.4007400,38421-Jan-200718:16x64SP2SP2QFE

WORKAROUND

You can safely ignore Event ID 257 if this event does not fill up the System event log.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
835473 Event IDs 257, 12, and 51 are logged on a Windows Server 2003-based computer

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 924390 - Last Review: October 9, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
kbautohotfix kbwinserv2003postsp2fix kbexpertiseinter kbbug kbfix kbHotfixServer kbqfe KB924390

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