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Error message when you try to reinstall an InfoPath 2007 form template: "The form is already installed on this computer"

Article ID:924392
Last Review:November 3, 2006
Revision:1.2
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/) Description of the Microsoft Windows registry
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SYMPTOMS

Consider the following scenario:
You install a Microsoft Office InfoPath 2007 form template.
You delete the installed InfoPath 2007 form template (.xsn) file.
You uninstall the InfoPath 2007 form template.
You try to reinstall the InfoPath form template.
In this scenario, you receive the following error message:
The form is already installed on this computer. You must unintall the current form before you can install a new version of the form. To uninstall the current form, use Add or Remove Programs in Control Panel.

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CAUSE

This issue occurs because you manually deleted the installed form template (.xsn) file before you uninstalled the form template.

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WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To work around this issue, follow these steps:
1. Click Start, click Run, type regedit, and then click OK.
2.Locate and then click the registry subkey that has the form ID of the deleted form template. The registry subkey has a value that resembles the following:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\InfoPath\SolutionsCatalog\urn:schemas-microsoft-com:office:infopath:TemplateName:-myXSD-2006-08-25T13-53-37
3. On the Edit menu, click Delete, and then click Yes to confirm.

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MORE INFORMATION

Steps to reproduce the issue

1.Create an installation file in Microsoft InfoPath 2007. To do this, follow these steps:
a. Start InfoPath 2007.
b. Click Design a Form Template, click Blank, and then click OK.
c. On the File menu, click Publish, enter a name for the form template, and then click Save.
d. Click As an installable form template (.js or .msi file), and then click Next.
e. Click Microsoft Installer (.msi) file, and then click Next.
f. Select a location for the installation file, click Next, click Publish, and then click Close.
2. Double-click the installation file to install the template.

Note By default this file will be installed to the %ProgramFiles%\TemplateName folder.
3. Delete the installed form template (.xsn) file.
4. Right-click the installation file, and then click Uninstall to uninstall the template.
5. Double-click the installation file. You receive the error message that is mentioned in the "Symptoms" section.

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APPLIES TO
Microsoft Office InfoPath 2007

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Keywords: 
kbtshoot kbexpertiseinter kbprb KB924392

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