Article ID: 924663 - Last Review: October 11, 2007 - Revision: 2.6

Print jobs take longer to finish than you expect in a Terminal Services session in Windows Server 2003

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SYMPTOMS

In Microsoft Windows Server 2003, print jobs may take longer to finish than you expect in a Terminal Services session that does not use Microsoft Windows Explorer.

CAUSE

This problem occurs because the print spooler waits for a Windows Explorer window to display a print notification. The print spooler waits even though the notification does not appear when Windows Explorer is not running.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Updspapi.dll6.2.29.0371,42412-Oct-200523:13x86
Winspool.drv5.2.3790.2778150,52825-Aug-200617:29Not Applicable
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winspool.drv5.2.3790.2778252,92826-Aug-200618:50Not Applicable
Wwinspool.drv5.2.3790.2778150,52826-Aug-200618:50Not Applicable
Updspapi.dll6.2.29.0462,04826-Aug-200618:55x64
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Winspool.drv5.2.3790.2778410,11226-Aug-200618:50Not Applicable
Wwinspool.drv5.2.3790.2778150,52826-Aug-200618:50Not Applicable
Updspapi.dll6.2.29.0638,68826-Aug-200618:55IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbfileprintservices kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB924663
 

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