The update operation times out when you try to update Antigen 9.0 for Exchange scan engines

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Article ID: 924705 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

When you try to update the Microsoft Antigen 9.0 for Exchange scan engines, one or more engine updates may be unsuccessful. In this situation, you experience the following symptoms:
  • The engine update operation times out.
  • Information that resembles the following is logged in the %ProgramFiles%\Microsoft Antigen for Exchange\ProgramLog.txt file:
    "INFORMATION: Attempting to download the Sophos scan engine package from http://antigendl.microsoft.com/antigen/x86/Sophos."
    "ERROR: UpdateException: GetFileCommand failed on sophos_fullpkg.cab.  (0x00002ee2) The operation timed out.  WinHttpClient failed while receiving a response."
    "INFORMATION: The Sophos scan engine for Antigen has been rolled back

CAUSE

This problem occurs because of the default time-out value for calls that the WinHTTP process makes. By default, any calls that the WinHTTP process makes have a 30-second time-out value. Therefore, during periods of high network activity, or in an environment that has insufficient bandwidth, the Antigen 9.0 for Exchange engine update process may time out before the engine download operation has finished.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

There are no prerequisites for installing this hotfix.

Restart requirement

Generally, you do not have to restart the computer after you apply this hotfix. The update package automatically stops and then restarts the appropriate services on the computer. However, if these services cannot be stopped, or if files are open, you may have to restart the computer to finish the installation of this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Getenginefiles.exe9.0.1055.23526,84811-Sep-200618:28x86

Hotfix installation information

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply this hotfix, you can you can increase the default time-out for WinHTTP calls. To do this, create the following registry entry:
HKEY_LOCAL_MACHINE\SOFTWARE\Sybari Software\Antigen for Exchange


Value name: GetFileHTTPTimeout
Value type: REG_DWORD
Value data: milliseconds (decimal)
In this registry entry, replace milliseconds with the number of milliseconds that you want to configure as the new time-out value.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 924705 - Last Review: September 23, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Antigen 9.0 for Exchange
Keywords: 
fpe2010sweptdoesnotapply kbautohotfix kbbug kbfix kbHotfixServer kbqfe KB924705

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