Internet Explorer 6 stops responding when you try to print a Web page or try to view a print preview of a Web page on a Windows XP Service Pack 2-based computer

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Article ID: 924764 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You are running Microsoft Internet Explorer 6 on a Microsoft Windows XP Service Pack 2 (SP2)-based computer.
  • You try to print a Web page or try to view a print preview of a Web page in Internet Explorer 6 by using a cascading style sheet (CSS).
  • You specify a negative value for the margin-top attribute in the CSS.
In this scenario, Internet Explorer 6 stops responding.

CAUSE

This problem occurs because of a bug in the Mshtml.dll file.

RESOLUTION

Security update information

To resolve this problem, install the most current cumulative security update for Internet Explorer. To install the most current updates, visit the following Microsoft Web site:
http://update.microsoft.com
For more technical information about the most current cumulative security update for Internet Explorer, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/current.aspx
Note This fix was first included in security update 947864 (MS08-024). For more information, click the following article number to view the article in the Microsoft Knowledge Base:
947864 MS08-024: Cumulative Security Update for Internet Explorer

924764 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on your computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll6.0.2900.29923,058,68808-Sep-200613:00x86

WORKAROUND

To work around this problem, do not specify a negative value for the margin-top attribute in the CSS.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 924764 - Last Review: October 9, 2011 - Revision: 4.0
APPLIES TO
  • Microsoft Internet Explorer 6.0
Keywords: 
kbautohotfix kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug kbqfe KB924764

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