An SMS 2003 management point computer receives many 10907 status messages and stops responding

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Article ID: 924842 - View products that this article applies to.
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SYMPTOMS

After you turn on the Software Metering Client Agent in Microsoft Systems Management Server (SMS) 2003, the computer may receive many 10907 status messages. When this problem occurs, the computer may stop responding.

CAUSE

This problem occurs if the following conditions are true:
  • Each SMS 2003 management point serves many SMS clients.
  • The software metering rules for the SMS clients are configured to monitor many executable files.
A 10907 status message indicates that an SMS client computer has received a rule. When this problem occurs, the SMS\MP\OUTBOXES\STAT.BOX folder on the SMS management point contains many 10907 status messages from SMS clients. Therefore, the computer may stop responding when the management point File Dispatch Manager tries to read the contents of the SMS\MP\OUTBOXES\STAT.BOX folder.

If 500 software metering rules apply to 500 SMS clients, the SMS 2003 management point receives 250,000 10907 status messages.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Note This hotfix disables the generation of 10907 status messages on the client computer.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Mtrmgr.dll2.50.3174.1177159,23219-Sep-200623:42x86
Swmtrschema.mof1,45819-Sep-200623:42Not Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The SMS 2003 Software Metering component requires creating a unique rule for each program file that is monitored. Clients that receive and apply Software Metering Policy rules acknowledge receipt of each rule with a 10907 status message. Configuring SMS 2003 software metering to monitor 500 application files requires creating 500 unique software metering rules.

A client that receives 500 software metering rules responds to the management point site server with 500 10907 status messages. This results in the generation of 250,000 client 10907 status messages in the scenario in which the management point services 500 clients. Therefore, it is possible to overwhelm or to saturate a management point if the number of Software Metering Policy rules together with the number of clients that are serviced generates more client 10907 status messages than the management point can process.

The number of 10907 status messages a management point can process depends on the hardware configuration, the workload, and other variables. A large and growing volume of 10907 status messages in the Stat.Box folder is an indicator that the management point is saturated.
For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 924842 - Last Review: July 24, 2007 - Revision: 2.4
APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbfix kbqfe kbhotfixserver kbexpertiseinter kbsms2003spfix kbsms200sp2fix KB924842

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