Lorsque vous redémarrez Windows Server 2003, l'ordinateur peut afficher un écran gris ou peut sembler cesser de répondre

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256986 Description du Registre de Microsoft Windows
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Sommaire

Résumé

Le fichier Lsass.exe dans Microsoft Windows Server 2003 est identifié en tant que fichier infecté et mis en quarantaine par la signature antivirus Computer Associates (CA) eTrust 303.3.30.54. En raison de ce problème, il est possible qu'un écran gris s'affiche au redémarrage de l'ordinateur. L'ordinateur peut sembler cesser de répondre.

Symptômes

Lorsque vous redémarrez Windows Server 2003, l'ordinateur peut afficher un écran gris ou peut sembler cesser de répondre. L'ordinateur peut répondre à une commande ping. Toutefois, vous ne pouvez pas accéder à l'ordinateur d'une autre manière. Un message d'avertissement concernant le virus Win32/Lasssrv.b peut aussi rapidement s'afficher.

Cause

Ce problème se produit car le fichier Lsass.exe a été mis en quarantaine par le logiciel Computer Associates eTrust, alors que ce fichier n'est pas réellement infecté.

La signature antivirus CA 303.3.30.54 identifie le fichier Lsass.exe en tant que virus. Elle supprime ou met en quarantaine le fichier, suivant la configuration du client. Pour plus d'informations, reportez-vous au site Web CA à l'adresse suivante (en anglais) :
http://supportconnect.ca.com/sc/kb/techdetail.jsp?searchID=TEC405236&docid=405236&bypass=yes&fromscreen=kbresults

Contournement

Pour contourner ce problème, remplacez le fichier Lsass.exe. Appliquez l'une des méthodes ci-dessous pour remplacer le fichier Lsass.exe.

Méthode 1 : Démarrage de la console de récupération, puis remplacement du fichier Lsass.exe

  1. Démarrez la console de récupération, puis tapez le nombre correspondant à l'installation souhaitée.
  2. Tapez le mot de passe de l'administrateur local pour l'ordinateur.
  3. Tapez la commande suivante :
    copy c:\windows\system32\dllcache\lsass.exe c:\windows\system32\lsass.exe
    Remarque Si le message d'erreur « Fichier introuvable » s'affiche lors de l'exécution de cette commande, vous devez copier le fichier Lsass.exe d'un ordinateur opérationnel sur une disquette. Vous pouvez également extraire le fichier d'un Service Pack puis le copier sur une disquette. Dans ce cas, tapez la commande suivante :
    copy a:\lsass.exe c:\windows\system32\lsass.exe
  4. Redémarrez l'ordinateur en mode sans échec.
  5. Désactivez tous les services antivirus. Pour cela, procédez comme suit :

    Important Ces étapes peuvent augmenter le risque de sécurité et rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d'utilisateurs malintentionnés ou de logiciels nuisibles tels que les virus. Nous recommandons d'exécuter le processus décrit par cet article pour permettre aux programmes de fonctionner normalement ou pour implémenter des fonctionnalités spécifiques du programme. Avant de procéder à ces modifications, nous vous recommandons d'évaluer les risques associés à l'implémentation de ce processus dans votre environnement propre. Si vous décidez d'implémenter ce processus, prenez toutes les mesures nécessaires pour protéger votre système. Nous vous recommandons d'utiliser ce processus uniquement si vous en avez vraiment besoin.
    1. Cliquez sur Démarrer, sur Exécuter, tapez msconfig, puis cliquez sur OK.
    2. Cliquez sur l'onglet Services.
    3. Cliquez sur Masquer tous les services Microsoft, puis désactivez tous les services antivirus.
  6. Redémarrez l'ordinateur, puis mettez à jour la signature CA. Pour mettre à jour la signature, reportez-vous au site Web de CA à l'adresse suivante (en anglais) :
    http://www3.ca.com/support/vicdownload/SignDownload.aspx?CID=
    Si le fichier Lsass.exe ne figure pas dans la liste des dossiers Dllcache, vous devrez peut-être vous le procurer en appliquant une autre méthode.

Méthode 2 : Utilisation de la console de récupération pour désactiver les services eTrust

Important Ces étapes peuvent augmenter le risque de sécurité et rendre votre ordinateur ou votre réseau plus vulnérable aux attaques d'utilisateurs malintentionnés ou de logiciels nuisibles tels que les virus. Nous recommandons d'exécuter le processus décrit par cet article pour permettre aux programmes de fonctionner normalement ou pour implémenter des fonctionnalités spécifiques du programme. Avant de procéder à ces modifications, nous vous recommandons d'évaluer les risques associés à l'implémentation de ce processus dans votre environnement propre. Si vous décidez d'implémenter ce processus, prenez toutes les mesures nécessaires pour protéger votre système. Nous vous recommandons d'utiliser ce processus uniquement si vous en avez vraiment besoin.
  1. Démarrez la console de récupération.
  2. Désactivez les processus suivants :
    • eTrust Antivirus Job Server
    • eTrust Antivirus Realtime Server
    • eTrust Antivirus RPC Server
    Remarque Si vous ne désactivez pas ces processus eTrust, le fichier Lsass.exe sera mis à nouveau en quarantaine.
  3. Copiez le fichier Lsass.exe dans les dossiers C:\Windows\System32\Dllcache et C:\Windows\System32 .
  4. Redémarrez l'ordinateur, puis mettez à jour la signature CA. Pour mettre à jour la signature, reportez-vous au site Web de CA à l'adresse suivante (en anglais) :
    http://www3.ca.com/support/vicdownload/SignDownload.aspx?CID=

Méthode 3 : Utilisation de l'environnement de préinstallation Windows ou d'une installation parallèle sur le système pour obtenir un accès

Avertissement Des problèmes sérieux peuvent se produire si vous modifiez le Registre de façon incorrecte à l'aide de l'Éditeur du Registre ou toute autre méthode. Ces problèmes peuvent vous obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes puissent être résolus. Vous assumez l'ensemble des risques liés à la modification du Registre.

Remarque N'appliquez cette méthode que si la console de récupération ne peut pas être utilisée.
  1. Déterminez si l'ordinateur exécute ou pas Windows Server 2003 Service Pack 1 (SP1). Pour cela, suivez l'une des étapes ci-dessous. Si vous avez accès à l'environnement de préinstallation Windows (Windows PE), suivez la première étape.
    • Démarrez Windows PE, lancez l'Éditeur du Registre, sélectionnez HKEY_local_machine, puis Charger la ruche dans le menu Fichier, accédez au répertoire C:\Windows\System32\Config\Software, puis déterminez la valeur de CSDVersion REG_SZ sous la sous-clé de Registre suivante :
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
    • Placez une installation parallèle sur le serveur, démarrez l'Éditeur du Registre, sélectionnez HKEY_local_machine, Charger la ruche dans le menu Fichier, accédez au répertoire C:\Windows\System32\Config\Software, puis déterminez la valeur de CSDVersion REG_SZ sous la sous-clé de Registre suivante :
      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
  2. Procédez à l'extraction du fichier Lsass.exe à partir d'un CD Windows, ou copiez le fichier à partir d'un serveur qui ne connaît pas ce problème et qui est au même niveau de Service Pack.

    Remarque Si vous avez effectué une installation parallèle, vous pouvez appliquer Windows Server 2003 SP1 si nécessaire, puis copier le fichier Lsass.exe de l'installation parallèle.

Propriétés

Numéro d'article: 924995 - Dernière mise à jour: vendredi 13 avril 2007 - Version: 1.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003 Service Pack 1
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Mots-clés : 
kbtshoot kbprb KB924995
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