Article ID: 925138 - Last Review: October 21, 2008 - Revision: 3.0

The accounting function of Windows System Resource Manager (WSRM) returns incorrect values in Windows Server 2003 x64 versions

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SYMPTOMS

When you use the accounting function of Microsoft Windows System Resource Manager (WSRM) in x64-based versions of Microsoft Windows Server 2003, some of the values that WSRM returns are incorrect. For example, you may see values that resemble the following in the WSRM console:
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Page File Usage (KB)Peak Page File Usage (KB)Peak Working Set Size (KB)
184467440737084064131844674407370846237318446744073708333281
Note In this example, the values that WSRM returns are abnormally large.

Note This problem occurs on x64-based and x86-based versions Windows Server 2003. The problem occurs on the x86-based computers if they have more than 4 gigabytes of memory and are running Windows Server 2003 Enterprise edition with the Physical Addressing Extension (PAE) enabled.

CAUSE

The accounting function of WSRM uses 64-bit integer values that Windows Management Instrumentation (WMI) returns. However, WMI returns 32-bit integer values. Therefore, the upper 32 bits of the 64-bit integer value are not initialized and contain random data. The random data makes the 64-bit integer values incorrect.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100  (http://support.microsoft.com/kb/889100/ ) How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.After you apply this hotfix, WMI returns the values in kilobytes instead of bytes.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP1 installed on the computer.

Restart requirement

You must restart the Windows Management Instrumentation service and the Windows System Resource Manager service after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Cimwin32.dll5.2.3790.27941,372,67216-Sep-200611:50x86SP1
Wsrm.exe1.2.727.1446,97616-Sep-200609:05x86SP1
Windows Server 2003, x64-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Cimwin32.dll5.2.3790.27942,352,12815-Sep-200621:18x64SP1
Wsrm.exe1.2.727.1805,88815-Sep-200621:18x64SP1
Windows Server 2003, Itanium-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Cimwin32.dll5.2.3790.27945,041,15215-Sep-200621:20IA-64SP1
Wsrm.exe1.2.727.11,403,90415-Sep-200621:20IA-64SP1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
kbautohotfix kbwinserv2003sp2fix kbbug kbfix kbhotfixserver kbqfe kbwinserv2003presp1fix kbpubtypekc KB925138
 

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