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After you import a Package Definition File (.pdf) that contains dependent programs in SMS 2003, the dependent programs are not run

Article ID:925142
Last Review:October 1, 2007
Revision:1.3
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SYMPTOMS

You use the Create Package From Definition Wizard in Microsoft Systems Management Server (SMS) 2003 to import a Package Definition File (.pdf) that contains dependent programs. When the package is run on SMS client computers, only the parent program is run. The dependent programs are not run successfully. However, the SMS client computer reports that the package was run successfully.

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CAUSE

When you use the SMS Administrator Console or the Create Package From Definition Wizard to create a package that contains a program dependency, a new entry that is named PackageID;;ProgramName is created in the DependentProgram column of the PkgPrograms table in the SMS database. However, when you import a .pdf file that contains a program dependency, only the ;;ProgramName entry is created in the DependentProgram column. Because the DependentProgram column does not contain the PackageID entry that references the dependent program, the package is not run successfully.

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Smsse.dll2.50.2726.999977,82428-Jun-200521:31x86
Sms_mdef.dll2.50.4160.2119196,60801-Mar-200610:30x86
Smsse.dll2.50.2726.999977,82428-Jun-200521:31x86

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Systems Management Server 2003

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Keywords: 
kbautohotfix kbfix kbqfe kbhotfixserver kbexpertiseinter kbsms2003spfix KB925142

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