FIX: When you generate a report to show the history of a source file, Visual SourceSafe 2005 may stop unexpectedly

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Article ID: 925275
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SYMPTOMS

When you try to generate a report to show the history of a source file in Microsoft Visual SourceSafe 2005, Visual SourceSafe may stop unexpectedly.

Note This problem does not occur if you use Microsoft Visual SourceSafe 6.0.

CAUSE

This problem occurs if the report contains specific characters. For example, this problem occurs if the report contains the percent sign (%).

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this software update.

Hotfix replacement information

This software update does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTime
ssgui.dll8.0.50727.2141,252,86419-Sep-200605:46
ssscc.dll8.0.50727.2141,264,64019-Sep-200607:17

WORKAROUND

To work around this problem, remove any occurrence of the percent sign (%) in the source files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce this problem

  1. Use Microsoft Visual SourceSafe 2005 Admin to create a new repository by using the default settings.
  2. Create a text file that is named Test.txt.
  3. Open Visual SourceSafe 2005 Solution Explorer, and then connect to the new repository that you created in step 1.
  4. Open the Test.txt file in the Visual SourceSafe root project to add it to the repository.
  5. Use Visual SourceSafe 2005 Solution Explorer to check out the Test.txt file, and then edit the Test.txt file in Notepad.
  6. Type %, and then save the file.
  7. Check in the Test.txt file.
  8. Right-click Test.txt, click Show History, keep all the default options, and then click OK.
  9. In the History of $/Test.txt dialog box, click Report.
  10. Click Include Differences, and then click Preview. Visual SourceSafe stops unexpectedly.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Article ID: 925275 - Last Review: October 8, 2011 - Revision: 3.0
Keywords: 
kbautohotfix kbprb kbbug kbfix kbexpertiseinter kbexpertisebeginner kbHotfixServer kbqfe KB925275

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