Artigo: 925520 - Última revisão: sexta-feira, 26 de Outubro de 2007 - Revisão: 2.7

Personalizar módulos GINA não funcionam depois de actualizar o computador para o Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Depois de actualizar o computador para o Windows Vista, módulos de gráficos de identificação e autenticação (GINA) personalizados deixam de funcionar.

Causa

Este comportamento ocorre porque a funcionalidade GINA que existiam em versões anteriores do Windows é substituída por um modelo de fornecedor de credenciais no Windows Vista. Por conseguinte, módulos GINA não funcionam depois de actualizar o computador para o Windows Vista.

Resolução

Utilize um dos seguintes procedimentos, conforme adequado à situação:
  • Se obteve o módulo GINA personalizado a partir de um fornecedor de software de outros fabricantes ou fornecedor de hardware de outros fabricantes, contacte o fornecedor para obter informações sobre uma substituição.
  • Se desenvolveu o módulo GINA personalizado, crie uma nova solução que utiliza o modelo de fornecedor de credenciais no Windows Vista.
Nota Personalizar módulos GINA utilize a seguinte subchave do registo:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\GinaDLL
Se a subchave GinaDLL estiver presente, contém o nome de um ficheiro de .dll GINA. A subchave GinaDLL não está presente nas instalações predefinidas do Windows.

Mais Informação

O modelo de fornecedor de credenciais no Windows Vista é uma arquitectura conectáveis que permite que os módulos que funcionam com as credenciais sejam escritos uma interface comum. Por isso, módulos podem trabalhar com vários componentes do sistema. Estes componentes incluem o componente LogonUI e o componente CredUI.

Para mais informações sobre a interface ICredentialProvider , consulte o tópico "Shell Interfaces" no Windows Software Development Kit (SDK). Para obter credenciais do Windows Vista amostras de fornecedor, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyID=1287ec56-77b4-48c4-8b58-35b7295d6c2c&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=1287ec56-77b4-48c4-8b58-35b7295d6c2c&displaylang=en)

A informação contida neste artigo aplica-se a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
Palavras-chave: 
kbmt kbexpertisebeginner kbtshoot kbprb KB925520 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 925520  (http://support.microsoft.com/kb/925520/en-us/ )