Personalizado módulos GINA não funcionam após atualizar seu computador para o Windows Vista

Traduções deste artigo Traduções deste artigo
ID do artigo: 925520 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Após atualizar seu computador para o Windows Vista, módulos personalizados de Graphical Identification and Authentication (GINA) não funcionam mais.

Causa

Esse comportamento ocorre porque a funcionalidade GINA que existia em versões anteriores do Windows é substituída por um modelo de provedor de credenciais do Windows Vista. Portanto, módulos GINA não funcionam após atualizar seu computador para o Windows Vista.

Resolução

Use um dos seguintes procedimentos, conforme apropriado para sua situação:
  • Se você adquiriu o módulo GINA personalizado de um fornecedor de software de terceiros ou fornecedores de hardware de terceiros, contate o fornecedor para saber mais sobre uma substituição.
  • Se você desenvolveu o módulo GINA personalizado, criar uma nova solução que usa o modelo de provedor de credenciais no Windows Vista.
Observação Personalizado módulos GINA usam a seguinte subchave do Registro:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\GinaDLL
Se a subchave GinaDLL estiver presente, ele contém o nome de um arquivo de DLL GINA. A subchave GinaDLL não está presente nas instalações padrão do Windows.

Mais Informações

O modelo de provedor de credenciais do Windows Vista é uma arquitetura conectável, que permite que módulos que funcionam com credenciais para ser gravados em uma interface comum. Portanto, os módulos podem trabalhar com vários componentes do sistema. Esses componentes incluem o componente LogonUI e o componente de CredUI.

Para obter mais informações sobre a interface ICredentialProvider , consulte o tópico "Interfaces do shell" no Windows Software Development Kit (SDK). Para obter credenciais do Windows Vista provedor exemplos, visite o seguinte site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=1287ec56-77b4-48c4-8b58-35b7295d6c2c&displaylang=en

Propriedades

ID do artigo: 925520 - Última revisão: sexta-feira, 26 de outubro de 2007 - Revisão: 2.7
A informação contida neste artigo aplica-se a:
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
Palavras-chave: 
kbmt kbexpertisebeginner kbtshoot kbprb KB925520 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 925520

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com