Id. de artículo: 925757 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

INTRODUCCIÓN

En este artículo paso a paso se describe cómo habilitar o deshabilitar los mensajes de advertencia cada vez que se hace clic en un hipervínculo en un programa de Microsoft Office 2007 o de Microsoft Office 2010. 

Más información

Importante Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. Sin embargo, la modificación incorrecta del Registro puede producir graves problemas. Por tanto, compruebe que sigue estos pasos cuidadosamente. Para obtener mayor protección, realice una copia de seguridad del Registro antes de modificarlo. De esta manera, puede restaurar el Registro si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad del Registro y restaurarlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows


En Office 2007 y Office 2010, al hacer clic en un hipervínculo o en un objeto que vincula a un archivo ejecutable, puede recibir el mensaje de advertencia siguiente:
Abriendo "ruta de acceso/nombre de archivo".
Los hipervínculos pueden dañar el equipo y los datos. Para proteger el equipo, haga clic solo en hipervínculos de orígenes de confianza. ¿Desea continuar?
Este comportamiento se produce independientemente de la configuración del nivel de seguridad.

Nota: para encontrar la configuración del nivel de seguridad, en el menú Herramientas, seleccione Macro y, a continuación, haga clic en Seguridad.

Además, cuando se abren imágenes TIFF o archivos de Microsoft Document Imaging (MDI), aparece el siguiente mensaje de advertencia:
Abriendo ruta de acceso/nombre de archivo.
Algunos archivos pueden contener virus o causar daños en el equipo. Asegúrese de que este archivo procede de un origen de confianza. ¿Desea abrir este archivo?
Este mensaje de advertencia aparece incluso cuando ya se ha implementado la clave del Registro que se describe en este artículo. Este mensaje de advertencia proviene del archivo HLINK.dll cuando se gestiona la navegación de los vínculos. La forma de diferenciar el mensaje de advertencia de los hipervínculos de Office 2007 o de Office 2010 del mensaje de advertencia de HLINK es observar las comillas alrededor de la ruta de acceso del archivo en el mensaje de advertencia. El mensaje de Office 2007 o de Office 2010 contiene comillas. El mensaje de HLINK no contiene comillas. Office 2007 y Office 2010 intentan determinar si el tipo de archivo no es seguro comprobando la extensión, el identificador de programa (progid), el identificador de clase (classid) y el tipo MIME del documento.

Cómo habilitar o deshabilitar globalmente advertencias de hipervínculos

Para que habilitemos las advertencias de hipervínculo en programas de Office 2007 o de Office 2010 en su lugar, vaya a la sección "Solucionarlo en mi lugar". Si prefiere habilitar esta configuración usted mismo, vaya a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar



Para solucionar el problema de forma automática, haga clic en el vínculo o en el botón Fix it. Haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y, a continuación, siga los pasos del Asistente de Fix it.
Contraer esta imagenAmpliar esta imagen
assets fixit1
Habilitar advertencias de hipervínculo
Microsoft Fix it 50681
Contraer esta imagenAmpliar esta imagen
assets fixit2


Notas
  • Este asistente podría estar sólo en inglés. Sin embargo, la solución automática también funciona con otras versiones de idioma de Windows. 
  • Si no está utilizando el equipo que tiene el problema, guarde la solución Fix it en una unidad flash o en un CD para posteriormente ejecutarla en el equipo con el problema.

A continuación, vaya a la sección "¿Esta información le ayudó a resolver su problema?".



Solucionarlo por mí mismo

Para habilitar o deshabilitar las advertencias de hipervínculo en programas de Office 2007 y de Office 2010 cuando se utiliza una dirección http://, notes:// o ftp://, debe crear una nueva subclave del Registro. Para ello, siga estos pasos: 
  1. Haga clic en Inicio y, a continuación, en Ejecutar.
  2. En el cuadro de diálogo Abrir, escriba regedit y, después, haga clic en Aceptar.

    Notas
    • Tiene que modificar solo una de estas subclaves del Registro. No tiene que modificar ambas.
    • Si la subclave Security ya existe, vaya directamente al paso 6 después de seleccionar dicha subclave.
  3. En el Editor del registro, busque una de las siguientes subclaves del Registro para Office 2007:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common
    O bien, en el Editor del Registro, busque una de las siguientes subclaves del registro para Office 2010:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common
  4. Haga clic en la subclave del Registro, seleccione Nuevo en el menú Edición y, a continuación, haga clic en Clave.
  5. Escriba Security y presione Entrar para asignar un nombre a la clave.
  6. En el menú Edición, seleccione Nuevo y haga clic en Valor DWORD.
  7. Escriba DisableHyperlinkWarning y presione Entrar para asignar un nombre a la entrada.
  8. En el panel derecho, haga clic con el botón secundario del mouse en DisableHyperlinkWarning y después haga clic en Modificar.
  9. En el cuadro de diálogo Editar valor DWORD, haga clic en Decimal y escriba 1 o 0 en Información del valor.

    Nota: el valor 0 habilita el mensaje de advertencia de hipervínculo. Un valor de 1 deshabilita el mensaje de advertencia de hipervínculo.
  10. Haga clic en Aceptar.
  11. Salga del Editor del Registro.

Cómo habilitar o deshabilitar advertencias de hipervínculos por protocolo

Para deshabilitar la presentación de advertencias de seguridad para un protocolo determinado, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  2. Busque la siguiente subclave del Registro:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Common\Security\Trusted Protocols\All Applications
    Nota: en esta subclave, sustituya "xx.0" por 12.0 para Outlook 2007 y por 14.0 para Outlook 2010.
  3. Haga clic en la subclave Todas las aplicaciones.
  4. En el menú Edición, seleccione Nuevo y haga clic en Clave.
  5. Escriba el nombre del protocolo que desea excluir. Por ejemplo, para deshabilitar la presentación de una advertencia de seguridad para el protocolo "Notas:", escriba Notas:.

    Nota:
    compruebe que ha incluido el carácter de dos puntos (:).
  6. Presione Entrar.
  7. Salga del Editor del Registro.

Si sigue recibiendo un mensaje de advertencia

Después de deshabilitar los mensajes de advertencia, puede que siga recibiendo un mensaje de advertencia de Microsoft Windows. Si continúa recibiendo un mensaje de advertencia después de seguir los pasos que se describen en este artículo, utilice uno de los métodos siguientes para resolver este problema.

Nota: el método 1 se aplica solo a Windows XP y a versiones anteriores de Windows. Para Windows Vista y versiones posteriores de Windows, utilice el método 2. 

Método 1: Desactivar la opción "Confirmar apertura después de la descarga" para el tipo de archivo que intenta abrir

  1. Haga doble clic en Mi PC.
  2. En el menú Herramientas, haga clic en Opciones de carpeta.
  3. En la pestaña Tipos de archivo, seleccione la extensión de archivo apropiada (por ejemplo, WMV) en el cuadro Tipos de archivo registrados y haga clic en el botón Opciones avanzadas.
  4. Haga clic en la casilla de verificación Confirmar apertura después de la descarga para desactivarla y, después, haga clic en Aceptar.
  5. En el cuadro de diálogo Opciones de carpeta, haga clic en Cerrar.

Método 2: modificar la subclave del Registro HKEY_CLASSES_ROOT\<CLSID>\EditFlags

Utilice este método si el mensaje de advertencia afecta a varios equipos. 

Para deshabilitar el mensaje de advertencia, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  2. Busque la siguiente subclave del Registro:
    HKEY_CLASSES_ROOT\<CLSID>\EditFlags
    Por ejemplo, si la extensión de nombre de archivo es WMV, seleccione HKEY_CLASSES_ROOT\WMVFile\EditFlags
  3. Haga clic en EditFlags y, en el menú Edición, haga clic en Cambiar nombre.
  4. Escriba OldEditFlags y, a continuación, presione Entrar.
  5. En el menú Edición, seleccione Nuevo y haga clic en Valor DWORD.
  6. Escriba EditFlags y presione ENTRAR.
  7. En el menú Edición, haga clic en Modificar.
  8. En el cuadro de diálogo Editar valor DWORD, haga clic en Hexadecimal debajo de Base.
  9. Escriba 10000 y, después, haga clic en Aceptar.
Para volver a habilitar el mensaje de advertencia, siga estos pasos:
  1. Haga clic en Inicio y en Ejecutar, escriba regedit y haga clic en Aceptar.
  2. Busque la siguiente subclave del Registro:
    HKEY_CLASSES_ROOT\<CLSID>\EditFlags
  3. Haga clic en EditFlags y, en el menú Edición, haga clic en Modificar.
  4. Escriba 0 y, después, haga clic en Aceptar.

Nota: aun después de haber seguido estos pasos, recibirá el mensaje de advertencia si abre archivos en Office 2010 con Vista protegida.



¿Esta información le ha ayudado a solucionar el problema?

  • Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede ponerse en contacto con el soporte técnico.
  • Valoramos sus comentarios. Para realizar algún comentario o informar de cualquier problema con esta solución, deje su comentario en el blog "Solucionarlo en mi lugar" o envíenos un mensaje de correo electrónico.
Nota: es un artículo de "PUBLICACIÓN RÁPIDA" creado directamente por la organización de soporte técnico de Microsoft. La información aquí contenida se proporciona como está, como respuesta a problemas que han surgido. Como consecuencia de la rapidez con la que lo hemos puesto disponible, los materiales podrían incluir errores tipográficos y pueden ser revisados en cualquier momento sin previo aviso. Vea las Condiciones de uso para otras consideraciones

Propiedades

Id. de artículo: 925757 - Última revisión: martes, 02 de julio de 2013 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office SharePoint Designer 2007
  • Microsoft Office Word 2007
  • Microsoft Excel 2010
  • Microsoft Word 2010
  • Microsoft PowerPoint 2010
  • Microsoft Publisher 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Outlook 2010
  • Microsoft OneNote 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Professional 2010
Palabras clave: 
kbexpertisebeginner kbhowto kbfixme kbmsifixme KB925757

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com