Numer ID artykułu: 925757 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

WPROWADZENIE

W tym artykule z instrukcjami krok po kroku opisano, jak włączyć lub wyłączyć wyświetlanie komunikatu ostrzegawczego za każdym razem po kliknięciu hiperłącza w programie pakietu Microsoft Office 2007 lub w programie pakietu Microsoft Office 2010.

Więcej informacji

Ważne W tej sekcji, metodzie lub w tym zadaniu podano informacje dotyczące modyfikowania rejestru. Niepoprawne zmodyfikowanie rejestru może jednak być przyczyną poważnych problemów. Dlatego należy uważnie wykonywać podane czynności. Aby zapewnić dodatkową ochronę, przed zmodyfikowaniem rejestru należy wykonać jego kopię zapasową. Dzięki temu w przypadku wystąpienia problemu będzie można przywrócić rejestr. Aby uzyskać więcej informacji dotyczących wykonywania kopii zapasowej i przywracania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Jak wykonywać kopię zapasową rejestru i przywracać go w systemie Windows


W pakiecie Office 2007 i Office 2010 po kliknięciu hiperłącza lub obiektu połączonego z plikiem wykonywalnym wyświetlany jest następujący komunikat ostrzegawczy:
Otwieranie „ścieżka/nazwa_pliku”.
Hiperłącza mogą być szkodliwe dla komputera i danych. Aby chronić komputer, klikaj tylko hiperłącza z zaufanych źródeł. Czy chcesz kontynuować?
Takie działanie występuje niezależnie od ustawień poziomu zabezpieczeń.

Uwaga Aby zlokalizować ustawienia poziomu zabezpieczeń, należy wskazać polecenie Makro w menu Narzędzia, a następnie kliknąć polecenie Zabezpieczenia.

Ponadto po otwarciu obrazów TIFF lub plików MDI (Microsoft Document Imaging) wyświetlany jest następujący komunikat ostrzegawczy:
Trwa otwieranie pliku ścieżka/nazwa_pliku.
Niektóre pliki mogą zawierać wirusy lub uszkodzić komputer w inny sposób. Upewnij się, że ten plik pochodzi z zaufanego źródła. Czy chcesz otworzyć ten plik?
Ten komunikat ostrzegawczy jest wyświetlany, nawet jeśli już zaimplementowano klucz rejestru opisany w tym artykule. Ten komunikat ostrzegawczy jest wysyłany przez plik HLINK.dll podczas obsługiwania nawigacji łącza. Komunikat ostrzegawczy dotyczący hiperłącza z pakietu Office 2007 lub Office 2010 można odróżnić od komunikatu ostrzegawczego pliku HLINK na podstawie cudzysłowów wokół ścieżki pliku w komunikacie ostrzegawczym. Komunikat pakietu Office 2007 lub Office 2010 zawiera cudzysłowy. Komunikat pliku HLINK nie zawiera cudzysłowów. Pakiety Office 2007 i Office 2010 usiłują określić, czy sam typ pliku jest niebezpieczny, sprawdzając rozszerzenie, identyfikator programu, identyfikator klasy i typ MIME dokumentu.

Jak włączyć lub wyłączyć ostrzeżenia dotyczące hiperłączy w programach pakietu Office 2007 i w programach pakietu Office 2010

Aby automatycznie włączyć ostrzeżenia o hiperłączach dla programów pakietu Office 2007 i programów pakietu Office 2010, przejdź do sekcji Automatyczne rozwiązywanie problemu. Aby samodzielnie włączyć ustawienie, przejdź do sekcji Samodzielne rozwiązywanie problemu.

Automatyczne rozwiązywanie problemu



Aby automatycznie rozwiązać problem, należy kliknąć przycisk lub łącze Fix it. W oknie dialogowym Pobieranie pliku należy kliknąć przycisk Uruchom i wykonać kroki kreatora rozwiązywania problemu.


Włącz ostrzeżenia o hiperłączach
Microsoft Fix it 50681


Uwagi
  • Ten kreator może być dostępny tylko w języku angielskim. Jednak ta poprawka automatyczna działa również w innych wersjach językowych systemu Windows.
  • Jeśli używany komputer nie jest tym, którego dotyczy problem, można zapisać to rozwiązanie w postaci poprawki automatycznej na dysku flash lub CD i uruchomić je na odpowiednim komputerze.

Teraz przejdź do sekcji Czy problem został rozwiązany?



Samodzielne rozwiązywanie problemu

Aby włączyć lub wyłączyć ostrzeżenia o hiperłączach w programach pakietu Office 2007 i w programach pakietu Office 2010, gdy jest używany adres http://, notes:// lub ftp://, należy utworzyć nowy podklucz rejestru. W tym celu należy wykonać następujące czynności:
  1. Kliknij przycisk Start, a następnie kliknij polecenie Uruchom.
  2. W polu Otwórz wpisz polecenie regedit, a następnie kliknij przycisk OK.

    Uwagi
    • Należy zmodyfikować tylko jeden z tych podkluczy rejestru. Nie jest konieczne modyfikowanie ich obu.
    • Jeśli podklucz Security już istnieje, należy przejść bezpośrednio do kroku 6 po wybraniu podklucza Security.
  3. W Edytorze rejestru zlokalizuj jeden z następujących podkluczy rejestru dla pakietu Office 2007:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\CommonHKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Common
    Ewentualnie w Edytorze rejestru zlokalizuj jeden z następujących podkluczy rejestru dla pakietu Office 2010:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\CommonHKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Common
  4. Kliknij podklucz rejestru, wskaż polecenie Nowy w menu Edycja, a następnie kliknij polecenie Klucz.
  5. Wpisz ciąg Security, a następnie naciśnij klawisz Enter, aby nadać nazwę kluczowi.
  6. W menu Edycja wskaż polecenie Nowy, a następnie kliknij polecenie Wartość DWORD.
  7. Wpisz ciąg DisableHyperlinkWarning, a następnie naciśnij klawisz Enter, aby nadać nazwę wpisowi.
  8. W prawym okienku kliknij prawym przyciskiem myszy pozycję DisableHyperlinkWarning, a następnie kliknij polecenie Modyfikuj.
  9. W oknie dialogowym Edytowanie wartości DWORD kliknij pozycję Dziesiętny, a następnie wpisz 1 lub 0 w obszarze Dane wartości.

    Uwaga Wartość 0 powoduje włączenie komunikatu ostrzegawczego o hiperłączu. Wartość 1 powoduje wyłączenie komunikatu ostrzegawczego o hiperłączu.
  10. Kliknij przycisk OK.
  11. Zakończ działanie Edytora rejestru.

Jeśli nadal jest wyświetlany komunikat ostrzegawczy

Po wyłączeniu komunikatów ostrzegawczych może być nadal wyświetlany komunikat ostrzegawczy systemu Microsoft Windows. Jeśli po wykonaniu czynności przedstawionych w tym artykule nadal jest wyświetlany komunikat ostrzegawczy, należy rozwiązać ten problem, używając jednej z następujących metod.

Uwaga Metodę 1 można zastosować tylko w systemie Windows XP lub we wcześniejszych wersjach systemu Windows. W przypadku systemu Windows Vista i nowszych wersji systemu Windows należy zastosować metodę 2.

Metoda 1. Wyłączenie opcji „Potwierdź otwarcie po pobraniu” dla typu pliku, który próbuje się otworzyć

  1. Kliknij dwukrotnie ikonę Mój komputer.
  2. W menu Narzędzia kliknij polecenie Opcje folderów.
  3. Na karcie Typy plików wybierz odpowiednie rozszerzenie nazwy pliku (na przykład WMV) w polu Zarejestrowane typy plików, a następnie kliknij przycisk Zaawansowane.
  4. Kliknij pole wyboru Potwierdź otwarcie po pobraniu, aby je wyczyścić, a następnie kliknij przycisk OK.
  5. W oknie dialogowym Opcje folderów kliknij przycisk Zamknij.

Metoda 2. Zmodyfikowanie podklucza rejestru HKEY_CLASSES_ROOT\WMVFile\EditFlags

Tej metody należy użyć, jeśli komunikaty ostrzegawcze są wyświetlane na wielu komputerach.

Aby wyłączyć komunikat ostrzegawczy, wykonaj następujące czynności:
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz ciąg regedit, a następnie kliknij przycisk OK.
  2. Zlokalizuj następujący podklucz rejestru:
    HKEY_CLASSES_ROOT\WMVFile\EditFlags
  3. Kliknij pozycję EditFlags, a następnie w menu Edycja kliknij polecenie Zmień nazwę.
  4. Wpisz nazwę OldEditFlags, a następnie naciśnij klawisz ENTER.
  5. W menu Edycja wskaż polecenie Nowy, a następnie kliknij polecenie Wartość DWORD.
  6. Wpisz nazwę EditFlags, a następnie naciśnij klawisz ENTER.
  7. W menu Edycja kliknij polecenie Modyfikuj.
  8. W oknie dialogowym Edytowanie wartości DWORD kliknij opcję Szesnastkowy w obszarze System.
  9. Wpisz wartość 10000, a następnie kliknij przycisk OK.
Aby ponownie włączyć komunikat ostrzegawczy, wykonaj następujące czynności:
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz ciąg regedit, a następnie kliknij przycisk OK.
  2. Zlokalizuj następujący podklucz rejestru:
    HKEY_CLASSES_ROOT\WMVFile\EditFlags
  3. Kliknij pozycję EditFlags, a następnie w menu Edycja kliknij polecenie Modyfikuj.
  4. Wpisz wartość 0, a następnie kliknij przycisk OK.

UwagaNawet po wykonaniu tych czynności komunikat ostrzegawczy będzie wyświetlany, jeśli pliki będą otwierane w pakiecie Office 2010 w widoku chronionym.



Czy problem został rozwiązany?

  • Należy sprawdzić, czy problem został rozwiązany. Jeśli problem został rozwiązany, to koniec pracy z tą sekcją. Jeśli problem nie został rozwiązany, można skontaktować się z pomocą techniczną.
  • Prosimy o opinię. Aby przekazać swoją opinię lub zgłosić jakiekolwiek problemy dotyczące tego rozwiązania, można zostawić komentarz w blogu Fix it for me (Automatyczne rozwiązywanie problemu) lub wysłać wiadomość e-mail.
Uwaga: Niniejszy artykuł, przeznaczony do „SZYBKIEJ PUBLIKACJI”, został utworzony bezpośrednio przez organizację pomocy technicznej firmy Microsoft. Zawarte w nim informacje są udostępniane „w stanie takim, w jakim są” w odpowiedzi na pojawiające się problemy. W wyniku przyspieszonego trybu udostępniania materiały mogą zawierać błędy typograficzne i mogą zostać poprawione w dowolnym momencie bez uprzedzenia. Więcej informacji można znaleźć w Warunkach użytkowania.

Właściwości

Numer ID artykułu: 925757 - Ostatnia weryfikacja: 20 grudnia 2011 - Weryfikacja: 1.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Office Basic 2007
  • Microsoft Office Enterprise 2007
  • Office 2007 dla Uzytkownikow Domowych
  • Microsoft Office Professional 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Access 2007
  • Microsoft Office Excel 2007
  • Microsoft Office Outlook 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Publisher 2007
  • Microsoft Office SharePoint Designer 2007
  • Microsoft Office Word 2007
  • Microsoft Excel 2010
  • Microsoft Word 2010
  • Microsoft PowerPoint 2010
  • Microsoft Publisher 2010
  • Microsoft Visio Professional 2010
  • Microsoft Visio Standard 2010
  • Microsoft Outlook 2010
  • Microsoft OneNote 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Professional 2010
Słowa kluczowe: 
kbexpertisebeginner kbhowto kbfixme kbmsifixme KB925757

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com