Messaggio di errore quando un computer basato su Windows Server 2003 con un livello elevato di attività di I/O: "le copie shadow del volume Volume_Name sono state interrotte perché il file area diff non può crescere in tempo"

Traduzione articoli Traduzione articoli
Identificativo articolo: 925799 - Visualizza i prodotti a cui si riferisce l?articolo.
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

Sintomi

Quando un computer basato su Windows Server 2003 dispone di un elevato livello di attività di I/O, nell'applicazione venga registrato il seguente messaggio di errore registro:
Tipo evento: errore
Origine evento: VolSnap
Categoria evento: nessuna
ID evento: 25
Descrizione: Le copie shadow del volume Volume_Name sono stati interrotta perché il file area diff non può crescere in tempo. Provare a ridurre il carico di I/O nel sistema per evitare questo problema in futuro.

Cause

Questo problema può verificarsi quando uno o più delle seguenti condizioni:
  • Il driver Volsnap.sys ha rilevato un numero eccessivo di I/O dell'attività. Di conseguenza, non è possibile aumentare l'area "diff".
  • Il computer ha esaurito spazio di archiviazione copia shadow.

Risoluzione

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Per risolvere il problema, utilizzare uno dei seguenti metodi:
  • Installare Windows Server 2003 Service Pack 1 (SP1). Per ulteriori informazioni su come ottenere Windows Server 2003 SP1, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
    889100Come ottenere il service pack più recente per Windows Server 2003
  • Quando la causa è spazio copia shadow insufficiente, doppia l'allocazione di spazio di archiviazione.
  • Utilizzare un disco di rigido secondo esclusivamente per spazio di archiviazione copia shadow.
  • Aumentare lo spazio libero disponibile sul volume che viene utilizzato.
  • Creare la seguente sottochiave di registro di sistema per modificare le dimensioni dell'area diff:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VolSnap\MinDiffAreaFileSize
    Per effettuare questa operazione, attenersi alla seguente procedura:
    1. Fare clic su Start , scegliere Esegui , digitare regedit e quindi fare clic su OK .
    2. Individuare e selezionare la seguente sottochiave:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VolSnap
    3. Scegliere Nuovo dal menu Modifica , quindi valore DWORD .
    4. Digitare MinDiffAreaFileSize e quindi premere INVIO.
    5. Nel menu Modifica , fare clic su Modifica .
    6. Consente di calcolare un valore cinque percentuali del più piccolo spazio di archiviazione copia shadow su qualsiasi uno volume nel sistema.
    7. Per impostare il valore MinDiffAreaFileSize , utilizzare le linee guida riportate di seguito:
      • Se si calcola un valore che è minore o uguale a (< =) 600 megabyte (MB), impostare il MinDiffAreaFileSize valore 600 . Se si continua a ricevere 25 ID evento, aumentare in modo incrementale il valore fino a quando il valore maggiore di 3.000.
      • Se è possibile calcolare un valore che è più di o uguale a (> =) 3.000 MB, impostare ilvalore MinDiffAreaFileSize su 3000 .
      • Se si calcola un valore compreso tra 600 MB e 3.000 MB, impostare il valore di MinDiffAreaFileSize sul valore che è stato calcolato.
    Nota Se il valore della sottochiave del Registro di sistema
    MinDiffAreaFileSize
    è maggiore della dimensione massima dell'area di archiviazione di copia shadow, copie shadow non funzionino correttamente. Ad esempio, se si imposta l'impostazione del Registro di sistema a 1024 MB, software di backup non genererà snapshot di 200 MB partizione di sistema. Pertanto, prima di creare la sottochiave del Registro di sistema
    MinDiffAreaFileSize
    , assicurarsi che il file area diff è maggiore di 300 MB o che il file area diff sia maggiore del valore specificato nel Registro di sistema. Inoltre, assicurarsi di disporre di almeno 300 MB di spazio libero sul volume di archiviazione copia shadow.
Se si continua a ricevere 25 ID evento, attenersi alla seguente procedura per risolvere il problema:
  1. Inserire l'archiviazione della copia shadow in un altro volume, anche nel se in cui il volume si trova su stesso disco rigido.
  2. Assicurarsi che il volume che genera l'evento ID 25 non sia il volume stesso contenente il file di paging. Se il volume che causa l'ID evento 25 contiene il file di paging, è necessario considerare inserire il file di paging in un altro volume.
  3. Assicurarsi che il volume che genera l'evento ID 25 è utilizzato come l'archiviazione della copia shadow per qualsiasi altro volume.

Proprietà

Identificativo articolo: 925799 - Ultima modifica: domenica 14 giugno 2009 - Revisione: 3.1
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Chiavi: 
kbmt kbprb kbinfo kbtshoot kbhowto KB925799 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 925799
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com