尝试启动 Windows Vista 或 Windows 7 时,出现停止错误,或计算机停止响应

文章翻译 文章翻译
文章编号: 925810 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

症状

尝试启动 Windows Vista 或 Windows 7 时,出现停止错误。或者计算机停止响应。

原因

很多情况下都可能出现此问题。这些情况包括:
  • 注册表损坏。
  • 系统文件丢失或损坏。
  • 设备驱动程序文件丢失或损坏。

解决方案

要解决此问题,请使用启动修复工具。启动修复工具可以修复某些阻止操作系统正常启动的问题。

可以使用 Windows Vista 或 Windows 7 安装光盘或使用计算机的预安装恢复选项运行启动修复工具。

要使用 Windows Vista 或 Windows 7 安装光盘运行启动修复工具

如果您有 Windows Vista 或 Windows 7 安装光盘,请按照下列步骤使用启动修复工具:
  1. 插入安装光盘。

    注意:必须将计算机配置为从 CD 或 DVD 启动。有关如何将计算机配置为从 CD 或 DVD 启动的信息,请参见计算机附带的信息。
  2. 重新启动计算机。若要执行此操作,依次单击「开始」
    收起这个图片展开这个图片
    开始按钮
    “锁定”按钮旁边的箭头、“重新启动”

    注意:如果使用此方法无法重新启动计算机,请使用电源按钮关闭 计算机。然后重新打开计算机电源。
  3. 设置您的语言首选项,然后单击“下一步”

    注意:在大多数情况下,启动修复过程会自动启动,“系统恢复选项”菜单中并不提供可用于选择它的选项。
  4. 单击“修复计算机”
  5. “系统恢复选项”对话框中,单击要修复的操作系统,然后单击“下一步”
  6. “系统恢复选项”菜单中,单击“启动修复”启动修复过程。
  7. 修复过程完成后,请单击“完成”

如果计算机已预安装恢复选项,则运行启动修复工具

如果计算机有预安装恢复选项,请按照下列步骤使用启动修复工具。

注意:在大多数情况下,启动修复过程会自动启动。只有在启动修复工具未自动启动时,才应按照下列步骤操作。
  1. 从计算机中取出所有软盘、CD 和 DVD,然后重新启动计算机。
  2. 按照下列步骤之一操作:
    • 如果计算机上只安装了一个操作系统,请在计算机重新启动时按下 F8 键。您必须在 Windows 徽标出现之前按 F8 键。如果 Windows 徽标已出现,则必须重新启动并重试。
    • 如果计算机上有多个操作系统,请使用箭头键选择要修复的操作系统。然后按下 F8。
  3. “高级启动选项”中,使用箭头键选择“修复计算机”,然后按 Enter。
  4. 单击列表中的一种键盘布局,然后单击“下一步”
  5. 单击列表中的用户名,输入密码,然后单击“确定”
  6. “系统恢复选项”菜单中,单击“启动修复”
  7. 修复过程完成后,请单击“完成”
注意:启动修复工具运行一次后,可能不会解决问题。在计算机重新启动后,如果问题仍未解决,请按照上述步骤重试。

更多信息

启动修复工具可自动修复很多常见问题。此外,使用该工具还可以迅速诊断并修复更为复杂的启动问题。当计算机检测到启动问题时,它便会运行启动修复工具。该工具启动后会执行一系列诊断操作。其中包括分析启动日志文件,以确定问题的原因。在启动修复工具确定问题的原因后,该工具会自动尝试修复问题。

如果启动修复工具无法修复出现的启动问题,系统将还原到它已知的上次工作状态。如果启动修复工具无法自动恢复系统,它会提供诊断信息和支持选项,以便于进行故障排除。

启动修复工具会生成一个日志文件,以帮助您了解各个启动问题以及已进行的修复工作。可以在以下位置中找到该日志文件:
%windir%\System32\LogFiles\Srt\Srttrail.txt
此处,%windir% 是安装了 Windows 的文件夹。

属性

文章编号: 925810 - 最后修改: 2009年10月22日 - 修订: 5.0
这篇文章中的信息适用于:
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Home Premium
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Home Basic
  • Windows Vista Home Basic 64-bit edition
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
关键字:?
kbexpertisebeginner kbtshoot kbbug kbprb KB925810
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com