Zostanie wyświetlony komunikat o błędzie kodu lub odtwarzanie dźwięku, ale wideo nie jest odtwarzane podczas odtwarzania plików multimedialnych w Odtwarzacz multimedialny Windows 11

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że film wideo nie jest odtwarzany podczas odtwarzania go w Odtwarzacz multimedialny Windows 11.

Dotyczy: Odtwarzacz multimedialny Windows 11
Oryginalny numer KB: 926373

Symptomy

Podczas próby odtworzenia pliku wideo w Odtwarzacz multimedialny Windows 11 wideo nie jest odtwarzane. Jednak dźwięk jest odtwarzany.

Ponadto podczas próby odtworzenia pliku audio lub pliku wideo w Odtwarzacz multimedialny Windows 11 może zostać wyświetlony komunikat o błędzie podobny do jednego z następujących komunikatów o błędach:

Odtwarzacz multimedialny Windows nie może odtworzyć pliku, ponieważ wymagany koder wideo nie jest zainstalowany na komputerze.

Odtwarzacz multimedialny Windows nie może odtworzyć, nagrać, zgrać lub zsynchronizować pliku, ponieważ wymagany koder audio nie jest zainstalowany na komputerze.

Do odtworzenia tego pliku jest wymagany koder. Aby ustalić, czy ten koder jest dostępny do pobrania z sieci Web, kliknij pozycję Pomoc internetowa.

Nieprawidłowy format pliku.

Przyczyna

Ten problem występuje, jeśli koder, który jest wymagany do odtworzenia pliku, nie jest zainstalowany na komputerze.

Rozwiązanie

Aby rozwiązać ten problem, skonfiguruj Odtwarzacz multimedialny Windows do automatycznego pobierania koderów. Aby to zrobić, wykonaj następujące kroki w Odtwarzacz multimedialny Windows 11:

  1. Na karcie Narzędzia wybierz pozycję Opcje.
  2. Wybierz kartę Odtwarzacz , zaznacz pole wyboru Pobierz koderki automatycznie , a następnie wybierz przycisk OK.
  3. Spróbuj odtworzyć plik.

Jeśli zostanie wyświetlony monit o zainstalowanie programisty, wybierz pozycję Zainstaluj. Jeśli nadal nie możesz poprawnie odtworzyć pliku, spróbuj wykonać kroki opisane w sekcji Zaawansowane rozwiązywanie problemów . Jeśli nie masz doświadczenia w zaawansowanym rozwiązywaniu problemów, poproś kogoś o pomoc lub skontaktuj się z pomoc techniczna firmy Microsoft.

Zaawansowane rozwiązywanie problemów

Poniższe kroki są przeznaczone dla zaawansowanych użytkowników komputerów.

Uzyskaj i zainstaluj koder, wykonując następujące kroki w Odtwarzacz multimedialny Windows 11:

  1. Określ, czy koder jest zainstalowany na komputerze używanym do odtwarzania pliku. Aby tak zrobić, wykonaj następujące kroki:

    1. W obszarze Teraz odtwarzane kliknij prawym przyciskiem myszy plik, który próbujesz odtworzyć, a następnie wybierz pozycję Właściwości.
    2. Wybierz kartę Plik , zanotuj koderki określone w obszarze Koder audio i koder wideo , a następnie wybierz przycisk OK. Jeśli spełnione są następujące warunki, przejdź do kroku 2.
      • Nie określono koder dźwiękowy.
      • Nie określono koder wideo.
    3. W menu Pomoc wybierz pozycję Informacje o Odtwarzacz multimedialny Windows.
    4. Wybierz hiperlink Informacje o pomocy technicznej .
    5. Jeśli próbujesz odtworzyć plik audio, określ, czy koder audio zanotowany w kroku 1b jest wymieniony w obszarze Koderze audio . Jeśli próbujesz odtworzyć plik wideo, określ, czy koder wideo lub koder audio zanotowany w kroku 1b jest wymieniony w obszarze Koder wideo . Jeśli koder nie znajduje się na liście, przejdź do kroku 2.
    6. Spróbuj ponownie zainstalować koder. Jeśli nie możesz ponownie zainstalować kodu, przejdź do kroku 2.
    7. Spróbuj odtworzyć plik. Jeśli możesz odtworzyć plik, pomiń kroki 2 i 3.
  2. Zainstaluj koder, wykonując następujące kroki:

    1. Jeśli podczas próby odtworzenia pliku zostanie wyświetlony komunikat o błędzie, wybierz pozycję Pomoc internetowa. Jeśli podczas próby odtworzenia pliku nie zostanie wyświetlony komunikat o błędzie, przejdź do kroku 3.

    2. W witrynie sieci Web firmy Microsoft wybierz link do witryny sieci Web Wmplugins.

    3. Postępuj zgodnie z instrukcjami w witrynie sieci Web, aby pobrać i zainstalować koder dla pliku. Jeśli witryna sieci Web nie znajdzie automatycznie kodera pliku i jeśli spełniony jest któryś z następujących warunków, przejdź do kroku 3:

      • Koder nie został zanotowany w kroku 1b.
      • W witrynie sieci Web nie można odnaleźć kodera zanotowanego w kroku 1b.
    4. Spróbuj odtworzyć plik. Jeśli możesz odtworzyć plik, pomiń krok 3.

  3. Uzyskaj koder od innego dostawcy.

Uwaga

Jeśli używasz Odtwarzacz multimedialny Windows w środowisku zarządzanym przez administratora sieci, może być konieczne skontaktowanie się z administratorem sieci, aby pobrać i zainstalować koder.

Więcej informacji

Informacje i rozwiązanie zawarte w tym dokumencie reprezentują bieżący firmy Microsoft Corporation w tych kwestiach na dzień publikacji. To rozwiązanie jest dostępne za pośrednictwem firmy Microsoft lub dostawcy innej firmy. Firma Microsoft nie zaleca konkretnie żadnego innego dostawcy ani rozwiązania innej firmy, które może opisywać ten artykuł. Mogą istnieć również inni dostawcy lub rozwiązania innych firm, których ten artykuł nie opisuje. Ponieważ firma Microsoft musi reagować na zmieniające się warunki rynkowe, te informacje nie powinny być interpretowane jako zobowiązanie firmy Microsoft. Firma Microsoft nie może zagwarantować ani potwierdzić dokładności jakichkolwiek informacji ani jakiegokolwiek rozwiązania przedstawionego przez firmę Microsoft ani przez żadnego wymienionego dostawcę zewnętrznego.

Firma Microsoft nie udziela żadnych gwarancji i wyklucza wszystkie oświadczenia, gwarancje i warunki, zarówno te wyrażone bezpośrednio, dorozumiane, jak i ustawowe. Obejmują one między innymi oświadczenia, gwarancje lub warunki tytułu, nieuchybienia, zadowalający warunek, przydatność handlową i przydatność do określonego celu, w odniesieniu do wszelkich usług, rozwiązań, produktów lub innych materiałów lub informacji. W żadnym wypadku firma Microsoft nie ponosi odpowiedzialności za jakiekolwiek rozwiązania innych firm wymienionych w tym artykule.