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Error message when a client tries to access resources on a Web site that uses ADFS: "Access is Denied"

Article ID:926408
Last Review:August 17, 2007
Revision:3.4
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SYMPTOMS

After a client successfully authenticates on a Web site that uses Active Directory Federation Services (ADFS), the client receives the following error message when the client tries to access a resource on the Web site:
Access is Denied
When this problem occurs, the following event is logged in the Application log on the server that hosts the Web site:

Event Type: Warning
Event Source: ADFS ISAPI Extension
Event Category: None
Event ID: 107
User: N/A
Description: The ADFS Web Agent Internet Server Application Programming Interface (ISAPI) Extension was unable to obtain a Windows NT token from the authentication service.

This problem occurs if the following conditions are true:
The server is running Microsoft Windows Server 2003 R2.
The server is running ADFS.
The server acts as a resource federation server that supports single sign-on authentication for an ADFS-enabled Web site.

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CAUSE

This problem occurs because the incoming group claims of the account partner are unexpectedly removed. This situation occurs if the following conditions are true:
The resource group for an organization group claim has been modified.
The incoming group claims are mapped to this organization group claim.

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Federation.adminconsole.dll5.2.3790.28132,945,02416-Oct-200612:43x86
Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Federation.adminconsole.dll5.2.3790.28132,945,02415-Oct-200622:07x86

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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APPLIES TO
Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
Microsoft Windows Server 2003 R2 Standard x64 Edition
Microsoft Windows Server 2003 R2 Enterprise x64 Edition
Microsoft Windows Server 2003 R2 Datacenter x64 Edition

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Keywords: 
kbautohotfix kbwinserv2003postsp2fix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB926408

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