O provedor WMI do Windows Communication Foundation não é registrado quando você instala o .NET Framework 3.0 em um computador baseado no Windows Server 2003

Traduções deste artigo Traduções deste artigo
ID do artigo: 926640 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Sintomas

Quando você instala o Microsoft .NET Framework 3.0 em um computador com Microsoft Windows Server 2003, você enfrentar os seguintes problemas:
  • O .NET Framework 3.0 é instalado com êxito. No entanto, o provedor Windows Communication Foundation (WCF) (WMI) não está registrado.
  • Um evento é registrado no log do aplicativo sobre a falha ao registrar o provedor WMI do WCF ou sobre a falha para executar o arquivo Mofcomp.exe.
  • O arquivo de log de rastreamento de instalação %windir%\Temp\dd_wcf_retCA* contém entradas sobre a falha ao registrar o provedor WMI do WCF.

    Observação % windir % representa o caminho da pasta de sistema do Windows. Normalmente, C:\Windows é o caminho da pasta de sistema do Windows.
  • Você recebe uma das seguintes erros de exceção no log do aplicativo ou no arquivo de log de rastreamento de instalação:
    Mensagem de erro 1
    ServiceModelReg [11:09:59:046]: System.ApplicationException: resultado inesperado 3 executando E:\WINDOWS\system32\wbem\mofcomp.exe com "E:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows comunicação Foundation\ServiceModel.mof"
    Mensagem de erro 2
    ServiceModelReg [07:19:33:843]: System.TypeInitializationException: O inicializador de tipo de 'System.Management.ManagementPath' emitiu uma exceção. ---> System.Runtime.InteropServices.COMException (0 x 80040154): Falha ao recuperar a fábrica de classes COM para o componente com CLSID {CF4CC405-E2C5-4DDD-B3CE-5E7582D8C9FA} devido o seguinte erro: 80040154.
    Mensagem de erro 3
    ServiceModelReg [07:19:32:750]: System.IO.FileNotFoundException: não foi possível carregar arquivo ou assembly 'C:\WINDOWS\system32\wbem\mofcomp.exe' ou uma de suas dependências. O sistema não é possível localizar o arquivo especificado. Nome do arquivo: ' C:\WINDOWS\system32\wbem\mofcomp.exe

Causa

Esse problema pode ocorrer se o serviço WMI está corrompido. Portanto, o instalador do WCF não é possível usar o arquivo Mofcomp.exe para registrar o arquivo MOF do WCF.

Resolução

Para resolver esse problema, execute essas etapas:
  1. Execute o utilitário diagnóstico WMI para diagnosticar e reparar problemas com o serviço WMI.

    Para baixar o utilitário de diagnóstico do WMI, visite o seguinte site:
    http://www.microsoft.com/downloads/details.aspx?familyid=D7BA3CD6-18D1-4D05-B11E-4C64192AE97D&displaylang=en
    Para obter mais informações sobre o utilitário de diagnóstico do WMI, visite o seguinte site:
    http://www.microsoft.com/technet/scriptcenter/topics/help/wmidiag.mspx
  2. Use Adicionar ou remover programas para reparar a instalação do .NET Framework 3.0, ou remova e reinstale o .NET Framework 3.0.

    Para reparar a instalação do .NET Framework 3.0, execute essas etapas:
    1. Clique em Iniciar , clique em Executar , digite appwiz.cpl e, em seguida, clique em OK .
    2. Na lista programas instalados , clique em Microsoft .NET Framework 3.0 e clique em Alterar/remover .
    3. Clique em Reparar e, em seguida, clique em Avançar .
    4. Siga as instruções para reparar a instalação do .NET Framework 3.0.
    Para remover e, em seguida, reinstalar o .NET Framework 3.0, execute essas etapas:
    1. Clique em Iniciar , clique em Executar , digite appwiz.cpl e, em seguida, clique em OK .
    2. Na lista programas instalados , clique em Microsoft .NET Framework 3.0 e clique em Alterar/remover .
    3. Clique em desinstalar e, em seguida, clique em Avançar .
    4. Siga as instruções para remover o programa .NET Framework 3.0.
    5. Reinstale o .NET Framework 3.0.

Propriedades

ID do artigo: 926640 - Última revisão: quinta-feira, 30 de novembro de 2006 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
Palavras-chave: 
kbmt kbprb kbwinservperf kbmgmtservices kbexpertiseadvanced kbtshoot KB926640 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 926640

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com