A Bluetooth enabled device does not appear in the Bluetooth Personal Area Network Devices dialog box in Windows XP with Service Pack 2

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Article ID: 926720 - View products that this article applies to.
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SYMPTOMS

You pair a Bluetooth enabled device to a computer that is running Microsoft Windows XP with Service Pack 2 (SP2). Then, you enable Personal Area Networking (PAN) on the device. However, the newly paired device does not appear in the Bluetooth Personal Area Network Devices dialog box. The device does not appear even after you click Add to scan for the device.

This problem occurs if the device is running Windows Mobile 5.0 Adaptation Kit Update (AKU) 3 or a later version that supports Bluetooth PAN.

CAUSE

This problem occurs because Windows XP does not update the cached information about the device.

RESOLUTION

After you apply the hotfix, a Refresh button appears in the Bluetooth Personal Area Network Devices dialog box. You can then update the device information by clicking Refresh.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply the hotfix, you must have Microsoft Windows XP Service Pack 2 (SP2) installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
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File nameFile versionFile sizeDateTimePlatformSP requirement
Btpanui.dll5.1.2600.302650,68803-Nov-200613:16x86SP2
Xpsp3res.dll5.1.2600.3026248,32003-Nov-200610:19x86SP2

WORKAROUND

To work around this problem, follow these steps:
  1. In Control Panel, double-click Bluetooth Devices, and then delete the device that is paired to the computer.
  2. On the device, make sure that PAN is enabled.
  3. In the Bluetooth Devices Control Panel item, pair the device to the computer again.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
883259 How to install and configure Bluetooth devices in Windows XP Service Pack 2
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
883258 How to troubleshoot Bluetooth detection and connectivity problems in Windows XP Service Pack 2
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 926720 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Keywords: 
kbautohotfix kbexpertisebeginner kbfix kbqfe kbHotfixServer KB926720

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