Es posible que un dibujo de Visio no se abra en Visio Viewer 2007 y que reciba un mensaje de error en Internet Explorer

Seleccione idioma Seleccione idioma
Id. de artículo: 926948 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando intenta abrir un dibujo de Microsoft Office Visio 2007 o Microsoft Office Visio 2003 en un equipo que ejecuta Microsoft Office Visio Viewer 2007, es posible que el dibujo no se abra en Windows Internet Explorer. Además, es posible que aparezca uno de los siguientes mensajes de error:
  • Mensaje de error 1
    No se puede mostrar la página.
  • Mensaje de error 2
    Internet Explorer no puede mostrar la página web.

Causa

Este problema puede producirse si está instalado Microsoft Visio 2002 en un equipo que tenga también Visio Viewer 2007.

Solución

Para que podamos solucionar este problema en su lugar utilizando el método 2, diríjase a la sección "Solucionarlo en mi lugar". Si prefiere solucionar este problema usted mismo, vaya a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar



Para solucionar el problema de forma automática, haga clic en el vínculo Fix it o en el botón gráfico. Haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y, a continuación, siga los pasos del Asistente Fix it


Solucionar este problema
Microsoft Fix it 50712
Notas
  • Este asistente podría estar sólo en inglés. Sin embargo, la solución automática también funciona con las otras versiones de idioma de Windows. 
  • Si no está utilizando el equipo que tiene el problema, puede guardar la solución de reparación en una unidad flash o en un CD para posteriormente ejecutarla en el equipo con el problema.

A continuación, vaya a la sección "¿Esta información le ayudó a resolver su problema?".



Solucionarlo por mí mismo

Para solucionar este problema, utilice uno de los métodos siguientes.

Método 1: desinstalar Visio Viewer 2007 y, a continuación, instalar Visio Viewer 2003

  1. Haga clic en Inicio y en Ejecutar, escriba appwiz.cpl y, a continuación, haga clic en Aceptar.
  2. En la lista Programas actualmente instalados, haga clic en Microsoft Office conjunto de aplicaciones 2007 y, a continuación, haga clic en Cambiar.
  3. Haga clic en Agregar o quitar funciones y, a continuación, haga clic en Continuar.
  4. En la página Opciones de instalación, expanda la lista que se encuentra junto a Microsoft Office Visio Viewer y, a continuación, haga clic en No disponible.
  5. Haga clic en Continuar.
  6. Después de quitar Visio Viewer 2007, instale Visio Viewer 2003. Para obtener Visio Viewer 2003, visite el siguiente sitio web de Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=3FB3BD5C-FED1-46CF-BD53-DA23635AB2DF&displaylang=en
Utilice Visio Viewer 2003 para ver los archivos de Visio creados en Visio 2007 o en Visio 2003.

Método 2: modificar el Registro

Importante Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. Sin embargo, la modificación incorrecta del Registro puede producir graves problemas. Por tanto, asegúrese de seguir estos pasos cuidadosamente. Para obtener mayor protección, realice una copia de seguridad del Registro antes de modificarlo. A continuación, puede restaurar el Registro si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el Registro, haga clic en el número de artículo siguiente de Microsoft Knowledge Base:
322756 Cómo realizar una copia de seguridad y restablecer el Registro en Windows


En el Bloc de notas, cree un archivo de Registro (. reg) para cambiar las entradas del Registro de Visio Viewer 2007. Para ello, siga estos pasos: 
  1. Copie y pegue el siguiente texto en un nuevo archivo del Bloc de notas:
    Editor del Registro de Windows versión 5.00
    
    [HKEY_CLASSES_ROOT\.vsd] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vst] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vdx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vss] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vst] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vsx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vtx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
  2. En el menú Archivo, haga clic en Guardar como.
  3. Seleccione una ubicación para guardar el archivo.
  4. En el cuadro Nombre de archivo, escriba Visioreg.reg.
  5. En el cuadro Guardar como tipo, haga clic en Documento de texto (*.txt) y, a continuación, haga clic en Guardar.
  6. En el menú Archivo, haga clic en Nuevo.
  7. Copie y pegue el siguiente texto en el nuevo archivo del Bloc de notas:
    @echo off reg delete "hkcr\.vdx"  /f reg delete "hkcr\.vsd"  /f reg delete "hkcr\.vss"  /f reg delete "hkcr\.vst"  /f reg delete "hkcr\.vsx"  /f reg delete "hkcr\.vtx"  /f regedit /s C:\Visioreg.reg
    Nota: la última línea del archivo debe incluir la ruta de acceso y el nombre del archivo completos del archivo .reg que guardó en el paso 5.
  8. En el menú Archivo, haga clic en Guardar como.
  9. Seleccione una ubicación para guardar el archivo.
  10. En el cuadro Nombre de archivo, escriba Visiofix.reg.
  11. En el cuadro Guardar como tipo, haga clic en Documento de texto (*.txt) y, a continuación, haga clic en Guardar.
  12. En el Explorador de Windows, busque la carpeta en la que guardó el archivo Visiofix.bat .
  13. Haga doble clic en Visiofix.bat.
Cuando haya completado el método 2, si hace doble clic en un archivo de Visio, este se abrirá solo en Visio Viewer. Para modificar un archivo de Visio, debe iniciar Visio, hacer clic en Abrir en el menú Archivo y, a continuación, ubicar el archivo que desea modificar.

Debe volver a aplicar esta solución si se repara Visio 2002 o si se aplica un Service Pack.

¿Esta información le ayudó a resolver el problema?

  • Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede ponerse en contacto con el soporte técnico.
  • Valoramos sus comentarios. Para realizar comentarios o informar de cualquier problema con esta solución, deje su comentario en el blog "Solucionarlo en mi lugar" o envíenos un mensaje de correo electrónico.

Propiedades

Id. de artículo: 926948 - Última revisión: lunes, 03 de octubre de 2011 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2002 Standard Edition
Palabras clave: 
kbtshoot kbexpertisebeginner kbprb kbfixme kbmsifixme KB926948

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com