Kresba programu Visio sa neotvára v zobrazovači Visio Viewer 2007 a v programe Internet Explorer sa môže zobraziť chybové hlásenie

Preklady článku Preklady článku
ID článku: 926948 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Keď sa v počítači s nainštalovaným zobrazovačom Microsoft Office Visio Viewer 2007 pokúsite otvoriť kresbu programu Microsoft Office Visio 2007 alebo Microsoft Office Visio 2003, kresba sa neotvorí v programe Windows Internet Explorer. Môže sa tiež zobraziť jedno z nasledujúcich chybových hlásení:
  • Chybové hlásenie 1
    Stránka sa nedá zobraziť.
  • Chybové hlásenie 2
    Program Internet Explorer nemôže zobraziť webovú stránku.

PRICINA

K tomuto problému môže dochádzať, ak je v počítači s nainštalovaným zobrazovačom Visio Viewer 2007 nainštalovaný aj program Microsoft Visio 2002.

RIEŠENIE

Ak chcete, aby sme tento problém vyriešili za vás použitím postupu 2, prejdite na časť Opravte to za mňa. Ak chcete tento problém vyriešiť sami, prejdite na časť Vyriešim problém sám.

Opravte to za mňa



Ak chcete tento problém vyriešiť automaticky, kliknite na prepojenie alebo tlačidlo Opraviť tento problém. Potom kliknite na položku Spustiť v dialógovom okne Prevzatie súboru a postupujte podľa pokynov sprievodcu služby Fix it.


Opraviť tento problém
Microsoft Fix it 50712
Poznámky
  • Tento sprievodca môže byť dostupný iba v angličtine. Automatickú opravu je však možné použiť aj pre ostatné jazykové verzie systému Windows.
  • Ak nepracujete s počítačom, v ktorom sa vyskytol problém, môžete opravné riešenie uložiť na jednotku flash alebo na disk CD a potom ho môžete spustiť v počítači s problémom.

Potom prejdite na časť Vyriešil sa problém?



Vyriešim problém sám

Ak chcete vyriešiť tento problém, použite jeden z nasledujúcich postupov.

Postup 1: Odinštalovanie zobrazovača Visio Viewer 2007 a nainštalovanie zobrazovača Visio Viewer 2003

  1. Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte príkaz appwiz.cpl a potom kliknite na tlačidlo OK.
  2. V zozname Nainštalované programy kliknite na položku Microsoft Office Suite 2007 a potom kliknite na položku Zmeniť.
  3. Kliknite na položku Pridať alebo odstrániť súčasti a potom kliknite na tlačidlo Zmeniť.
  4. Na stránke Možnosti inštalácie rozbaľte zoznam vedľa položky Microsoft Office Visio Viewer a kliknite na položku Nie je k dispozícii.
  5. Kliknite na tlačidlo Pokračovať.
  6. Po odstránení zobrazovača Visio Viewer 2007 nainštalujte zobrazovač Visio Viewer 2003. Ak chcete získať zobrazovač Visio Viewer 2003, navštívte nasledujúcu webovú lokalitu spoločnosti Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=3FB3BD5C-FED1-46CF-BD53-DA23635AB2DF&displaylang=en
Na zobrazenie súborov vytvorených v programe Visio 2007 alebo Visio 2003 použite zobrazovač Visio Viewer 2003.

Postup 2: Úprava databázy Registry

Dôležité upozornenie: Táto sekcia, postup alebo úloha obsahuje kroky, ktoré informujú o úpravách databázy Registry. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Preto dávajte pozor a postupujte presne podľa týchto krokov. Na dosiahnutie lepšej ochrany je pred úpravou databázu Registry vhodné zálohovať. To vám umožní obnoviť databázu Registry, ak sa vyskytnú problémy. Ďalšie informácie o zálohovaní a obnovení databázy Registry nájdete v nasledujúcom článku databázy Microsoft Knowledge Base:
322756 Zálohovanie a obnovovanie databázy Registry v systéme Windows


V programe Poznámkový blok vytvorte súbor databázy Registry (.reg), ktorý vám umožní zmeniť položky programu Visio Viewer 2007 v databáze Registry. Postupujte podľa nasledujúcich krokov:
  1. Skopírujte nasledujúci text a prilepte ho do nového súboru programu Poznámkový blok:
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\.vsd] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vst] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vdx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vss] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vst] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vsx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
    
    [HKEY_CLASSES_ROOT\.vtx] "Content Type"="application/vnd.ms-visio.viewer" @="VisioViewer.Viewer"
  2. V ponuke Súbor kliknite na príkaz Uložiť ako.
  3. Vyberte umiestnenie na uloženie súboru.
  4. Do poľa Názov súboru zadajte reťazec Visioreg.reg.
  5. V zozname Typ súboru kliknite na položku Textový dokument (*.txt) a potom kliknite na tlačidlo Uložiť.
  6. V ponuke Súbor kliknite na položku Nové.
  7. Skopírujte nasledujúci text a prilepte ho do nového súboru programu Poznámkový blok:
    @echo off reg delete "hkcr\.vdx"  /f reg delete "hkcr\.vsd"  /f reg delete "hkcr\.vss"  /f reg delete "hkcr\.vst"  /f reg delete "hkcr\.vsx"  /f reg delete "hkcr\.vtx"  /f regedit /s C:\Visioreg.reg
    Poznámka: Posledný riadok súboru musí obsahovať úplnú cestu a názov súboru .reg, ktorý ste uložili v kroku 5.
  8. V ponuke Súbor kliknite na príkaz Uložiť ako.
  9. Vyberte umiestnenie na uloženie súboru.
  10. Do poľa Názov súboru zadajte reťazec Visiofix.bat.
  11. V zozname Typ súboru kliknite na položku Textový dokument (*.txt) a potom kliknite na tlačidlo Uložiť.
  12. V programe Windows Prieskumník vyhľadajte priečinok, do ktorého ste uložili súbor Visiofix.bat.
  13. Dvakrát kliknite na súbor Visiofix.bat.
Keď po dokončení druhého postupu dvakrát kliknete na súbor programu Visio, otvorí sa v zobrazovači Visio Viewer. Ak chcete upraviť súbor programu Visio, musíte spustiť program Visio, kliknúť na položku Otvoriť v ponuke Súbor a vyhľadať súbor, ktorý chcete upraviť.

Ak opravíte program Visio 2002 alebo nainštalujete balík Service Pack, musíte toto riešenie znova použiť.

Vyriešil sa problém?

  • Skontrolujte, či sa problém vyriešil. Ak sa problém vyriešil, úspešne ste dokončili postupy v tejto časti. Ak sa vám problém nepodarilo vyriešiť, môžete sa obrátiť na technickú podporu.
  • Oceníme vaše pripomienky. Ak chcete poskytnúť pripomienky alebo nahlásiť ľubovoľný problém súvisiaci s týmto riešením, pridajte komentár na blog Fix it for me alebo nám pošlite e-mailovú správu.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Vlastnosti

ID článku: 926948 - Posledná kontrola: 3. októbra 2011 - Revízia: 2.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Office Visio Professional 2007
  • Microsoft Office Visio Standard 2007
  • Microsoft Office Visio Professional 2003
  • Microsoft Visio 2002 Professional Edition
  • Microsoft Visio 2002 Standard Edition
Kľúčové slová: 
kbtshoot kbexpertisebeginner kbprb kbfixme kbmsifixme KB926948

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com