Help and Support

Article ID: 926986 - Last Review: October 25, 2007 - Revision: 3.3

The performance of a server that is running Exchange 2003 deteriorates over time when you run a WMI script to enumerate public folders

Hotfix download is availableHotfix Download Available
View and request hotfix downloads

On This Page

Expand all | Collapse all

SYMPTOMS

When you run a Windows Management Instrumentation (WMI) script that uses the Exchange_PublicFolder class to enumerate public folders, the performance of the server that is running Microsoft Exchange Server 2003 deteriorates over time. You can stop this behavior by restarting the Windows Management Instrumentation service. However, the problem recurs.

This problem occurs if the access control lists for the public folders have many entries.

CAUSE

This problem occurs because of a memory leak in the Lsass.exe process. If you monitor the Lsass.exe process, you will notice that the Private Bytes counter continues to increase steadily.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993  (http://support.microsoft.com/kb/836993/ ) How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Exmgmt.exe6.5.7652.13,218,43221-Nov-200619:03x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates
For more information about the naming schema for Exchange software updates, click the following article number to view the article in the Microsoft Knowledge Base:
817903  (http://support.microsoft.com/kb/817903/ ) New naming schema for Exchange Server software update packages

REFERENCES

For more information about the Exchange_PublicFolder WMI class, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/aa143746.aspx (http://msdn2.microsoft.com/en-us/library/aa143746.aspx)

APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbautohotfix kbexpertiseadvanced kbhotfixserver kbqfe kbfix kbbug kbpubtypekc KB926986

Article Translations

 

Related Support Centers