Article ID: 927009 - Last Review: September 11, 2009 - Revision: 9.1

A new window opens when you try to view a 2007 Microsoft Office program document in Windows Internet Explorer 7 or Internet Explorer 8

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SYMPTOMS

When you try to open a Microsoft Office Word 2007 document, a Microsoft Office Excel 2007 document, or a Microsoft Office PowerPoint 2007 document in Windows Internet Explorer 7 or Windows Internet Explorer 8, the document may not open in the same window as Internet Explorer. Instead, a new Word 2007, Excel 2007, or PowerPoint 2007 window opens to display the document.

CAUSE

This behavior is by design. The 2007 Microsoft Office system intentionally sets a BrowserFlags registry value for its file types to force the documents to open within the Office application window and not inside the Internet Explorer window.

Certain editing features are available only when the document is open outside the Web browser. Additionally, the Office Ribbon may not work as expected in Internet Explorer. Also, security enhancements to Windows Internet Explorer 7 or Internet Explorer 8 running on Windows Vista make opening the document outside the low-integrity context of Internet Explorer (when running in protected mode) better for overall security and usability.

WORKAROUND

If you have an existing application that requires the old behavior, you can modify the registry to allow the 2007 Office system files to open in Internet Explorer. We encourage you to do this only if the situation requires it. If you make these changes, all users of the computer will be affected.

Note For applications that require Office files to open inside the Web browser window, use the following workaround. However, this Internet Explorer feature may not exist in future operating systems that are later than Windows Vista.

To have us do this for you, go to the "Fix it for me" section. To do this yourself, go to the "Let me fix it myself" section.

Fix it for me

To change the registry automatically, click the Fix this problem link. Click Run in the File Download dialog box, and then follow the steps in the Fix it wizard.

Fix this problem
Microsoft Fix it 50298


Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, you can save the automatic fix to a flash drive or to a CD so that you can run it on the computer that has the problem.

Now go to the "Did this fix the problem?" section.

Let me fix it myself

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows


To work around this behavior, follow these steps:
  1. Start Notepad.
  2. Copy and then paste the following text to Notepad:
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.8]
    "BrowserFlags"=dword:80000024
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.RTF.8]
    "BrowserFlags"=dword:80000024
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.12]
    "BrowserFlags"=dword:80000024
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.DocumentMacroEnabled.12]
    "BrowserFlags"=dword:80000024
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8]
    "BrowserFlags"=dword:80000A00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12]
    "BrowserFlags"=dword:80000A00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetMacroEnabled.12]
    "BrowserFlags"=dword:80000A00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetBinaryMacroEnabled.12]
    "BrowserFlags"=dword:80000A00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.Show.8]
    "BrowserFlags"=dword:800000A0
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.Show.12]
    "BrowserFlags"=dword:800000A0
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.ShowMacroEnabled.12]
    "BrowserFlags"=dword:800000A0
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShow.8]
    "BrowserFlags"=dword:800000A0
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShow.12]
    "BrowserFlags"=dword:800000A0
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShowMacroEnabled.12]
    "BrowserFlags"=dword:800000A0
    
  3. Save the file as FileName.reg.
  4. Double-click FileName.reg to run this registry script.
  5. Start Internet Explorer 7.

STATUS

This behavior is by design.

Did this fix the problem?

Check whether you can open Microsoft Office Word 2007 document, a Microsoft Office Excel 2007 document, or a Microsoft Office PowerPoint 2007 document in Windows Internet Explorer 7 or Windows Internet Explorer 8. If you are able to open documents, you are finished with this article. If you are not able to open documents, you can contact support (http://support.microsoft.com/contactus) .

APPLIES TO
  • Microsoft Office Excel 2007
  • Microsoft Office PowerPoint 2007
  • Microsoft Office Word 2007, when used with:
    • Windows Internet Explorer 7
  • Windows Internet Explorer 8
Keywords: 
kbmsifixme kbfixme kbtshoot kbexpertisebeginner kbprb KB927009
 

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