Article ID: 927153 - Last Review: September 12, 2011 - Revision: 3.0

The 2007 Office suite or the 2010 Office suite Setup program will not restart after an initial installation is interrupted

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SYMPTOMS

Consider the following scenario. When you install a Microsoft Office suite or an Office program, the installation process is interrupted. Additionally, the Setup program is prevented from rolling back the Office installation. In this scenario, when you try to install the same Office suite or the Office program again, you receive the following error message: 
Microsoft Office suite_name encountered an error during setup.

CAUSE

This problem may occur if the Rgstrtn.lck file is not removed from the computer. If this file is present when you try to install the same Office suite or the Office program that you previously tried to install, the Setup program detects the file. Then, the Setup program stops the installation.

WORKAROUND

To work around this problem, delete the Rgstrtn.lck file. To do this, follow the steps, as appropriate for the operating system that you are using.

Warning If you install another Microsoft program after you receive the error message that is mentioned in the "Symptoms" section, you may experience problems with the program's Help system if you follow these steps. If you installed another Microsoft program after you receive the error message that is mentioned in the "Symptoms" section, uninstall the program before you follow these steps.

To have us fix this problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me



To fix this problem automatically, click the Fix it button or link. Click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50493


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not using the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

In Windows XP
  1. Click Start, click Run, type cmd, and then click OK.
  2. Type cd "%allusersprofile%\Application Data\Microsoft Help", and then press ENTER.
  3. Type attrib -h rgstrtn.lck, and then press ENTER.
  4. Type del rgstrtn.lck, and then press ENTER.
  5. Type dir /b /od /ad, and then press ENTER.
  6. Type rd /q /s "<folder names>"and then press ENTER.


    Note
     The <folder names> are the folder names that are listed after you run the command in step 5. There should be a space between each folder-name. For example: rd /q /s "foldername1" "foldername2" "foldername3".
  7. Type exit, and then press ENTER.
In Windows Vista and Windows 7
  1. Click Start
    Collapse this imageExpand this image
    Start button
    , and then type cmd in the Start Search box, and then click OK.
  2. Type cd "%allusersprofile%\Microsoft Help", and then press ENTER,
  3. Type attrib -h rgstrtn.lck, and then press ENTER.
  4. Type del rgstrtn.lck, and then press ENTER.
  5. Type dir /b /od /ad, and then press ENTER.
  6. Type rd /q /s "<folder names>"and then press ENTER.


    Note
     The <folder names> are the folder names that are listed after you run the command in step 5. There should be a space between each folder-name. For example: rd /q /s "foldername1" "foldername2" "foldername3"
  7. Type exit, and then press ENTER.
After you perform these steps, you can try to install the Office suite or the Office program that you tried to install earlier.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) .

APPLIES TO
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
  • Microsoft Office Professional 2010
  • Microsoft Office Professional Plus 2010
  • Microsoft Office Standard 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Internet Information Services Media Services 2.0
Keywords: 
kbcommandline kbsetup kbexpertisebeginner kbtshoot kbprb kbfixme kbmsifixme KB927153