Numéro d'article: 927153 - Dernière mise à jour: mercredi 14 septembre 2011 - Version: 2.0

Le programme d'installation de la suite Office 2007 ou Office 2010 ne redémarre pas à la suite de l'interruption d'une installation initiale

A noterCet article s'applique à un système d'exploitation différent de celui que vous utilisez. Le contenu de l'article qui ne vous concerne peut-être pas est désactivé.
Agrandir tout | Réduire tout

Symptômes

Envisagez le scénario suivant. Alors que vous installez une suite ou un programme Microsoft Office, le processus est interrompu. Par ailleurs, le programme d'installation ne peut pas annuler l'installation d'Office. Dans ce scénario, lorsque vous essayez d'installer de nouveau la même suite ou le même programme Office, le message d'erreur suivant s'affiche :
Une erreur s'est produite au cours de l'installation de nom_suite_Microsoft Office.

Cause

Ce problème peut survenir si le fichier Rgstrtn.lck n'est pas supprimé de l'ordinateur. Si ce fichier est présent lorsque vous tentez d'installer la même suite ou le même programme Office que vous aviez précédemment essayé d'installer, il est détecté par le programme d'installation. Le programme d'installation arrête alors l'installation.

Contournement

Pour contourner ce problème, supprimez le fichier Rgstrtn.lck. Pour cela, suivez ces étapes, en fonction du système d'exploitation que vous utilisez.

Avertissement Si vous utilisez un autre programme Microsoft après avoir reçu le message d'erreur mentionné à la section « Symptômes », vous pouvez rencontrer des problèmes dans le système d'aide du programme si vous suivez ces étapes. Si vous avez installé un autre programme Microsoft après avoir reçu le message d'erreur mentionné à la section « Symptômes », désinstallez-le avant de suivre ces étapes.

Afin que nous puissions résoudre le problème pour vous, consultez la section « Aidez-moi ». Si vous préférez résoudre le problème vous-même, consultez la section « Je résous le problème moi-même ».

Aidez-moi



Pour résoudre ce problème automatiquement, cliquez sur le bouton ou le lien Résolution. Cliquez sur Exécuter dans la boîte de dialogue Téléchargement de fichier, et suivez la procédure indiquée par l'Assistant Résolution.


Résoudre ce problème
Microsoft Fix it 50493


Remarques
  • Cet Assistant peut n'exister qu'en anglais. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.
  • Si vous n'utilisez pas l'ordinateur concerné, vous pouvez enregistrer la solution sur un lecteur flash ou sur un CD-ROM et ensuite l'exécuter sur l'ordinateur concerné par le problème.

Consultez ensuite la section « Le problème est-il résolu ? ».



Je résous le problème moi-même

Sous Windows XP
  1. Cliquez sur Démarrer, sur Exécuter, tapez cmd, puis cliquez sur OK.
  2. Tapez cd "%allusersprofile%\Application Data\Microsoft Help", puis appuyez sur ENTRÉE.
  3. Tapez attrib -h rgstrtn.lck et appuyez sur ENTRÉE.
  4. Tapez del rgstrtn.lck, puis appuyez sur ENTRÉE.
  5. Tapez dir /b /od /ad et appuyez sur ENTRÉE.
  6. Tapez rd /q /s "<folder names>"puis appuyez sur ENTRÉE.


    Remarque
     <folder names> correspond aux noms des dossiers qui sont répertoriés après avoir exécuté la commande à l'étape 5. Chaque nom de dossier doit être séparé par un espace. Par exemple : rd /q /s "foldername1" "foldername2" "foldername3".
  7. Tapez exit, puis appuyez sur ENTRÉE.
Sous Windows Vista et Windows 7
  1. Cliquez sur Démarrer
    Réduire cette imageAgrandir cette image
    Bouton Démarrer
    , puis tapez cmd dans la zone Rechercher, puis cliquez sur OK.
  2. Tapez cd "%allusersprofile%\Application Data\Microsoft Help", puis appuyez sur ENTRÉE.
  3. Tapez attrib -h rgstrtn.lck et appuyez sur ENTRÉE.
  4. Tapez del rgstrtn.lck, puis appuyez sur ENTRÉE.
  5. Tapez dir /b /od /ad et appuyez sur ENTRÉE.
  6. Tapez rd /q /s "<folder names>"puis appuyez sur ENTRÉE.


    Remarque
     <folder names> correspond aux noms des dossiers qui sont répertoriés après avoir exécuté la commande à l'étape 5. Chaque nom de dossier doit être séparé par un espace. Par exemple : rd /q /s "foldername1" "foldername2" "foldername3"
  7. Tapez exit, puis appuyez sur Entrée.
Après avoir supprimé le fichier Rgstrtn.lck, vous pouvez tenter d'installer la suite ou le programme Office que vous aviez précédemment essayé d'installer.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft figurant dans la liste des produits concernés par cet article.

Le problème est-il résolu ?

  • Vérifiez que le problème est résolu. Si c'est le cas, vous n'avez plus besoin de cette section. Sinon, vous pouvez contacter l'assistance (http://support.microsoft.com/contactus) .
  • Vos commentaires sont les bienvenus. Pour nous faire part de vos commentaires ou d'un problème concernant cette solution, écrivez-nous sur le blog « Aidez-moi (http://blogs.technet.com/fixit4me/)  » ou envoyez-nous un courrier électronique (mailto:fixit4me@microsoft.com?Subject=KB) .

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Ultimate 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Standard 2007
  • Microsoft Office Home and Student 2007
  • Microsoft Office Basic 2007
  • Microsoft Office Professional 2010
  • Microsoft Office Professional Plus 2010
  • Microsoft Office Standard 2010
  • Microsoft Office Home and Student 2010
  • Microsoft Office Home and Business 2010
  • Microsoft Internet Information Services Media Services 2.0
Mots-clés : 
kbcommandline kbsetup kbexpertisebeginner kbtshoot kbprb kbfixme kbmsifixme KB927153
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.