REVISIÓN: El programa de configuración de una aplicación no se ejecuta y se borra la clave RunOnceEx del Registro cuando reinicia un equipo que ejecuta Internet Explorer 7

Seleccione idioma Seleccione idioma
Id. de artículo: 927357 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Instala Windows Internet Explorer 7 en un equipo.
  • Después instala otra aplicación en el equipo.
  • El programa de instalación de la segunda aplicación establece la clave
    RunOnceEx
    del Registro para ejecutar un programa de configuración la próxima vez que se inicia el equipo.
En esta situación, el programa de configuración de la segunda aplicación no se ejecuta cuando reinicia el equipo. Además, se borra la clave
RunOnceEx
del Registro.

Causa

Cuando Internet Explorer 7 está instalado en el equipo, Iernonce.dll no procesa la clave
RunOnceEx
del Registro.

Solución

Información de la actualización seguridad

Para resolver este problema, los usuarios deben instalar la actualización de seguridad acumulativa más reciente para Internet Explorer. Para instalar las actualizaciones más recientes, visite el siguiente sitio Web de Microsoft:
http://update.microsoft.com
Para obtener más información técnica acerca de la actualización de seguridad acumulativa más reciente para Internet Explorer, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/technet/security/current.aspx
Nota
Esta revisión (hotfix) se incluyó primero en la actualización de seguridad 928090 (MS07-016). Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
928090 MS07-016: Actualización de seguridad acumulativa para Internet Explorer

Solución

Cuando desarrolle la aplicación, establezca la opción No Status Dialog de la clave
RunOnceEx
del Registro.

Estado

Microsoft ha confirmado que se trata de un error de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional acerca de la clave RunOnceEx del Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
310593 Descripción de la clave RunOnceEx del Registro
Para obtener más información acerca de terminología relativa a la actualización de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 927357 - Última revisión: martes, 17 de mayo de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows XP
Palabras clave: 
kbexpertisebeginner kbtshoot kbfix kbbug kbprb KB927357

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com