FIX: Il programma di configurazione per un'applicazione non viene eseguito e la chiave del Registro di sistema RunOnceEx viene cancellata al momento del riavvio di un computer che esegue Internet Explorer 7

Traduzione articoli Traduzione articoli
Identificativo articolo: 927357 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si consideri lo scenario descritto di seguito:
  • Sul computer in uso è stato installato Windows Internet Explorer 7.
  • Successivamente viene installata un'altra applicazione.
  • Tramite il programma di installazione della seconda applicazione la chiave del Registro di sistema
    RunOnceEx
    viene impostata per l'esecuzione di un programma di configurazione al successivo avvio del computer.
In questo scenario, il programma di configurazione della seconda applicazione non viene eseguito al momento del riavvio del computer. Inoltre, la chiave del Registro di sistema
RunOnceEx
viene cancellata.

Cause

Quando in un computer viene installato Internet Explorer 7, la chiave del Registro di sistema
RunOnceEx
non viene elaborata dal file lernonce.dll.

Risoluzione

Informazioni sull'aggiornamento della protezione

Per risolvere questo problema, gli utenti devono installare l'aggiornamento della protezione cumulativo più recente per Internet Explorer. Per installare gli aggiornamenti più recenti, visitare il seguente sito Web Microsoft:
http://update.microsoft.com
Per ulteriori informazioni tecniche sull'aggiornamento della protezione cumulativo più recente per Internet Explorer, visitare il seguente sito Web Microsoft (informazioni in lingua inglese):
http://www.microsoft.com/technet/security/current.aspx
Nota Questo hotfix è stato incluso per la prima volta nell'aggiornamento della protezione 928090 (MS07-016). Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
928090 MS07-016: Aggiornamento della protezione cumulativo per Internet Explorer

Workaround

Quando si sviluppa l'applicazione, impostare l'opzione No Status Dialog della chiave del Registro di sistema
RunOnceEx
.

Status

Microsoft ha confermato che questo bug è presente nei prodotti elencati alla fine di questo articolo.

Informazioni

Per ulteriori informazioni sulla chiave del Registro di sistema SynAttackProtect, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
310593 Descrizione della chiave del Registro di sistema RunOnceEx
Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684 Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 927357 - Ultima modifica: venerdì 13 maggio 2011 - Revisione: 2.0
Le informazioni in questo articolo si applicano a:
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows XP
Chiavi: 
kbexpertisebeginner kbtshoot kbfix kbbug kbprb KB927357
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com