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Häufige Probleme mit der Datei- und Registrierungsvirtualisierung in Windows Vista

Artikel-ID:927387
Geändert am:Sonntag, 29. April 2007
Version:2.6
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
927387 (http://support.microsoft.com/kb/927387/EN-US/) Common file and registry virtualization issues in Windows Vista
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Sie sollten eine Sicherungskopie der Registrierung erstellen, bevor Sie die Registrierung bearbeiten. Sie müssen wissen, wie die Registrierung wiederhergestellt werden kann, wenn ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986 (http://support.microsoft.com/kb/256986/DE/) Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn Sie die Virtualisierungsfunktion von Windows Vista verwenden, treten möglicherweise die in den folgenden Szenarios beschriebenen Probleme mit der Datei- und Registrierungsvirtualisierung auf.

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Szenario 1: Es werden Fehlermeldungen angezeigt, wenn Sie eine Anwendung installieren, aktualisieren oder verwenden

Wenn Sie eine Anwendung installieren, aktualisieren oder verwenden, können verschiedene Fehlermeldungen angezeigt werden, die besagen, dass der Zugriff verweigert wurde. Es kann zum Beispiel eines der folgenden Symptome auftreten:
?Nachdem Sie eine Anwendung in einem anderen Ordner als dem Ordner "%ProgramFiles%" installiert haben, werden "Zugriff verweigert"-Fehlermeldungen angezeigt. Außerdem kann es sein, dass die Anwendung nicht wie erwartet funktioniert.
?Es werden Anwendungsfehlermeldungen etwa folgenden Inhalts angezeigt:
Es kann kein Ordner unter C:\Anwendung\Temp erstellt werden
Es kann keine Datei unter C:\Anwendung\Temp\output.dat erstellt werden
?Es werden Fehlermeldungen etwa folgenden Inhalts angezeigt:
Fehler beim Schreiben in Dateiname.exe
Dieses Problem kann auftreten, wenn Sie eine der folgenden Aktionen durchführen:
?Sie erstellen Verknüpfungen in virtualisierte Speicherorte.
?Sie verwenden das verschlüsselnde Dateisystem (Encrypting File System, EFS), um Dateien zu verschlüsseln.
?Sie versuchen, komprimierte Dateien anzuzeigen.
?Sie verwenden die Eingabeaufforderung, um eine EXE-, SYS- oder DLL-Datei in einen virtualisierbaren Speicherort zu kopieren.
?Teile der Anwendung, die Dateieingabe oder -ausgabe erfordern, funktionieren nicht länger korrekt.

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Szenario 2: Sie können gerade erstellte Dateien oder Ordner nicht finden

Wenn Sie eine Anwendung verwenden, für die Virtualisierung aktiviert ist, erstellen Sie Datendateien in virtualisierbaren Speicherorten des Dateisystems. Wenn Sie versuchen, mit einer anderen Anwendung oder Windows Explorer auf diese neu erstellten Dateien zuzugreifen, können Sie sie nicht finden. Wenn Sie zum Beispiel eine Datei in einem Bildbearbeitungsprogramm in den Ordnern "%ProgramFiles%", "%SystemRoot%" oder "%ProgramData%" speichern, können Sie diese Datei nicht finden.

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Szenario 3: Sie aktualisieren eine Anwendung und stellen danach ein unerwartetes Programmverhalten fest

Nach dem Aktualisieren einer Anwendung wird eine Fehlermeldung etwa folgenden Inhalts angezeigt:
Fehler. Bitte aktualisieren Sie Ihre Anwendung
Außerdem funktioniert die Anwendung nicht wie erwartet. Die Anwendung scheint Daten zu verwenden, die unkorrekt sind oder zu einem Zeitpunkt vor der Aktualisierung erstellt wurden.

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Szenario 4: Nachdem Sie eine Anwendung deinstalliert haben, sind die Dateien der Anwendung immer noch auf dem Computer vorhanden

In diesem Szenario tritt eines der folgenden Symptome auf:
?In einer anderen Anwendung stellen Sie fest, dass die Datei- und Ordnerinformationen für die deinstallierte Anwendung immer noch in den Ordnern "%ProgramFiles%", "%SystemRoot%" oder "%ProgramData%" vorhanden sind.
?Der Ordner "%UserProfile%\AppData\Local\VirtualStore" ist größer als erwartet. Bei der Deinstallation der Anwendung wurden die virtualisierten Dateien, die während der Laufzeit der Anwendung erstellt wurden, nicht entfernt.

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Ursache

Diese Probleme werden durch eine oder mehrere der folgenden Bedingungen verursacht:
?Die Anwendung versucht, Dateien oder Ordner außerhalb bestimmter definierter virtualisierter Ordner zu erstellen.
?Von einer Anwendung im Ordner "%ProgramFiles%" gespeicherte Dateien werden möglicherweise an einen anderen Ordner als den Benutzerordner im virtuellen Speicher umgeleitet.
?Die Anwendung verwendet eine Datei, für die keine Virtualisierung unterstützt wird.

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Lösung

Szenario 1

Suchen Sie in der Ereignisanzeige nach FileCreateVirtualExclude-Ereignissen, um zu ermitteln, ob das in Szenario 1 beschriebene Problem vorliegt. Gehen Sie hierzu folgendermaßen vor:
1.Klicken Sie auf StartSchaltfläche Start, geben Sie eventvwr in das Feld Suche starten ein, und klicken Sie in der Liste Programme auf eventvwr.exe.

Benutzerkontensteuerung Wenn Sie zur Angabe eines Administratorkennworts oder zum Bestätigen aufgefordert werden, geben Sie Ihr Kennwort ein oder klicken Sie auf Weiter.
2.Erweitern Sie Anwendungen und Dienstprotokolle, Microsoft, Windows und UacFileVirtualization, und wählen Sie anschließend Operational. Wenn die Ereigniskennung 5000 lautet, ist ein FileCreateVirtualExclude-Ereignis aufgetreten.
Wenden Sie eine der folgenden Methoden an, um dieses Problem zu beheben:
?Installieren Sie die Anwendung im Ordner "%ProgramFiles%" neu, wenn sie nicht bereits im Ordner "%ProgramFiles%" installiert ist.
? Verwenden Sie ein Konto mit Administratorrechten, um diese Anwendung auszuführen. Suchen Sie hierzu die Verknüpfung der Anwendung, klicken Sie mit der rechten Maustaste darauf, und klicken Sie auf Als Administrator ausführen.

Benutzerkontensteuerung Wenn Sie zur Angabe eines Administratorkennworts oder zum Bestätigen aufgefordert werden, geben Sie Ihr Kennwort ein oder klicken Sie auf Weiter.
?Führen Sie die Anwendung an einer Eingabeaufforderung mit erhöhten Benutzerrechten aus. Gehen Sie hierzu folgendermaßen vor:
1.Klicken Sie auf die Schaltfläche Start Schaltfläche "Start" . Im Feld Suche starten geben Sie cmd ein. Klicken Sie dann in der Liste Programme auf cmd.exe.
2.Klicken Sie in der Liste Programme mit der rechten Maustaste auf cmd, und klicken Sie anschließend auf Als Administrator ausführen.

Benutzerkontensteuerung Wenn Sie zur Angabe eines Administratorkennworts oder zum Bestätigen aufgefordert werden, geben Sie Ihr Kennwort ein oder klicken Sie auf Weiter.
3.Geben Sie Anwendungspfad/Anwendung ein, und drücken Sie die [EINGABETASTE]. Anwendungspfad/Anwendung steht für den Pfad und den Namen der Anwendung.
?Ändern Sie die Sicherheitseinstellungen für den Ordner der Anwendung. Gehen Sie hierzu folgendermaßen vor:
1.Melden Sie sich als Benutzer mit Administratorrechten an, und verwenden Sie Windows Explorer, um den Ordner der Anwendung zu öffnen.
2.Klicken Sie mit der rechten Maustaste auf den Ordner der Anwendung, und klicken Sie auf Eigenschaften.
3.Klicken Sie auf der Registerkarte Sicherheit auf Bearbeiten.

Benutzerkontensteuerung Wenn Sie zur Angabe eines Administratorkennworts oder zum Bestätigen aufgefordert werden, geben Sie Ihr Kennwort ein oder klicken Sie auf Weiter.
4.Klicken Sie unter Gruppen- oder Benutzernamen auf Ihr Benutzerkonto.
5.Klicken Sie unter Berechtigungen für Benutzer bei den folgenden Berechtigungen auf Zulassen:
?Ändern
?Lesen & Ausführen
?Ordnerinhalt auflisten
?Lesen
?Schreiben
6.Klicken Sie auf OK.

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Szenario 2

Wenden Sie eine der folgenden Methoden an, um dieses Problem zu beheben:
?Klicken Sie auf der Explorerleiste auf die Schaltfläche Kompatibilitätsdateien, um virtualisierte Dateien in dem Ordner anzuzeigen. Die Schaltfläche Kompatibilitätsdateien erscheint nur, wenn es virtualisierte Dateien in dem Ordner gibt.
?Suchen Sie in dem Ordner "C:\Users\Benutzername\AppData\Local\VirtualStore" nach Dateien und Ordnern.
?Speichern Sie die Daten für Ihre Anwendung in einem Ordner unter Ihrem Benutzerprofil.

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Szenario 3

Warnung: Durch die falsche Bearbeitung der Registrierung mithilfe des Registrierungs-Editors oder einer anderen Methode können schwerwiegende Probleme verursacht werden. Diese Probleme können eine Neuinstallation des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungs-Editors herrühren, behoben werden können. Benutzen Sie den Registrierungs-Editor auf eigene Verantwortung.

Wenden Sie eine der folgenden Methoden an, um dieses Problem zu beheben:
?Führen Sie die Anwendung an einer Eingabeaufforderung mit erhöhten Benutzerrechten aus. Gehen Sie hierzu folgendermaßen vor:
1.Klicken Sie auf die Schaltfläche Start Schaltfläche "Start" . Im Feld Suche starten geben Sie cmd ein. Klicken Sie dann in der Liste Programme auf cmd.exe.

Benutzerkontensteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Fortsetzen.
2.Geben Sie MyAppsPath/MyApp ein, und drücken Sie die [EINGABETASTE]. MyAppsPath/MyApp steht für den Pfad und den Namen der Anwendung.
?Öffnen Sie den virtuellen Speicher, und löschen Sie die alten Datendateien der Anwendung. Öffnen Sie hierzu mit Windows Explorer den Ordner "C:\Users\Benutzername\AppData\Local\VirtualStore\Program Files\Anwendung", und löschen Sie alle Dateien, die nicht Ihre Dokumente oder Datendateien sind.
?Löschen Sie den virtuellen Speicher aus der Registrierung.

Gehen Sie folgendermaßen vor, um den virtuellen Speicher in der Registrierung zu finden und nicht benötigte Schlüssel zu löschen:
1.Klicken Sie auf StartSchaltfläche Start, geben Sie regedit in das Feld Suche starten ein, und klicken Sie in der Liste Programme auf regedit.exe.

Benutzerkontensteuerung Wenn Sie aufgefordert werden, ein Administratorkennwort oder eine Bestätigung einzugeben, geben Sie Ihr Kennwort ein, oder klicken Sie auf Fortsetzen.
2.Klicken Sie auf den folgenden Unterschlüssel in der Registrierung:
HKEY_CURRENT_USER\Software\Classes\VirtualStore
3.Klicken Sie mit der rechten Maustaste auf alle Registrierungsschlüssel der Anwendung, die nicht mehr benötigt werden, klicken Sie auf Löschen und anschließend auf Ja.

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Szenario 4

Öffnen Sie zum Beheben dieses Problems mit Windows Explorer den Ordner "C:\Users\Benutzername\AppData\Local\VirtualStore\MyApp", und löschen Sie alle nicht mehr benötigten Anwendungsdaten.

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Weitere Informationen

Die Datei- und Registrierungsvirtualisierung ermöglicht Benutzern mit eingeschränktem Zugriff auf die Registrierung und das Dateisystem, in diese geschützten Bereiche zu schreiben. Die Virtualisierung erstellt eine Kopie für jeden Benutzer, und leitet anschließende Datenoperationen entsprechend um. Nehmen Sie zum Beispiel an, dass eine Anwendung unter einem Standardbenutzerkonto oder unter Konten ausgeführt wird, die Berechtigungen über die Benutzerzugriffssteuerung erfordern. Wenn diese Anwendung in einen Systemspeicherort wie den Ordner "%ProgramFiles%" schreibt, leitet Windows Vista Schreib- und Lesevorgänge an einen benutzerspezifischen Speicherort im Benutzerprofilordner (%LocalAppData%\VirtualStore) um. Dieser Speicherort ist standardmäßig "C:\Users\Benutzername\AppData\Local\VirtualStore\Program Files\Anwendungsname". Die Registrierungsvirtualisierung funktioniert entsprechend, bezieht sich jedoch auf Registrierungsschlüssel unter der Teilstruktur HKEY_LOCAL_MACHINE\Software. Die Schlüssel und Daten unter dieser Teilstruktur werden zum Unterschlüssel HKEY_CURRENT_USER\Software\Classes\VirtualStore umgeleitet.

Weitere Informationen hierzu finden Sie auf folgender Website von Microsoft:
http://msdn2.microsoft.com/de-de/library/aa480150.aspx (http://msdn2.microsoft.com/de-de/library/aa480150.aspx)

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Die Informationen in diesem Artikel beziehen sich auf:
?Windows Vista Business
?Windows Vista Enterprise
?Windows Vista Home Premium
?Windows Vista Home Basic
?Windows Vista Ultimate
?Windows Vista Business 64-bit edition
?Windows Vista Enterprise 64-bit edition
?Windows Vista Home Premium 64-bit edition
?Windows Vista Home Basic 64-bit edition
?Windows Vista Ultimate 64-bit edition

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