Problemas comunes de archivos y registro virtualización en Windows Vista o en Windows 7

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Finalizado el soporte técnico para Windows Vista sin ningún service pack instalado de 13 de abril de 2010. Para seguir recibiendo actualizaciones de seguridad para Windows, asegúrese de que está ejecutando Windows Vista con Service Pack 2 (SP2). Para obtener más información, consulte esta página web de Microsoft: Support is ending for some versions of Windows

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Síntomas

Cuando utilice la característica de virtualización de Windows Vista o de Windows 7, es posible que el archivo de la experiencia y la virtualización del registro de los problemas que se describen en los siguientes escenarios.

Escenario 1: Se recibe mensajes de error cuando instalar, actualizar o utilizar una aplicación

Al instalar, actualizar o utilizar una aplicación, puede recibir varios mensajes de error que indican que se ha denegado el acceso. Por ejemplo, puede experimentar uno de los síntomas siguientes:
  • Después de instalar una aplicación en una carpeta distinta de la carpeta % programfiles %, recibirá mensajes de error "acceso denegado". Además, la aplicación no funciona como se esperaba.
  • Recibir mensajes de error de aplicación similar al siguiente:
    No se puede crear una carpeta bajo C:\MyApp\Temp
    No se puede crear el archivo bajo C:\MyApp\Temp\output.dat
  • Recibir mensajes de error similar al siguiente:
    Error al escribir en MyFile.exe
    Este problema puede producirse cuando realiza alguna de las acciones siguientes:
    • Crear vínculos en ubicaciones virtualizadas.
    • Utilizar el sistema de archivos cifrados (EFS) para cifrar archivos.
    • Intente ver los archivos comprimidos.
    • Utilice el símbolo del sistema para copiar un archivo .exe, .sys o archivo .dll en una ubicación virtualizable.
  • Partes de la aplicación que requieren el archivo de entrada o salida ya no funcionan correctamente.

Escenario 2: Usted no puede encontrar el archivo o la carpeta que acaba de crear

Cuando se utiliza una aplicación para el que se habilite la virtualización, crear archivos de datos en ubicaciones virtualizable del sistema de archivos. Cuando utilice otra aplicación o en el Explorador de Windows para tener acceso a estos archivos recién creados, no pueden encontrarlos. Por ejemplo, si guarda un archivo en una aplicación en % programfiles %, % systemroot %, % systemdrive % o % programdata % carpetas de edición de fotografías, no puede encontrar este archivo.

Escenario 3: Actualice una aplicación y experimentar comportamiento inesperado de programa

Después de actualizar una aplicación, recibirá un mensaje de error similar al siguiente:
Error. Actualice la aplicación
Además, la aplicación no funciona como se esperaba. La aplicación parece estar utilizando datos incorrectos o previa a la actualización.

Escenario 4: Después de desinstalar una aplicación, los archivos de la aplicación están aún presentes en el equipo

En este escenario, experimenta uno de los síntomas siguientes:
  • En otra aplicación, observe que la información de archivos y carpetas para la aplicación no instalada todavía existe en % programfiles %, % programdata %, % systemdrive % o % systemroot % carpetas.
  • La carpeta %userprofile%\AppData\Local\VirtualStore es mayor de lo esperado. Cuando desinstala la aplicación, no se quitaron los archivos virtualizados creados durante el tiempo de ejecución de la aplicación.

Causa

Estos problemas son la causa una o varias de las condiciones siguientes:
  • La aplicación intenta crear archivos o carpetas fuera de ciertas carpetas virtualizadas especificados.
  • Archivos que se guardan por una aplicación en la carpeta % programfiles % se pueden dirigir a una carpeta distinta de la carpeta de almacén virtual del usuario.
  • La aplicación utiliza un archivo que no es compatible para la virtualización.

Solución

Escenario 1

Para determinar si tiene el problema que se describe en el escenario 1, busque en el Visor de sucesos FileCreateVirtualExclude eventos. Para ello, siga estos pasos:
  1. Haga clic en Inicio
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    Start button
    , escriba eventvwr en el cuadro Iniciar búsqueda y, a continuación, haga clic en <a2>eventvwr.exe en la lista de programas.

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    User Account Control permission
    Si se le pide una contraseña de administrador o que confirme la acción, escriba su contraseña o haga clic en continuar.
  2. Expanda registros de aplicaciones y servicios, expanda Microsoft, expanda Windows, expanda UacFileVirtualization y, a continuación, seleccione operacional. Si el identificador de suceso es 5000, se ha producido un evento FileCreateVirtualExclude.
Para resolver este problema, utilice uno de los métodos siguientes:
  • Vuelva a instalar la aplicación en la carpeta % programfiles % si el programa no está ya instalado en la carpeta % programfiles %.
  • Utilice una cuenta que tenga credenciales administrativas para ejecutar esta aplicación. Para ello, busque y, a continuación, haga clic con el botón secundario del mouse en el acceso directo de la aplicación y, a continuación, haga clic en Ejecutar como administrador.

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    User Account Control permission
    Si se le pide una contraseña de administrador o que confirme la acción, escriba su contraseña o haga clic en continuar.
  • Ejecute la aplicación en un símbolo del sistema elevado. Para ello, siga estos pasos:
    1. Haga clic en Inicio,
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      Start button
      , escriba cmd en el cuadro Iniciar búsqueda y, a continuación, haga clic en cmd.exe en la lista de programas.
    2. En la lista de programas, haga clic con el botón secundario del mouse en cmd y, a continuación, haga clic en Ejecutar como administrador.

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      User Account Control permission
      Si se le pide una contraseña de administrador o que confirme la acción, escriba su contraseña o haga clic en continuar.
    3. Escriba MyAppsPath/MyApp y, a continuación, presione ENTRAR. MyAppsPath/MyApp representa la ruta de acceso y nombre de la aplicación.
  • Cambiar la configuración de seguridad en la carpeta de la aplicación. Para ello, siga estos pasos:
    1. Inicie sesión como un usuario que tenga credenciales administrativas y, a continuación, utilice el Explorador de Windows para abrir la carpeta de la aplicación.
    2. Haga clic con el botón secundario del mouse en la carpeta de la aplicación y, a continuación, haga clic en Propiedades.
    3. En la ficha seguridad, haga clic en Editar.

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      User Account Control permission
      Si se le pide una contraseña de administrador o que confirme la acción, escriba su contraseña o haga clic en continuar.
    4. En nombres de grupos o usuarios, haga clic en su cuenta de usuario.
    5. En permisos para Users, haga clic en Permitir para los permisos siguientes:
      • Modificar
      • Leer & ejecutar
      • Contenido de la carpeta de lista
      • Lectura
      • Escribir
    6. Haga clic en Aceptar.

Escenario 2

Para resolver este problema, utilice uno de los métodos siguientes:
  • Haga clic en el botón Archivos de compatibilidad que aparece en la barra de Explorer para ver los archivos virtualizados en la carpeta. El botón Archivos de compatibilidad sólo aparece si hay archivos virtualizados en la carpeta.
  • Busque en la carpeta de \AppData\Local\VirtualStore C:\Users\ User_name para buscar archivos y carpetas.
  • Guardar datos de la aplicación en una carpeta debajo de su perfil de usuario.

Escenario 3

Importante Esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de seguir estos pasos cuidadosamente. Para conseguir una protección adicional, haga una copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo realizar una copia de seguridad y restaurar el registro de Windows


Para resolver este problema, utilice uno de los métodos siguientes:
  • Ejecute la aplicación en un símbolo del sistema elevado. Para ello, siga estos pasos:
    1. Haga clic en Inicio
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      Start button
      , escriba cmd en el cuadro Iniciar búsqueda y, a continuación, haga clic en cmd.exe en la lista de programas.

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      User Account Control permission
      Si se le pide una contraseña de administrador o que confirme la acción, escriba su contraseña o haga clic en continuar.
    2. Tipo MyAppsPath/MyApp. Representa la ruta de acceso y nombre de la aplicación MyAppsPath/MyApp y, a continuación, presione ENTRAR
  • Abrir el almacén virtual y, a continuación, elimine los antiguos archivos de datos de la aplicación. Para ello, utilice el Explorador de Windows para abrir la carpeta de C:\Users\ User_name \AppData\Local\VirtualStore\Program Files\ MyApp y, a continuación, elimine los archivos que se encuentren no los documentos o archivos de datos.
  • Eliminar el almacén virtual del registro.

    Para localizar la tienda virtual en el registro y quitar cualquier clave innecesaria, siga estos pasos:
    1. Haga clic en Inicio
      Contraer esta imagenAmpliar esta imagen
      Start button
      , escriba regedit en el cuadro Iniciar búsqueda y, a continuación, haga clic en regedit.exe en la lista de programas.

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      User Account Control permission
      Si se le pide una contraseña de administrador o que confirme la acción, escriba su contraseña o haga clic en continuar.
    2. Busque y haga clic en la siguiente subclave del Registro:
      HKEY_CURRENT_USER\Software\Classes\VirtualStore
    3. Para cualquier aplicación claves del registro que ya no son necesitan, haga clic con el botón secundario del mouse en la clave, haga clic en Eliminar y, a continuación, haga clic en .

Escenario 4

Para resolver este problema, utilice el Explorador de Windows para abrir la carpeta de \AppData\Local\VirtualStore\MyApp C:\Users\ User_name y eliminar los datos de aplicación obsoleta.

Más información

Los archivos y del registro virtualización ayuda a usuarios que tienen acceso restringido para el registro y el sistema de archivos se escriben en estas áreas protegidas. Virtualización crea una copia "por usuario" y redirecciona las operaciones de datos sucesivos. Por ejemplo, suponga que una aplicación se está ejecutando bajo una cuenta de usuario limitada o bajo cuentas que requieran permisos User Account Control. Cuando esta aplicación escribe en una ubicación del sistema, como para la carpeta % programfiles %, Windows Vista y Windows 7 redirección las operaciones de escritura y las operaciones a una ubicación específica del usuario en la carpeta del perfil de usuario (% localappdata%\VirtualStore) de lectura. De forma predeterminada, esta ubicación es C:\Users\ User_name \AppData\Local\VirtualStore\Program Files\ Application_name. Virtualización del registro funciona de forma similar, pero se aplica a claves del registro bajo el subárbol HKEY_LOCAL_MACHINE\Software. Las claves y datos bajo este subárbol se redirigen a la subclave
HKEY_CURRENT_USER\Software\Classes\VirtualStore
.

Para obtener más información al respecto, visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa480150.aspx

Referencias

Para obtener ayuda con tareas comunes de mantenimiento del sistema en Windows Vista, visite la siguiente página Web de Microsoft:
Fix problems with common system maintenance tasks

Propiedades

Id. de artículo: 927387 - Última revisión: jueves, 29 de octubre de 2009 - Versión: 4.2
La información de este artículo se refiere a:
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  • Windows Vista Enterprise
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
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Haga clic aquí para ver el artículo original (en inglés): 927387

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